FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 10-30-2008, 04:34 AM
"Andrey Vul"
 
Default broken ALSA

On Thu, Oct 30, 2008 at 1:26 AM, M. Sitorus <gkjdsh@gmail.com> wrote:
> pardon me?
> here is my error:
>

> ALSA lib dlmisc.c:118snd_dlsym_verify) unable to verify version for
> symbol _snd_pcm_empty_open
> ALSA lib pcm.c:2148snd_pcm_open_conf) symbol _snd_pcm_empty_open is
> not defined inside [builtin]
That error means that the plugin empty is required yet wasn't compiled
due to being disabled.
Set your ALSA_PCM_PLUGINS to "dmix open asym"
If things still don't work, use the ALSA_PCM_PLUGINS that I supplied.
Pretty much everything except SPDIF is enabled.


--
Andrey Vul

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?
 
Old 10-30-2008, 05:53 AM
"M. Sitorus"
 
Default broken ALSA

Ok, thanks. I'll try that later. I'm not on my gentoo box right now

--
Salam,

Marc
 
Old 10-30-2008, 03:15 PM
"Andrey Vul"
 
Default broken ALSA

On Thu, Oct 30, 2008 at 2:53 AM, M. Sitorus <gkjdsh@gmail.com> wrote:
> Ok, thanks. I'll try that later. I'm not on my gentoo box right now
>
There's always SSH...

--
Andrey Vul

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?
 
Old 10-30-2008, 11:36 PM
"M. Sitorus"
 
Default broken ALSA

unfortunately, my Gentoo box is not connected to Internet ( i'm
writing this from my office )

Andrey, I've try your advice my alsa still not working.
First I try to put asym after dmix on ALSA_PCM_PLUGINS, but it still
not working. And then I run emerge -pv alsa-lib, and look at the USE
Flag. I saw empty there, so I put empty on ALSA_PCM_PLUGINS, then I
emerge alsa-lib alsa-utils mpg123 again. But the results still the
same.
I try to put open on ALSA_PCM_PLUGINS, eventhough i didn't saw that
flag on emerge -pv alsa-lib, but there is no progress. I still got the
same error with the one before.

--
Salam,

Marc
 
Old 10-31-2008, 01:40 AM
"Andrey Vul"
 
Default broken ALSA

On Thu, Oct 30, 2008 at 8:36 PM, M. Sitorus <gkjdsh@gmail.com> wrote:
> unfortunately, my Gentoo box is not connected to Internet ( i'm
> writing this from my office )
>
> Andrey, I've try your advice my alsa still not working.
> First I try to put asym after dmix on ALSA_PCM_PLUGINS, but it still
> not working. And then I run emerge -pv alsa-lib, and look at the USE
> Flag. I saw empty there, so I put empty on ALSA_PCM_PLUGINS, then I
> emerge alsa-lib alsa-utils mpg123 again. But the results still the
> same.
> I try to put open on ALSA_PCM_PLUGINS, eventhough i didn't saw that
> flag on emerge -pv alsa-lib, but there is no progress. I still got the
> same error with the one before.
>
Something's weird, because my ALSA_PCM_PLUGINS works on all 3 of my
gentoo boxes.
Did you try emerge -DN alsa-lib ?



--
Andrey Vul

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?
 
Old 10-31-2008, 03:43 AM
"M. Sitorus"
 
Default broken ALSA

no, I did emerge -v. But the asym and empty USE Flag is used on emerge

--
Salam,

Marc
 
Old 10-31-2008, 03:52 AM
"Andrey Vul"
 
Default broken ALSA

On Fri, Oct 31, 2008 at 12:43 AM, M. Sitorus <gkjdsh@gmail.com> wrote:
> no, I did emerge -v. But the asym and empty USE Flag is used on emerge
Try -DNv . Sometimes portage is blind to new USE flags / features
unless -N or --newuse is used.



--
Andrey Vul

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?
 
Old 11-03-2008, 03:00 AM
"M. Sitorus"
 
Default broken ALSA

Andrey, emerge -DNv did not work, but i managed to get alsa working.
I got the solution by adding "asound" on ALSA_PCM_PLUGINS. Thanks for
the help Andrey

--
Salam,

Marc
 

Thread Tools




All times are GMT. The time now is 07:06 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org