FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 10-22-2008, 12:06 AM
Peter Wood
 
Default Installing packages for old Python version

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,
I am trying to install Plone which depends on Python 2.4. Portage
installs Python 2.4 in a slot in addition to Python 2.5 which my system
uses as a default. Plone also depends on 2 other packages
(Python-Imaging and Python-Elementtree). However, if I emerge these they
end up in /usr/lib/python2.5/site-packages.
Is there a way to change the default python version temporarily so that
emerge merges the correct version of these packages into
/usr/lib/python/2.4/site-packages, where I need them?
Thanks for any help in advance.
- --
Peter Wood
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkj+bp8ACgkQpGFGVEw9tBnBbgCeMmBaoY9ai/uG8/l6BMSb5fW9
AvYAnRo1KFma5qgKvlzO4dxXYPxjpsDL
=zmJF
-----END PGP SIGNATURE-----
 
Old 10-22-2008, 07:35 AM
Neil Bothwick
 
Default Installing packages for old Python version

On Tue, 21 Oct 2008 20:06:55 -0400, Peter Wood wrote:

> Is there a way to change the default python version temporarily so that
> emerge merges the correct version of these packages into
> /usr/lib/python/2.4/site-packages, where I need them?

I'd try app-admin/eselect-python


--
Neil Bothwick

"Bother," said Pooh, when he found Tigger stoned on his hash
 

Thread Tools




All times are GMT. The time now is 11:27 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org