FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 10-19-2008, 02:13 PM
Mike
 
Default AutoFS with LDAP

Folks,

Has anyone used AutoFS with the automounter information coming from
LDAP?

I have a LDAP server with the necessary maps setup. I have a number of
LDAP clients on Debian successfully using this. However, I cannot get
this to work with Gentoo. When I try to start autofs I get a message
saying "failed". I have also tried starting by handing using the
automount command that is running on my Debian box, however, it just
exits. The /usr/lib/autofs/autofs-ldap-auto-master returns the correct
information. However, automounter will not start.

Mike.
 
Old 10-20-2008, 09:08 AM
"Fred Elno"
 
Default AutoFS with LDAP

Yes I also use autofs with openldap.
My setup is as this: the PDC is running on a gentoo box and provide system authentification with openldap to windows
client and also gentoo client, I also use samba for filesharing between client and server.
Because I don't want my users being able to see at other users home directory I use autofs which mount only user
logged in home directory on the client.

I am not a specialist in Openldap so I don't know if I will be able to help you, but if it can help, I can give you
this link : http://www.drakonix.fr/index.php?id=gentoo&tab=21&pid=26#t03

It point to my setup documentation and perhaps you will found usefull information.
You will also find some links to other wiki's and doc which talk about this subject.

Oh I forgot it is written in French but all the command used and file configuration are written
And excuse me for my poor English

Hope it's help

Fred

> Folks,
>
> Has anyone used AutoFS with the automounter information coming from
> LDAP?
>
> I have a LDAP server with the necessary maps setup. I have a number of
> LDAP clients on Debian successfully using this. However, I cannot get
> this to work with Gentoo. When I try to start autofs I get a message
> saying "failed". I have also tried starting by handing using the
> automount command that is running on my Debian box, however, it just
> exits. The /usr/lib/autofs/autofs-ldap-auto-master returns the correct
> information. However, automounter will not start.
>
> Mike.
>
>


http://www.drakonix.fr
 
Old 10-20-2008, 12:31 PM
Mike
 
Default AutoFS with LDAP

On Mon, Oct 20, 2008 at 11:08:42AM +0200, Fred Elno wrote:
> Yes I also use autofs with openldap.
> My setup is as this: the PDC is running on a gentoo box and provide system authentification with openldap to windows
> client and also gentoo client, I also use samba for filesharing between client and server.
> Because I don't want my users being able to see at other users home directory I use autofs which mount only user
> logged in home directory on the client.
>
> I am not a specialist in Openldap so I don't know if I will be able to help you, but if it can help, I can give you
> this link : http://www.drakonix.fr/index.php?id=gentoo&tab=21&pid=26#t03
>
> It point to my setup documentation and perhaps you will found usefull information.
> You will also find some links to other wiki's and doc which talk about this subject.
>
> Oh I forgot it is written in French but all the command used and file configuration are written
> And excuse me for my poor English
>
> Hope it's help
>
> Fred

Thanks Fred,

I think I found the answer here: "[bug on amd64 try this: $
CFLAGS="-DLDAP_DEPRECATED" emerge autofs]". It's a 64bit system, so I
will try remerging it with LDAP_DEPRECATED and see what happenes.

Mike.
 

Thread Tools




All times are GMT. The time now is 06:27 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org