FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 10-12-2008, 02:30 AM
"Alan E. Davis"
 
Default Painted into a corner: avahi and mDNSResponder

Almost perpetually, the following packages or their versions are
blocking. I have run emerge -e system several times. Some other
problems were cleared up, and this
avahi--mDNSResponder/mdnsresponder-compat whatever it all is, just
keeps coming back even when solved by some skullduggery. I've removed
both of them at one time or another.

[blocks B ] net-dns/avahi ("net-dns/avahi" is blocking
net-misc/mDNSResponder-107.6-r5)

[blocks B ] net-misc/mDNSResponder ("net-misc/mDNSResponder" is
blocking net-dns/avahi-0.6.23)

I guess the problem is that I am running gnome and also have two or
three different versions/slots of kde installed. I suppose, then,
it's remarkable that only these blocks are showing up?

Can someone lend a hand on this? Anything I do is little more than
blind tinkering.

Alan


--
Alan Davis

"It's never a matter of liking or disliking ..."
---Santa Ynez Chumash Medicine Man
 
Old 10-12-2008, 03:07 AM
"Andrey Vul"
 
Default Painted into a corner: avahi and mDNSResponder

On Sat, Oct 11, 2008 at 10:30 PM, Alan E. Davis <lngndvs@gmail.com> wrote:
> Almost perpetually, the following packages or their versions are
> blocking. I have run emerge -e system several times. Some other
> problems were cleared up, and this
> avahi--mDNSResponder/mdnsresponder-compat whatever it all is, just
> keeps coming back even when solved by some skullduggery. I've removed
> both of them at one time or another.
>
> [blocks B ] net-dns/avahi ("net-dns/avahi" is blocking
> net-misc/mDNSResponder-107.6-r5)
>
> [blocks B ] net-misc/mDNSResponder ("net-misc/mDNSResponder" is
> blocking net-dns/avahi-0.6.23)
>
> I guess the problem is that I am running gnome and also have two or
> three different versions/slots of kde installed. I suppose, then,
> it's remarkable that only these blocks are showing up?
>
> Can someone lend a hand on this? Anything I do is little more than
> blind tinkering.
>
Play around with your USE flags, you'll get it working eventually
(that's what I did).
ufed helps.

--
Andrey Vul

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?
 
Old 10-12-2008, 06:04 AM
Volker Armin Hemmann
 
Default Painted into a corner: avahi and mDNSResponder

On Sonntag 12 Oktober 2008, Alan E. Davis wrote:
> Almost perpetually, the following packages or their versions are
> blocking. I have run emerge -e system several times. Some other
> problems were cleared up, and this
> avahi--mDNSResponder/mdnsresponder-compat whatever it all is, just
> keeps coming back even when solved by some skullduggery. I've removed
> both of them at one time or another.
>
> [blocks B ] net-dns/avahi ("net-dns/avahi" is blocking
> net-misc/mDNSResponder-107.6-r5)
>
> [blocks B ] net-misc/mDNSResponder ("net-misc/mDNSResponder" is
> blocking net-dns/avahi-0.6.23)
>
> I guess the problem is that I am running gnome and also have two or
> three different versions/slots of kde installed. I suppose, then,
> it's remarkable that only these blocks are showing up?
>
> Can someone lend a hand on this? Anything I do is little more than
> blind tinkering.
>
> Alan

set the avahi useflag, unmerge mdnsresponder, emerge avahi.
 
Old 10-12-2008, 07:51 AM
Alan McKinnon
 
Default Painted into a corner: avahi and mDNSResponder

On Sunday 12 October 2008 08:04:22 Volker Armin Hemmann wrote:
> On Sonntag 12 Oktober 2008, Alan E. Davis wrote:
> > Almost perpetually, the following packages or their versions are
> > blocking. I have run emerge -e system several times. Some other
> > problems were cleared up, and this
> > avahi--mDNSResponder/mdnsresponder-compat whatever it all is, just
> > keeps coming back even when solved by some skullduggery. I've removed
> > both of them at one time or another.
> >
> > [blocks B ] net-dns/avahi ("net-dns/avahi" is blocking
> > net-misc/mDNSResponder-107.6-r5)
> >
> > [blocks B ] net-misc/mDNSResponder ("net-misc/mDNSResponder" is
> > blocking net-dns/avahi-0.6.23)
> >
> > I guess the problem is that I am running gnome and also have two or
> > three different versions/slots of kde installed. I suppose, then,
> > it's remarkable that only these blocks are showing up?
> >
> > Can someone lend a hand on this? Anything I do is little more than
> > blind tinkering.
> >
> > Alan
>
> set the avahi useflag, unmerge mdnsresponder, emerge avahi.

That looks familiar. I remember similar deep blocks myself - it was nasty at
the time.

For the OP's benefit, here's a high level summary of what is going on:

Avahi and mDNSResponder implement a system called ZeroConf, first designed by
Apple. It's a way for machines on a network to find each other and what
network features they support. These systems are quite low-level so
unfortunately the implementations are often incompatible.

By and large you will find that Gnome stuff supports Avahi and KDE stuff
supports mDNSResponder, so the only way out of this mess is often extensive
use of 'equery hasuse', 'equery depends' and 'emerge -pvt' so see what pulls
in what. But first you should research what these things are so you can make
intelligent decisions about what to include and what to drop. The thing that
cleared it up for me was an interview with the KDE team lead responsible for
these features - Google will find it for you.

Personally, I find these things more trouble than they are worth. They seem to
be designed for the "Apple Generation User" (whatever that is), and I have no
use for that on the networks I work on. ZeroConf is not necessarily something
you have to have installed...

--
alan dot mckinnon at gmail dot com
 
Old 10-12-2008, 08:25 AM
"Andrey Vul"
 
Default Painted into a corner: avahi and mDNSResponder

On Sun, Oct 12, 2008 at 3:51 AM, Alan McKinnon <alan.mckinnon@gmail.com> wrote:
> On Sunday 12 October 2008 08:04:22 Volker Armin Hemmann wrote:
>> On Sonntag 12 Oktober 2008, Alan E. Davis wrote:
>> > Almost perpetually, the following packages or their versions are
>> > blocking. I have run emerge -e system several times. Some other
>> > problems were cleared up, and this
>> > avahi--mDNSResponder/mdnsresponder-compat whatever it all is, just
>> > keeps coming back even when solved by some skullduggery. I've removed
>> > both of them at one time or another.
>> >
>> > [blocks B ] net-dns/avahi ("net-dns/avahi" is blocking
>> > net-misc/mDNSResponder-107.6-r5)
>> >
>> > [blocks B ] net-misc/mDNSResponder ("net-misc/mDNSResponder" is
>> > blocking net-dns/avahi-0.6.23)
>> >
>> > I guess the problem is that I am running gnome and also have two or
>> > three different versions/slots of kde installed. I suppose, then,
>> > it's remarkable that only these blocks are showing up?
>> >
>> > Can someone lend a hand on this? Anything I do is little more than
>> > blind tinkering.
>> >
>> > Alan
>>
>> set the avahi useflag, unmerge mdnsresponder, emerge avahi.
>
> That looks familiar. I remember similar deep blocks myself - it was nasty at
> the time.
>
> For the OP's benefit, here's a high level summary of what is going on:
>
> Avahi and mDNSResponder implement a system called ZeroConf, first designed by
> Apple. It's a way for machines on a network to find each other and what
> network features they support. These systems are quite low-level so
> unfortunately the implementations are often incompatible.
>
> By and large you will find that Gnome stuff supports Avahi and KDE stuff
> supports mDNSResponder, so the only way out of this mess is often extensive
> use of 'equery hasuse', 'equery depends' and 'emerge -pvt' so see what pulls
> in what. But first you should research what these things are so you can make
> intelligent decisions about what to include and what to drop. The thing that
> cleared it up for me was an interview with the KDE team lead responsible for
> these features - Google will find it for you.
IIRC mdnsresponder-compat USE flags allows use of avahi in KDE (3).
>
> Personally, I find these things more trouble than they are worth. They seem to
> be designed for the "Apple Generation User" (whatever that is), and I have no
> use for that on the networks I work on. ZeroConf is not necessarily something
> you have to have installed...
>
> --
> alan dot mckinnon at gmail dot com
>
>



--
Andrey Vul

A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
A: Top-posting.
Q: What is the most annoying thing in e-mail?
 
Old 10-12-2008, 08:34 AM
Alan McKinnon
 
Default Painted into a corner: avahi and mDNSResponder

On Sunday 12 October 2008 10:25:51 Andrey Vul wrote:
> On Sun, Oct 12, 2008 at 3:51 AM, Alan McKinnon <alan.mckinnon@gmail.com>
wrote:
> > On Sunday 12 October 2008 08:04:22 Volker Armin Hemmann wrote:
> >> On Sonntag 12 Oktober 2008, Alan E. Davis wrote:
> >> > Almost perpetually, the following packages or their versions are
> >> > blocking. I have run emerge -e system several times. Some other
> >> > problems were cleared up, and this
> >> > avahi--mDNSResponder/mdnsresponder-compat whatever it all is, just
> >> > keeps coming back even when solved by some skullduggery. I've removed
> >> > both of them at one time or another.
> >> >
> >> > [blocks B ] net-dns/avahi ("net-dns/avahi" is blocking
> >> > net-misc/mDNSResponder-107.6-r5)
> >> >
> >> > [blocks B ] net-misc/mDNSResponder ("net-misc/mDNSResponder" is
> >> > blocking net-dns/avahi-0.6.23)
> >> >
> >> > I guess the problem is that I am running gnome and also have two or
> >> > three different versions/slots of kde installed. I suppose, then,
> >> > it's remarkable that only these blocks are showing up?
> >> >
> >> > Can someone lend a hand on this? Anything I do is little more than
> >> > blind tinkering.
> >> >
> >> > Alan
> >>
> >> set the avahi useflag, unmerge mdnsresponder, emerge avahi.
> >
> > That looks familiar. I remember similar deep blocks myself - it was nasty
> > at the time.
> >
> > For the OP's benefit, here's a high level summary of what is going on:
> >
> > Avahi and mDNSResponder implement a system called ZeroConf, first
> > designed by Apple. It's a way for machines on a network to find each
> > other and what network features they support. These systems are quite
> > low-level so unfortunately the implementations are often incompatible.
> >
> > By and large you will find that Gnome stuff supports Avahi and KDE stuff
> > supports mDNSResponder, so the only way out of this mess is often
> > extensive use of 'equery hasuse', 'equery depends' and 'emerge -pvt' so
> > see what pulls in what. But first you should research what these things
> > are so you can make intelligent decisions about what to include and what
> > to drop. The thing that cleared it up for me was an interview with the
> > KDE team lead responsible for these features - Google will find it for
> > you.
>
> IIRC mdnsresponder-compat USE flags allows use of avahi in KDE (3).

I believe you are correct:

alan@nazgul ~ $ grep mdns /var/portage/profiles/use.*
/var/portage/profiles/use.local.desc:net-dns/avahi:mdnsresponder-compat -
Enable compat libraries for mDNSResponder




--
alan dot mckinnon at gmail dot com
 
Old 10-12-2008, 09:11 AM
Volker Armin Hemmann
 
Default Painted into a corner: avahi and mDNSResponder

On Sonntag 12 Oktober 2008, Alan McKinnon wrote:
> On Sunday 12 October 2008 10:25:51 Andrey Vul wrote:
> > On Sun, Oct 12, 2008 at 3:51 AM, Alan McKinnon <alan.mckinnon@gmail.com>
>
> wrote:
> > > On Sunday 12 October 2008 08:04:22 Volker Armin Hemmann wrote:
> > >> On Sonntag 12 Oktober 2008, Alan E. Davis wrote:
> > >> > Almost perpetually, the following packages or their versions are
> > >> > blocking. I have run emerge -e system several times. Some other
> > >> > problems were cleared up, and this
> > >> > avahi--mDNSResponder/mdnsresponder-compat whatever it all is, just
> > >> > keeps coming back even when solved by some skullduggery. I've
> > >> > removed both of them at one time or another.
> > >> >
> > >> > [blocks B ] net-dns/avahi ("net-dns/avahi" is blocking
> > >> > net-misc/mDNSResponder-107.6-r5)
> > >> >
> > >> > [blocks B ] net-misc/mDNSResponder ("net-misc/mDNSResponder" is
> > >> > blocking net-dns/avahi-0.6.23)
> > >> >
> > >> > I guess the problem is that I am running gnome and also have two or
> > >> > three different versions/slots of kde installed. I suppose, then,
> > >> > it's remarkable that only these blocks are showing up?
> > >> >
> > >> > Can someone lend a hand on this? Anything I do is little more than
> > >> > blind tinkering.
> > >> >
> > >> > Alan
> > >>
> > >> set the avahi useflag, unmerge mdnsresponder, emerge avahi.
> > >
> > > That looks familiar. I remember similar deep blocks myself - it was
> > > nasty at the time.
> > >
> > > For the OP's benefit, here's a high level summary of what is going on:
> > >
> > > Avahi and mDNSResponder implement a system called ZeroConf, first
> > > designed by Apple. It's a way for machines on a network to find each
> > > other and what network features they support. These systems are quite
> > > low-level so unfortunately the implementations are often incompatible.
> > >
> > > By and large you will find that Gnome stuff supports Avahi and KDE
> > > stuff supports mDNSResponder, so the only way out of this mess is often
> > > extensive use of 'equery hasuse', 'equery depends' and 'emerge -pvt' so
> > > see what pulls in what. But first you should research what these things
> > > are so you can make intelligent decisions about what to include and
> > > what to drop. The thing that cleared it up for me was an interview with
> > > the KDE team lead responsible for these features - Google will find it
> > > for you.
> >
> > IIRC mdnsresponder-compat USE flags allows use of avahi in KDE (3).
>
> I believe you are correct:
>
> alan@nazgul ~ $ grep mdns /var/portage/profiles/use.*
> /var/portage/profiles/use.local.desc:net-dns/avahi:mdnsresponder-compat -
> Enable compat libraries for mDNSResponder

just grep for avahi in /usr/portage/kde-base ....
 

Thread Tools




All times are GMT. The time now is 01:37 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org