FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 10-07-2008, 11:25 PM
David Wei
 
Default common user has problem with opengl

Hi
I successfully emerged the x11-drivers/nvidia-drivers package and update the xorg.conf file as below:

......
Load "glx"
......
Section "Device"
#VideoRam 262144
# Insert Clocks lines here if appropriate
Identifier "My Video Card"
Driver "nvidia"
EndSection
......

I put my user in the video group and i can see the Nvidia logo when I starte the X,but opengl still seems not work(I get this idea from the glxinfo).I will attach the Xorg log below. Any idea what I can do?
Thank you!


X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: UNKNOWN
Current Operating System: Linux gfl 2.6.25-gentoo-r7 #3 SMP Wed Oct 1 00:41:34 KST 2008 i686
Build Date: 01 October 2008
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Oct 8 08:23:27 2008
(==) Using config file: "/etc/X11/xorg.conf"
(==) ServerLayout "Simple Layout"
(**) |-->Screen "Screen0" (0)
(**) | |-->Monitor "Monitor0"
(**) | |-->Device "Videocard0"
(**) |-->Input Device "Mouse1"
(**) |-->Input Device "Keyboard1"
(WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
Entry deleted from font path.
(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
(**) FontPath set to:
/usr/share/fonts/misc/,
/usr/share/fonts/75dpi/
(==) RgbPath set to "/usr/share/X11/rgb"
(==) ModulePath set to "/usr/lib/xorg/modules"
(**) Option "Xinerama" "0"
(WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
(II) No APM support in BIOS or kernel
(II) Loader magic: 0x81e75c0
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.3
X.Org Video Driver: 1.2
X.Org XInput driver : 0.7
X.Org Server Extension : 0.3
X.Org Font Renderer : 0.5
(II) Loader running on linux
(II) LoadModule: "pcidata"
(II) Loading /usr/lib/xorg/modules//libpcidata.so
(II) Module pcidata: vendor="X.Org Foundation"
compiled for 1.3.0, module version = 1.0.0
ABI class: X.Org Video Driver, version 1.2
(--) using VT number 7

(II) PCI: PCI scan (all values are in hex)
(II) PCI: 00:00:0: chip 10de,02f0 card 103c,30b5 rev a2 class 05,00,00 hdr 80
(II) PCI: 00:00:1: chip 10de,02fa card 103c,30b5 rev a2 class 05,00,00 hdr 80
(II) PCI: 00:00:2: chip 10de,02fe card 103c,30b5 rev a2 class 05,00,00 hdr 80
(II) PCI: 00:00:3: chip 10de,02f8 card 103c,30b5 rev a2 class 05,00,00 hdr 80
(II) PCI: 00:00:4: chip 10de,02f9 card 103c,30b5 rev a2 class 05,00,00 hdr 00
(II) PCI: 00:00:5: chip 10de,02ff card 103c,30b5 rev a2 class 05,00,00 hdr 80
(II) PCI: 00:00:6: chip 10de,027f card 103c,30b5 rev a2 class 05,00,00 hdr 80
(II) PCI: 00:00:7: chip 10de,027e card 103c,30b5 rev a2 class 05,00,00 hdr 80
(II) PCI: 00:02:0: chip 10de,02fc card 0000,0000 rev a1 class 06,04,00 hdr 01
(II) PCI: 00:03:0: chip 10de,02fd card 0000,0000 rev a1 class 06,04,00 hdr 01
(II) PCI: 00:05:0: chip 10de,0244 card 103c,30b5 rev a2 class 03,00,00 hdr 00
(II) PCI: 00:09:0: chip 10de,0270 card 103c,30b5 rev a2 class 05,00,00 hdr 00
(II) PCI: 00:0a:0: chip 10de,0260 card 103c,30b5 rev a3 class 06,01,00 hdr 80
(II) PCI: 00:0a:1: chip 10de,0264 card 103c,30b5 rev a3 class 0c,05,00 hdr 80
(II) PCI: 00:0a:3: chip 10de,0271 card 103c,30b5 rev a3 class 0b,40,00 hdr 80
(II) PCI: 00:0b:0: chip 10de,026d card 103c,30b5 rev a3 class 0c,03,10 hdr 80
(II) PCI: 00:0b:1: chip 10de,026e card 103c,30b5 rev a3 class 0c,03,20 hdr 80
(II) PCI: 00:0d:0: chip 10de,0265 card 103c,30b5 rev f1 class 01,01,8a hdr 00
(II) PCI: 00:0e:0: chip 10de,0266 card 103c,30b5 rev f1 class 01,01,85 hdr 00
(II) PCI: 00:10:0: chip 10de,026f card 0000,0000 rev a2 class 06,04,01 hdr 81
(II) PCI: 00:10:1: chip 10de,026c card 103c,30b5 rev a2 class 04,03,00 hdr 80
(II) PCI: 00:14:0: chip 10de,0269 card 103c,30b5 rev a3 class 06,80,00 hdr 00
(II) PCI: 00:18:0: chip 1022,1100 card 0000,0000 rev 00 class 06,00,00 hdr 80
(II) PCI: 00:18:1: chip 1022,1101 card 0000,0000 rev 00 class 06,00,00 hdr 80
(II) PCI: 00:18:2: chip 1022,1102 card 0000,0000 rev 00 class 06,00,00 hdr 80
(II) PCI: 00:18:3: chip 1022,1103 card 0000,0000 rev 00 class 06,00,00 hdr 80
(II) PCI: 01:00:0: chip 14e4,4312 card 103c,1361 rev 01 class 02,80,00 hdr 00
(II) PCI: End of PCI scan
(II) PCI-to-PCI bridge:
(II) Bus 1: bridge is at (0:2:0), (0,1,1), BCTRL: 0x0004 (VGA_EN is cleared)
(II) Bus 1 non-prefetchable memory range:
[0] -1 0 0xc3000000 - 0xc30fffff (0x100000) MX[b]
(II) PCI-to-PCI bridge:
(II) Bus 2: bridge is at (0:3:0), (0,2,2), BCTRL: 0x0004 (VGA_EN is cleared)
(II) Bus 2 I/O range:
[0] -1 0 0x00004000 - 0x000040ff (0x100) IX[b]
[1] -1 0 0x00004400 - 0x000044ff (0x100) IX[b]
[2] -1 0 0x00004800 - 0x000048ff (0x100) IX[b]
[3] -1 0 0x00004c00 - 0x00004cff (0x100) IX[b]
(II) Bus 2 non-prefetchable memory range:
[0] -1 0 0xc8000000 - 0xc87fffff (0x800000) MX[b]
(II) PCI-to-ISA bridge:
(II) Bus -1: bridge is at (0:10:0), (0,-1,-1), BCTRL: 0x0008 (VGA_EN is set)
(II) Subtractive PCI-to-PCI bridge:
(II) Bus 3: bridge is at (0:16:0), (0,3,3), BCTRL: 0x0204 (VGA_EN is cleared)
(II) Host-to-PCI bridge:
(II) Bus 0: bridge is at (0:24:0), (0,0,3), BCTRL: 0x0008 (VGA_EN is set)
(II) Bus 0 I/O range:
[0] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) Bus 0 non-prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
(II) Bus 0 prefetchable memory range:
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
(--) PCI:*(0:5:0) nVidia Corporation C51 PCI Express Bridge rev 162, Mem @ 0xc2000000/24, 0xd0000000/28, 0xc1000000/24
(--) PCI: (0:10:3) nVidia Corporation MCP51 PMU rev 163, Mem @ 0xc0040000/18
(II) Addressable bus resource ranges are
[0] -1 0 0x00000000 - 0xffffffff (0x0) MX[b]
[1] -1 0 0x00000000 - 0x0000ffff (0x10000) IX[b]
(II) OS-reported resource ranges:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[5] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
(II) Active PCI resource ranges:
[0] -1 0 0xc3000000 - 0xc3003fff (0x4000) MX[b]
[1] -1 0 0xc0007000 - 0xc0007fff (0x1000) MX[b]
[2] -1 0 0xc0000000 - 0xc0003fff (0x4000) MX[b]
[3] -1 0 0xc0006000 - 0xc0006fff (0x1000) MX[b]
[4] -1 0 0xc0005000 - 0xc00050ff (0x100) MX[b]
[5] -1 0 0xc0004000 - 0xc0004fff (0x1000) MX[b]
[6] -1 0 0xc0040000 - 0xc007ffff (0x40000) MX[b]
[7] -1 0 0xc1000000 - 0xc1ffffff (0x1000000) MX[b](B)
[8] -1 0 0xd0000000 - 0xdfffffff (0x10000000) MX[b](B)
[9] -1 0 0xc2000000 - 0xc2ffffff (0x1000000) MX[b](B)
[10] -1 0 0x000030b8 - 0x000030bf (0x8) IX[b]
[11] -1 0 0x00003090 - 0x0000309f (0x10) IX[b]
[12] -1 0 0x000030a0 - 0x000030a3 (0x4) IX[b]
[13] -1 0 0x000030a8 - 0x000030af (0x8) IX[b]
[14] -1 0 0x000030a4 - 0x000030a7 (0x4) IX[b]
[15] -1 0 0x000030b0 - 0x000030b7 (0x8) IX[b]
[16] -1 0 0x00003080 - 0x0000308f (0x10) IX[b]
[17] -1 0 0x00003000 - 0x0000303f (0x40) IX[b]
[18] -1 0 0x00003040 - 0x0000307f (0x40) IX[b]
(II) Active PCI resource ranges after removing overlaps:
[0] -1 0 0xc3000000 - 0xc3003fff (0x4000) MX[b]
[1] -1 0 0xc0007000 - 0xc0007fff (0x1000) MX[b]
[2] -1 0 0xc0000000 - 0xc0003fff (0x4000) MX[b]
[3] -1 0 0xc0006000 - 0xc0006fff (0x1000) MX[b]
[4] -1 0 0xc0005000 - 0xc00050ff (0x100) MX[b]
[5] -1 0 0xc0004000 - 0xc0004fff (0x1000) MX[b]
[6] -1 0 0xc0040000 - 0xc007ffff (0x40000) MX[b]
[7] -1 0 0xc1000000 - 0xc1ffffff (0x1000000) MX[b](B)
[8] -1 0 0xd0000000 - 0xdfffffff (0x10000000) MX[b](B)
[9] -1 0 0xc2000000 - 0xc2ffffff (0x1000000) MX[b](B)
[10] -1 0 0x000030b8 - 0x000030bf (0x8) IX[b]
[11] -1 0 0x00003090 - 0x0000309f (0x10) IX[b]
[12] -1 0 0x000030a0 - 0x000030a3 (0x4) IX[b]
[13] -1 0 0x000030a8 - 0x000030af (0x8) IX[b]
[14] -1 0 0x000030a4 - 0x000030a7 (0x4) IX[b]
[15] -1 0 0x000030b0 - 0x000030b7 (0x8) IX[b]
[16] -1 0 0x00003080 - 0x0000308f (0x10) IX[b]
[17] -1 0 0x00003000 - 0x0000303f (0x40) IX[b]
[18] -1 0 0x00003040 - 0x0000307f (0x40) IX[b]
(II) OS-reported resource ranges after removing overlaps with PCI:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[5] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
(II) All system resource ranges:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0xc3000000 - 0xc3003fff (0x4000) MX[b]
[5] -1 0 0xc0007000 - 0xc0007fff (0x1000) MX[b]
[6] -1 0 0xc0000000 - 0xc0003fff (0x4000) MX[b]
[7] -1 0 0xc0006000 - 0xc0006fff (0x1000) MX[b]
[8] -1 0 0xc0005000 - 0xc00050ff (0x100) MX[b]
[9] -1 0 0xc0004000 - 0xc0004fff (0x1000) MX[b]
[10] -1 0 0xc0040000 - 0xc007ffff (0x40000) MX[b]
[11] -1 0 0xc1000000 - 0xc1ffffff (0x1000000) MX[b](B)
[12] -1 0 0xd0000000 - 0xdfffffff (0x10000000) MX[b](B)
[13] -1 0 0xc2000000 - 0xc2ffffff (0x1000000) MX[b](B)
[14] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[15] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[16] -1 0 0x000030b8 - 0x000030bf (0x8) IX[b]
[17] -1 0 0x00003090 - 0x0000309f (0x10) IX[b]
[18] -1 0 0x000030a0 - 0x000030a3 (0x4) IX[b]
[19] -1 0 0x000030a8 - 0x000030af (0x8) IX[b]
[20] -1 0 0x000030a4 - 0x000030a7 (0x4) IX[b]
[21] -1 0 0x000030b0 - 0x000030b7 (0x8) IX[b]
[22] -1 0 0x00003080 - 0x0000308f (0x10) IX[b]
[23] -1 0 0x00003000 - 0x0000303f (0x40) IX[b]
[24] -1 0 0x00003040 - 0x0000307f (0x40) IX[b]
(II) LoadModule: "dbe"
(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so
(II) Module dbe: vendor="X.Org Foundation"
compiled for 1.3.0, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.3
(II) Loading extension DOUBLE-BUFFER
(II) LoadModule: "extmod"
(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so
(II) Module extmod: vendor="X.Org Foundation"
compiled for 1.3.0, module version = 1.0.0
Module class: X.Org Server Extension
ABI class: X.Org Server Extension, version 0.3
(II) Loading extension SHAPE
(II) Loading extension MIT-SUNDRY-NONSTANDARD
(II) Loading extension BIG-REQUESTS
(II) Loading extension SYNC
(II) Loading extension MIT-SCREEN-SAVER
(II) Loading extension XC-MISC
(II) Loading extension XFree86-VidModeExtension
(II) Loading extension XFree86-Misc
(II) Loading extension DPMS
(II) Loading extension TOG-CUP
(II) Loading extension Extended-Visual-Information
(II) Loading extension XVideo
(II) Loading extension XVideo-MotionCompensation
(II) Loading extension X-Resource
(II) LoadModule: "freetype"
(II) Loading /usr/lib/xorg/modules/fonts//libfreetype.so
(II) Module freetype: vendor="X.Org Foundation & the After X-TT Project"
compiled for 1.3.0, module version = 2.1.0
Module class: X.Org Font Renderer
ABI class: X.Org Font Renderer, version 0.5
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/lib/xorg/modules/extensions//libglx.so
(II) Module glx: vendor="X.Org Foundation"
compiled for 1.3.0, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.3
(==) AIGLX enabled
(II) Loading extension GLX
(II) LoadModule: "nvidia"
(II) Loading /usr/lib/xorg/modules/drivers//nvidia_drv.so
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.0
Module class: X.Org Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/lib/xorg/modules/input//mouse_drv.so
(II) Module mouse: vendor="X.Org Foundation"
compiled for 1.3.0, module version = 1.2.3
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.7
(II) LoadModule: "kbd"
(II) Loading /usr/lib/xorg/modules/input//kbd_drv.so
(II) Module kbd: vendor="X.Org Foundation"
compiled for 1.3.0, module version = 1.1.0
Module class: X.Org XInput Driver
ABI class: X.Org XInput driver, version 0.7
(II) NVIDIA dlloader X Driver 173.14.09 Wed Jun 4 23:47:25 PDT 2008
(II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
(II) Primary Device is: PCI 00:05:0
(--) Assigning device section with no busID to primary device
(WW) NVIDIA: No matching Device section for instance (BusID PCI:0:10:3) found
(--) Chipset NVIDIA GPU found
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/lib/xorg/modules//libfb.so
(II) Module fb: vendor="X.Org Foundation"
compiled for 1.3.0, module version = 1.0.0
ABI class: X.Org ANSI C Emulation, version 0.3
(II) Loading sub module "wfb"
(II) LoadModule: "wfb"
(WW) Warning, couldn't open module wfb
(II) UnloadModule: "wfb"
(EE) Failed to load module "wfb" (module does not exist, 0)
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"(II) Module already built-in
(II) resource ranges after xf86ClaimFixedResources() call:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0xc3000000 - 0xc3003fff (0x4000) MX[b]
[5] -1 0 0xc0007000 - 0xc0007fff (0x1000) MX[b]
[6] -1 0 0xc0000000 - 0xc0003fff (0x4000) MX[b]
[7] -1 0 0xc0006000 - 0xc0006fff (0x1000) MX[b]
[8] -1 0 0xc0005000 - 0xc00050ff (0x100) MX[b]
[9] -1 0 0xc0004000 - 0xc0004fff (0x1000) MX[b]
[10] -1 0 0xc0040000 - 0xc007ffff (0x40000) MX[b]
[11] -1 0 0xc1000000 - 0xc1ffffff (0x1000000) MX[b](B)
[12] -1 0 0xd0000000 - 0xdfffffff (0x10000000) MX[b](B)
[13] -1 0 0xc2000000 - 0xc2ffffff (0x1000000) MX[b](B)
[14] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[15] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[16] -1 0 0x000030b8 - 0x000030bf (0x8) IX[b]
[17] -1 0 0x00003090 - 0x0000309f (0x10) IX[b]
[18] -1 0 0x000030a0 - 0x000030a3 (0x4) IX[b]
[19] -1 0 0x000030a8 - 0x000030af (0x8) IX[b]
[20] -1 0 0x000030a4 - 0x000030a7 (0x4) IX[b]
[21] -1 0 0x000030b0 - 0x000030b7 (0x8) IX[b]
[22] -1 0 0x00003080 - 0x0000308f (0x10) IX[b]
[23] -1 0 0x00003000 - 0x0000303f (0x40) IX[b]
[24] -1 0 0x00003040 - 0x0000307f (0x40) IX[b]
(II) resource ranges after probing:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0xc3000000 - 0xc3003fff (0x4000) MX[b]
[5] -1 0 0xc0007000 - 0xc0007fff (0x1000) MX[b]
[6] -1 0 0xc0000000 - 0xc0003fff (0x4000) MX[b]
[7] -1 0 0xc0006000 - 0xc0006fff (0x1000) MX[b]
[8] -1 0 0xc0005000 - 0xc00050ff (0x100) MX[b]
[9] -1 0 0xc0004000 - 0xc0004fff (0x1000) MX[b]
[10] -1 0 0xc0040000 - 0xc007ffff (0x40000) MX[b]
[11] -1 0 0xc1000000 - 0xc1ffffff (0x1000000) MX[b](B)
[12] -1 0 0xd0000000 - 0xdfffffff (0x10000000) MX[b](B)
[13] -1 0 0xc2000000 - 0xc2ffffff (0x1000000) MX[b](B)
[14] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b]
[15] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b]
[16] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b]
[17] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[18] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[19] -1 0 0x000030b8 - 0x000030bf (0x8) IX[b]
[20] -1 0 0x00003090 - 0x0000309f (0x10) IX[b]
[21] -1 0 0x000030a0 - 0x000030a3 (0x4) IX[b]
[22] -1 0 0x000030a8 - 0x000030af (0x8) IX[b]
[23] -1 0 0x000030a4 - 0x000030a7 (0x4) IX[b]
[24] -1 0 0x000030b0 - 0x000030b7 (0x8) IX[b]
[25] -1 0 0x00003080 - 0x0000308f (0x10) IX[b]
[26] -1 0 0x00003000 - 0x0000303f (0x40) IX[b]
[27] -1 0 0x00003040 - 0x0000307f (0x40) IX[b]
[28] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b]
[29] 0 0 0x000003c0 - 0x000003df (0x20) IS[b]
(II) Setting vga for screen 0.
(II) NVIDIA(0): Creating default Display subsection in Screen section
"Screen0" for depth/fbbpp 24/32
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Option "TwinView" "1"
(**) NVIDIA(0): Option "MetaModes" "CRT: 1280x768 +0+32, DFP: 1280x800 +1280+0;"
(**) NVIDIA(0): Enabling RENDER acceleration
(**) NVIDIA(0): TwinView enabled
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0): log file that the GLX module has been loaded in your X
(EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
(EE) NVIDIA(0): you continue to encounter problems, Please try
(EE) NVIDIA(0): reinstalling the NVIDIA driver.
(II) NVIDIA(0): NVIDIA GPU GeForce Go 6150 (C51) at PCI:0:5:0 (GPU-0)
(--) NVIDIA(0): Memory: 262144 kBytes
(--) NVIDIA(0): VideoBIOS: 05.51.28.39.30
(--) NVIDIA(0): Interlaced video modes are supported on this GPU
(--) NVIDIA(0): Connected display device(s) on GeForce Go 6150 at PCI:0:5:0:
(--) NVIDIA(0): LG TV (CRT-0)
(--) NVIDIA(0): CMO (DFP-0)
(--) NVIDIA(0): LG TV (CRT-0): 350.0 MHz maximum pixel clock
(--) NVIDIA(0): CMO (DFP-0): 310.0 MHz maximum pixel clock
(--) NVIDIA(0): CMO (DFP-0): Internal Dual Link LVDS
(II) NVIDIA(0): Display Devices found referenced in MetaMode: CRT-0, DFP-0
(II) NVIDIA(0): Assigned Display Devices: CRT-0, DFP-0
(II) NVIDIA(0): Validated modes:
(II) NVIDIA(0): "CRT:1280x768+0+32,DFP:1280x800+1280+0"
(II) NVIDIA(0): Virtual screen size determined to be 2560 x 800
(--) NVIDIA(0): DPI set to (63, 67); computed from "UseEdidDpi" X config
(--) NVIDIA(0): option
(==) NVIDIA(0): Disabling 32-bit ARGB GLX visuals.
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
[0] -1 0 0x00100000 - 0x3fffffff (0x3ff00000) MX[b]E(B)
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX[b]
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX[b]
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX[b]
[4] -1 0 0xc3000000 - 0xc3003fff (0x4000) MX[b]
[5] -1 0 0xc0007000 - 0xc0007fff (0x1000) MX[b]
[6] -1 0 0xc0000000 - 0xc0003fff (0x4000) MX[b]
[7] -1 0 0xc0006000 - 0xc0006fff (0x1000) MX[b]
[8] -1 0 0xc0005000 - 0xc00050ff (0x100) MX[b]
[9] -1 0 0xc0004000 - 0xc0004fff (0x1000) MX[b]
[10] -1 0 0xc0040000 - 0xc007ffff (0x40000) MX[b]
[11] -1 0 0xc1000000 - 0xc1ffffff (0x1000000) MX[b](B)
[12] -1 0 0xd0000000 - 0xdfffffff (0x10000000) MX[b](B)
[13] -1 0 0xc2000000 - 0xc2ffffff (0x1000000) MX[b](B)
[14] 0 0 0x000a0000 - 0x000affff (0x10000) MS[b]
[15] 0 0 0x000b0000 - 0x000b7fff (0x8000) MS[b]
[16] 0 0 0x000b8000 - 0x000bffff (0x8000) MS[b]
[17] -1 0 0x0000ffff - 0x0000ffff (0x1) IX[b]
[18] -1 0 0x00000000 - 0x000000ff (0x100) IX[b]
[19] -1 0 0x000030b8 - 0x000030bf (0x8) IX[b]
[20] -1 0 0x00003090 - 0x0000309f (0x10) IX[b]
[21] -1 0 0x000030a0 - 0x000030a3 (0x4) IX[b]
[22] -1 0 0x000030a8 - 0x000030af (0x8) IX[b]
[23] -1 0 0x000030a4 - 0x000030a7 (0x4) IX[b]
[24] -1 0 0x000030b0 - 0x000030b7 (0x8) IX[b]
[25] -1 0 0x00003080 - 0x0000308f (0x10) IX[b]
[26] -1 0 0x00003000 - 0x0000303f (0x40) IX[b]
[27] -1 0 0x00003040 - 0x0000307f (0x40) IX[b]
[28] 0 0 0x000003b0 - 0x000003bb (0xc) IS[b]
[29] 0 0 0x000003c0 - 0x000003df (0x20) IS[b]
(II) NVIDIA(0): Initialized GPU GART.
(II) NVIDIA(0): Unable to connect to the ACPI daemon; the ACPI daemon may not
(II) NVIDIA(0): be running or the "AcpidSocketPath" X configuration option
(II) NVIDIA(0): may not be set correctly. When the ACPI daemon is
(II) NVIDIA(0): available, the NVIDIA X driver can use it to receive ACPI
(II) NVIDIA(0): events. For details, please see the "ConnectToAcpid" and
(II) NVIDIA(0): "AcpidSocketPath" X configuration options in Appendix B: X
(II) NVIDIA(0): Config Options in the README.
(II) NVIDIA(0): Setting mode "CRT:1280x768+0+32,DFP:1280x800+1280+0"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) Loading extension NV-CONTROL
(II) Loading extension XINERAMA
(==) RandR enabled
(II) Setting vga for screen 0.
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension XAccessControlExtension
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFIXES
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(EE) AIGLX: DRI module not loaded
(II) Loading local sub module "GLcore"
(II) LoadModule: "GLcore"
(II) Loading /usr/lib/xorg/modules/extensions//libGLcore.so
(II) Module GLcore: vendor="X.Org Foundation"
compiled for 1.3.0, module version = 1.0.0
ABI class: X.Org Server Extension, version 0.3
(II) GLX: Initialized MESA-PROXY GL provider for screen 0
(**) Option "Protocol" "Auto"
(**) Mouse1: Device: "/dev/input/mice"
(**) Mouse1: Protocol: "Auto"
(**) Option "CorePointer"
(**) Mouse1: Core Pointer
(**) Option "Device" "/dev/input/mice"
(==) Mouse1: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5 6 7"
(**) Mouse1: ZAxisMapping: buttons 4, 5, 6 and 7
(**) Mouse1: Buttons: 11
(**) Mouse1: Sensitivity: 1
(**) Option "CoreKeyboard"
(**) Keyboard1: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard1: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) Keyboard1: XkbRules: "xorg"
(**) Option "XkbModel" "pc101"
(**) Keyboard1: XkbModel: "pc101"
(**) Option "XkbLayout" "us"
(**) Keyboard1: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) Keyboard1: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard1" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse1" (type: MOUSE)
(--) Mouse1: PnP-detected protocol: "ExplorerPS/2"
(II) Mouse1: ps2EnableDataReporting: succeeded
FreeFontPath: FPE "/usr/share/fonts/misc/" refcount is 2, should be 1; fixing.


-------------------------------
*亮 David Wei

您可以通过下面的方式和我联系:
MSN: inadavid@hotmail.com
Gtalk: inadavid@gmail.com
Email: davidwei@newbread.tj.cn
 
Old 10-07-2008, 11:52 PM
Dale
 
Default common user has problem with opengl

David Wei wrote:
> Hi
> I successfully emerged the x11-drivers/nvidia-drivers package and update the xorg.conf file as below:
>
> < <SNIP >>
> (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
> (EE) NVIDIA(0): log file that the GLX module has been loaded in your X
> (EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
> (EE) NVIDIA(0): you continue to encounter problems, Please try
> (EE) NVIDIA(0): reinstalling the NVIDIA driver.
>
> < SNIP >
> -------------------------------
> *亮 David Wei
>
> 您可以通过下面的方式和我联系:
> MSN: inadavid@hotmail.com
> Gtalk: inadavid@gmail.com
> Email: davidwei@newbread.tj.cn
>
>
>

I couldn't help but notice that part. Below is my xorg.conf file. You
may want to compare mine to yours and check what is different.



# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder3) Fri Jan 11
15:05:59 PST 2008

# ************************************************** ********************
# Server flags section. This contains various server-wide Options.
# ************************************************** ********************
#Section "dri"
# Group "graphics"
# Mode 0660
#EndSection

Section "ServerLayout"
Identifier "X.org Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
FontPath "/usr/share/fonts/misc"
FontPath "/usr/share/fonts/75dpi"
FontPath "/usr/share/fonts/100dpi"
FontPath "/usr/share/fonts/TTF"
FontPath "/usr/share/fonts/Type1"
EndSection

Section "Module"
Load "glx"
Load "extmod"
Load "xtrap"
Load "record"
Load "dbe"
Load "freetype"
Load "type1"
EndSection

Section "ServerFlags"

# Option "OffTime" "10"
Option "BlankTime" "5"
Option "StandbyTime" "10"
# Option "SuspendTime" "10"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/input/mouse0"
Option "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Monitor Model"
Option "dpms"
EndSection

Section "Device"
Identifier "Card0"
Driver "nvidia"
VendorName "nVidia Corporation"
BoardName "NV34 [GeForce FX 5200]"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Card0"
Monitor "Monitor0"
Option "DPMS" "TRUE"
SubSection "Display"
Viewport 0 0
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 4
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 8
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 15
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 16
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1280x1024" "1024x768" "800x600"
EndSubSection
EndSection



Please note, I am NOT saying you should replace yours with mine. Just
look to see what differences may help with yours. Maybe something is
commented out that shouldn't be or something should be commented out
that isn't.

Hope that helps.

Dale

:-) :-)
 
Old 10-08-2008, 12:27 AM
David Wei
 
Default common user has problem with opengl

Hi,
Thanks for the reply,I also notice the error part about the glx module in the Xorg.log file,and I tried to reinstall the nvidia-drivers package,but the problem still remains.
After checking your xorg.conf file,I think the only difference that can cause my problem is in <Section "Module"> part. I tried to load dbe and other modules you mentioned,but still,nvidia showed this error message.
Any other ideas? Thank you very much!

On Tue, 07 Oct 2008 18:52:07 -0500
Dale <rdalek1967@gmail.com> wrote:

> David Wei wrote:
> > Hi
> > I successfully emerged the x11-drivers/nvidia-drivers package and update the xorg.conf file as below:
> >
> > < <SNIP >>
> > (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
> > (EE) NVIDIA(0): log file that the GLX module has been loaded in your X
> > (EE) NVIDIA(0): server, and that the module is the NVIDIA GLX module. If
> > (EE) NVIDIA(0): you continue to encounter problems, Please try
> > (EE) NVIDIA(0): reinstalling the NVIDIA driver.
> >
> > < SNIP >
> > -------------------------------
> > *亮 David Wei
> >
> > 您可以通过下面的方式和我联系:
> > MSN: inadavid@hotmail.com
> > Gtalk: inadavid@gmail.com
> > Email: davidwei@newbread.tj.cn
> >
> >
> >
>
> I couldn't help but notice that part. Below is my xorg.conf file. You
> may want to compare mine to yours and check what is different.
>
>
>
> # nvidia-xconfig: X configuration file generated by nvidia-xconfig
> # nvidia-xconfig: version 1.0 (buildmeister@builder3) Fri Jan 11
> 15:05:59 PST 2008
>
> # ************************************************** ********************
> # Server flags section. This contains various server-wide Options.
> # ************************************************** ********************
> #Section "dri"
> # Group "graphics"
> # Mode 0660
> #EndSection
>
> Section "ServerLayout"
> Identifier "X.org Configured"
> Screen 0 "Screen0" 0 0
> InputDevice "Mouse0" "CorePointer"
> InputDevice "Keyboard0" "CoreKeyboard"
> EndSection
>
> Section "Files"
> FontPath "/usr/share/fonts/misc"
> FontPath "/usr/share/fonts/75dpi"
> FontPath "/usr/share/fonts/100dpi"
> FontPath "/usr/share/fonts/TTF"
> FontPath "/usr/share/fonts/Type1"
> EndSection
>
> Section "Module"
> Load "glx"
> Load "extmod"
> Load "xtrap"
> Load "record"
> Load "dbe"
> Load "freetype"
> Load "type1"
> EndSection
>
> Section "ServerFlags"
>
> # Option "OffTime" "10"
> Option "BlankTime" "5"
> Option "StandbyTime" "10"
> # Option "SuspendTime" "10"
> EndSection
>
> Section "InputDevice"
> Identifier "Keyboard0"
> Driver "kbd"
> EndSection
>
> Section "InputDevice"
> Identifier "Mouse0"
> Driver "mouse"
> Option "Protocol" "auto"
> Option "Device" "/dev/input/mouse0"
> Option "ZAxisMapping" "4 5 6 7"
> EndSection
>
> Section "Monitor"
> Identifier "Monitor0"
> VendorName "Monitor Vendor"
> ModelName "Monitor Model"
> Option "dpms"
> EndSection
>
> Section "Device"
> Identifier "Card0"
> Driver "nvidia"
> VendorName "nVidia Corporation"
> BoardName "NV34 [GeForce FX 5200]"
> EndSection
>
> Section "Screen"
> Identifier "Screen0"
> Device "Card0"
> Monitor "Monitor0"
> Option "DPMS" "TRUE"
> SubSection "Display"
> Viewport 0 0
> Modes "1280x1024" "1024x768" "800x600"
> EndSubSection
> SubSection "Display"
> Viewport 0 0
> Depth 4
> Modes "1280x1024" "1024x768" "800x600"
> EndSubSection
> SubSection "Display"
> Viewport 0 0
> Depth 8
> Modes "1280x1024" "1024x768" "800x600"
> EndSubSection
> SubSection "Display"
> Viewport 0 0
> Depth 15
> Modes "1280x1024" "1024x768" "800x600"
> EndSubSection
> SubSection "Display"
> Viewport 0 0
> Depth 16
> Modes "1280x1024" "1024x768" "800x600"
> EndSubSection
> SubSection "Display"
> Viewport 0 0
> Depth 24
> Modes "1280x1024" "1024x768" "800x600"
> EndSubSection
> EndSection
>
>
>
> Please note, I am NOT saying you should replace yours with mine. Just
> look to see what differences may help with yours. Maybe something is
> commented out that shouldn't be or something should be commented out
> that isn't.
>
> Hope that helps.
>
> Dale
>
> :-) :-)
>


-------------------------------
*亮 David Wei

您可以通过下面的方式和我联系:
MSN: inadavid@hotmail.com
Gtalk: inadavid@gmail.com
Email: davidwei@newbread.tj.cn
 
Old 10-08-2008, 12:36 AM
Dale
 
Default common user has problem with opengl

David Wei wrote:
> Hi,
> Thanks for the reply,I also notice the error part about the glx module in the Xorg.log file,and I tried to reinstall the nvidia-drivers package,but the problem still remains.
> After checking your xorg.conf file,I think the only difference that can cause my problem is in <Section "Module"> part. I tried to load dbe and other modules you mentioned,but still,nvidia showed this error message.
> Any other ideas? Thank you very much!
>
>
>

Do you have anything like this in your make.conf file?

VIDEO_CARDS="nvidia"

For others with newer hardware and more knowledge on video cards than
me, what version of nvidia are you using and what is the model of your
card? It may be that it is installing the wrong version for your card or
that you need a older or newer version or that that specific version has
a known bug.

Dale

:-) :-)
 
Old 10-08-2008, 01:08 AM
魏亮
 
Default common user has problem with opengl

Hi
I now add this word to my make.conf file,should i re-emerge some package?
I've already re-emerged the nvidia-drivers package,and the problem stayed
still.

-------------------------------
您可以通过下面的方式和我联系:
MSN: inadavid@hotmail.com
Gtail: inadavid@gmail.com
Email: davidwei@newbread.tj.cn

On Wed, 十月 8, 2008 08:36, Dale wrote:
> David Wei wrote:
>> Hi,
>> Thanks for the reply,I also notice the error part about the glx module
>> in the Xorg.log file,and I tried to reinstall the nvidia-drivers
>> package,but the problem still remains.
>> After checking your xorg.conf file,I think the only difference that can
>> cause my problem is in <Section "Module"> part. I tried to load dbe and
>> other modules you mentioned,but still,nvidia showed this error message.
>> Any other ideas? Thank you very much!
>>
>>
>>
>
> Do you have anything like this in your make.conf file?
>
> VIDEO_CARDS="nvidia"
>
> For others with newer hardware and more knowledge on video cards than
> me, what version of nvidia are you using and what is the model of your
> card? It may be that it is installing the wrong version for your card or
> that you need a older or newer version or that that specific version has
> a known bug.
>
> Dale
>
> :-) :-)
>
>
>
 
Old 10-08-2008, 01:40 AM
Dale
 
Default common user has problem with opengl

*亮 wrote:
> Hi
> I now add this word to my make.conf file,should i re-emerge some package?
> I've already re-emerged the nvidia-drivers package,and the problem stayed
> still.
>
> -------------------------------
> 您可以通过下面的方式和我联系:
> MSN: inadavid@hotmail.com
> Gtail: inadavid@gmail.com
> Email: davidwei@newbread.tj.cn
>
> On Wed, 十月 8, 2008 08:36, Dale wrote:
>
>> David Wei wrote:
>>
>>> Hi,
>>> Thanks for the reply,I also notice the error part about the glx module
>>> in the Xorg.log file,and I tried to reinstall the nvidia-drivers
>>> package,but the problem still remains.
>>> After checking your xorg.conf file,I think the only difference that can
>>> cause my problem is in <Section "Module"> part. I tried to load dbe and
>>> other modules you mentioned,but still,nvidia showed this error message.
>>> Any other ideas? Thank you very much!
>>>
>>>
>>>
>>>
>> Do you have anything like this in your make.conf file?
>>
>> VIDEO_CARDS="nvidia"
>>
>> For others with newer hardware and more knowledge on video cards than
>> me, what version of nvidia are you using and what is the model of your
>> card? It may be that it is installing the wrong version for your card or
>> that you need a older or newer version or that that specific version has
>> a known bug.
>>
>> Dale
>>
>> :-) :-)
>>
>>

I think you need to re-emerge xorg. I would do a equery list xorg and
just re-emerge whatever you have installed. Don't forget to add the
--oneshot when you re-emerge.

Everybody else, if this is incorrect, please speak up. There may be a
way to tell emerge to see the change that I am not aware of, yet. ;-)

Dale

:-) :-)
 
Old 10-08-2008, 01:41 AM
Volker Armin Hemmann
 
Default common user has problem with opengl

On Mittwoch 08 Oktober 2008, *亮 wrote:
> Hi
> I now add this word to my make.conf file,should i re-emerge some package?
> I've already re-emerged the nvidia-drivers package,and the problem stayed
> still.

how about eselect opengl set nvidia?
 
Old 10-08-2008, 02:10 AM
David Wei
 
Default common user has problem with opengl

hey Volker!
I tried to : eselect opengl set nvidia
and it seem worked!!! i get no error message any more from the xorg log.I am now doing this remotely so i can not 100% confirm that,but I think it is solved!
thank you very much both of you guys, I can play my 3D game now.

On Wed, 8 Oct 2008 03:41:17 +0200
Volker Armin Hemmann <volker.armin.hemmann@tu-clausthal.de> wrote:

> On Mittwoch 08 Oktober 2008, *亮 wrote:
> > Hi
> > I now add this word to my make.conf file,should i re-emerge some package?
> > I've already re-emerged the nvidia-drivers package,and the problem stayed
> > still.
>
> how about eselect opengl set nvidia?
>


-------------------------------
*亮 David Wei

您可以通过下面的方式和我联系:
MSN: inadavid@hotmail.com
Gtalk: inadavid@gmail.com
Email: davidwei@newbread.tj.cn
 

Thread Tools




All times are GMT. The time now is 11:17 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org