FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 10-03-2008, 01:41 PM
"Andrey Vul"
 
Default cannot compile eclipse-ecj using gcj

Gcj can't compile eclipse(-ecj) due to encoding issues. Any solutions?

Emerge log attached.
--
Andrey Vul

These are the packages that would be merged, in order:

Calculating dependencies ..... ....... done!
[ebuild N ] dev-java/eclipse-ecj-3.4-r2 USE="gcj java6" 0 kB

Total: 1 package (1 new), Size of downloads: 0 kB


>>> Verifying ebuild manifests

>>> Emerging (1 of 1) dev-java/eclipse-ecj-3.4-r2
* ecjsrc-3.4.zip RMD160 SHA1 SHA256 size ;-) ... [ ok ]
* checking ebuild checksums ;-) ... [ ok ]
* checking auxfile checksums ;-) ... [ ok ]
* checking miscfile checksums ;-) ... [ ok ]
>>> Unpacking source...
>>> Unpacking ecjsrc-3.4.zip to /var/tmp/portage/dev-java/eclipse-ecj-3.4-r2/work
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/dev-java/eclipse-ecj-3.4-r2/work ...
* bootstrapping ecj with /usr/x86_64-pc-linux-gnu/gcc-bin/4.2.4/gcj -C ...
org/eclipse/jdt/internal/compiler/lookup/MethodVerifier15.java:755: error: Unrecognized character for encoding 'UTF-8'.
// JLS 3 8.4.5: more are accepted, with an unchecked conversion
^
1 error
*
* ERROR: dev-java/eclipse-ecj-3.4-r2 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3838: Called die
* The specific snippet of code:
* ${javac} ${javac_opts} $(find org/ -name '*.java') || die;
* The die message:
* (no error message)
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/dev-java/eclipse-ecj-3.4-r2/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-java/eclipse-ecj-3.4-r2/temp/environment'.
*
!!! When you file a bug report, please include the following information:
GENTOO_VM= CLASSPATH="." JAVA_HOME="/etc/java-config-2/current-system-vm"
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info

* Messages for package dev-java/eclipse-ecj-3.4-r2:

*
* ERROR: dev-java/eclipse-ecj-3.4-r2 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 3838: Called die
* The specific snippet of code:
* ${javac} ${javac_opts} $(find org/ -name '*.java') || die;
* The die message:
* (no error message)
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/dev-java/eclipse-ecj-3.4-r2/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-java/eclipse-ecj-3.4-r2/temp/environment'.
*
 
Old 10-03-2008, 03:21 PM
Aaron Clark
 
Default cannot compile eclipse-ecj using gcj

Andrey Vul wrote:

Gcj can't compile eclipse(-ecj) due to encoding issues. Any solutions?

Emerge log attached.


Ask on gentoo-java?

Aaron
 
Old 10-03-2008, 07:29 PM
James
 
Default cannot compile eclipse-ecj using gcj

Andrey Vul <andrey.vul <at> gmail.com> writes:

>
> Gcj can't compile eclipse(-ecj) due to encoding issues. Any solutions?
>
> Emerge log attached.


Hello Andrey,

I have Installed versions: 3.4-r2 on my amd64. What
version are you trying to install? I also have these
entries in my package.keywords files:

dev-util/eclipse-cdt ~amd64
dev-util/eclipse-sdk ~amd64
dev-java/cldc-api ~amd64
dev-java/junit ~amd64
dev-java/hamcrest-core ~amd64
dev-java/junit ~amd64
dev-java/eclipse-ecj ~amd64
app-admin/eselect-ecj ~amd64
dev-java/lucene-analyzers ~amd64
dev-java/ant-eclipse-ecj ~amd64
dev-java/swt ~amd64
dev-java/jsch ~amd64
dev-java/icu4j ~amd64
dev-java/commons-el ~amd64
dev-java/lucene ~amd64
dev-java/tomcat-servlet-api ~amd64
dev-java/commons-logging ~amd64


hth,

James
 
Old 10-03-2008, 10:41 PM
"Andrey Vul"
 
Default cannot compile eclipse-ecj using gcj

On Fri, Oct 3, 2008 at 3:29 PM, James <wireless@tampabay.rr.com> wrote:
> Andrey Vul <andrey.vul <at> gmail.com> writes:
>
>>
>> Gcj can't compile eclipse(-ecj) due to encoding issues. Any solutions?
>>
>> Emerge log attached.
>
>
> Hello Andrey,
>
> I have Installed versions: 3.4-r2 on my amd64. What
> version are you trying to install? I also have these
> entries in my package.keywords files:
>
> dev-util/eclipse-cdt ~amd64
> dev-util/eclipse-sdk ~amd64
> dev-java/cldc-api ~amd64
> dev-java/junit ~amd64
> dev-java/hamcrest-core ~amd64
> dev-java/junit ~amd64
> dev-java/eclipse-ecj ~amd64
> app-admin/eselect-ecj ~amd64
> dev-java/lucene-analyzers ~amd64
> dev-java/ant-eclipse-ecj ~amd64
> dev-java/swt ~amd64
> dev-java/jsch ~amd64
> dev-java/icu4j ~amd64
> dev-java/commons-el ~amd64
> dev-java/lucene ~amd64
> dev-java/tomcat-servlet-api ~amd64
> dev-java/commons-logging ~amd64
Eclipse 3.4-r2
The keywords aren't neccessary, I have ~amd64 set in make.conf.

--
Andrey Vul
 
Old 10-03-2008, 10:44 PM
"Andrey Vul"
 
Default cannot compile eclipse-ecj using gcj

On Fri, Oct 3, 2008 at 9:41 AM, Andrey Vul <andrey.vul@gmail.com> wrote:
> Gcj can't compile eclipse(-ecj) due to encoding issues. Any solutions?
>

The specific byte is 0xA8 (the section sign). However, it is *not*
encoded in UTF-8. leading to the error. Which 8-bit encodings have
high-ASCII (i.e. 0x80-0xFF) support?

--
Andrey Vul
 

Thread Tools




All times are GMT. The time now is 09:58 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org