FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 09-27-2008, 07:35 AM
"Walter Dnes"
 
Default Absolutely no sound whatsoever after latest emerge update

On Fri, Sep 26, 2008 at 10:27:14AM -0400, Willie Wong wrote
> On Fri, Sep 26, 2008 at 02:14:48AM -0400, Penguin Lover Walter Dnes squawked:
> > [AO_ALSA] alsa-lib: pcm_dmix.c:996snd_pcm_dmix_open) unable to open slave
> > [AO_ALSA] Playback open error: Device or resource busy
> > DVB card number must be between 1 and 4
> > AO: [null] 22050Hz 2ch s16le (2 bytes per sample)
>
> This points to an issue with your alsa configuration/installation.
>
> > mpg123 doesn't work
> >
> > [d530][waltdnes][~] mpg123 /home/misc/music/pop_standards/Tennessee_Waltz_-_Patti_Page.mp3
> > ALSA lib pcm_dmix.c:996snd_pcm_dmix_open) unable to open slave
> > [alsa.c:146] error: cannot open device default
> > [audio.c:517] error: failed to open audio device
> > [mpg123.c:709] error: Failed to initialize output, goodbye.
>
> Same error as above, a problem with alsa.

Another Google search. In addition to a bunch of people with
problems, this time around, someone had a solution...

http://www.nabble.com/Re%3A--Bug-37649--pulseaudio%2C-REOPENED%3A-ALSA-lib-pcm_dmix.c%3A996%3A%28-snd_pcm_dmix_open%29-unable-to-open-slave-p16659896.html

Namely, restart alsasound (as root).

/etc/init.d/alsasound restart

I've put this in my /etc/conf.d/local.start

--
Walter Dnes <waltdnes@waltdnes.org>
 

Thread Tools




All times are GMT. The time now is 05:09 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org