FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 09-12-2008, 01:02 AM
RYAN vAN GINNEKEN
 
Default newbie broke something

Hello all gentoo newbie here i did a raid lvm quick install from the 2008.r1 livecd i must have missed something because i keep getting rc.conf file from the future errors and my /var directory was empty so i just uncompressed the stage 3 and recopied /var from stage three to my own /var. Seemed a bit messy so i figured i would try to clean things up a bit with
emerge --sync
emerge --update --deep --newuse world
but i think i broke something

now when i do an emerge --sync and it tells me to update portage, i tried to do so but am getting this looooooong error

Calculating dependencies... done!
[nomerge ] sys-apps/debianutils-2.28.5 USE="-static"
[nomerge ] sys-apps/coreutils-6.10-r2 USE="acl nls (-selinux) -static -vanilla -xattr"
[nomerge ] sys-apps/acl-2.2.47 USE="nls (-nfs)"
[nomerge ] sys-devel/automake-1.10.1
[nomerge ] dev-lang/perl-5.8.8-r5 USE="berkdb gdbm -build -debug -doc -ithreads -perlsuid"
[nomerge ] sys-libs/gdbm-1.8.3-r3 USE="berkdb"
[nomerge ] sys-libs/db-4.5.20_p2 USE="-bootstrap -doc -java -nocxx -tcl -test"
[nomerge ] sys-devel/binutils-2.18-r3 USE="nls -multislot -multitarget -test -vanilla"
[nomerge ] sys-devel/gettext-0.17 USE="acl nls openmp -doc -emacs -nocxx"
[nomerge ] dev-libs/libxml2-2.6.32 USE="ipv6 python readline -bootstrap -build -debug -doc -examples -test"
[nomerge ] dev-lang/python-2.5.2-r7 USE="berkdb gdbm ipv6 ncurses readline ssl threads -bootstrap -build -doc -examples -sqlite -tk -ucs2 -wininst"
[nomerge ] dev-libs/openssl-0.9.8g-r2 USE="zlib -bindist -gmp -kerberos -sse2 -test"
[ebuild N ] app-misc/ca-certificates-20080514-r2
[ebuild N ] dev-libs/openssl-0.9.8g-r2 USE="zlib -bindist -gmp -kerberos -sse2 -test"
[ebuild N ] app-admin/python-updater-0.5
[ebuild N ] dev-libs/libxml2-2.6.32 USE="ipv6 python readline -bootstrap -build -debug -doc -examples -test"
[ebuild N ] sys-apps/portage-2.1.4.4 USE="-build -doc -epydoc (-selinux)" LINGUAS="-pl"
[ebuild N ] dev-lang/python-2.5.2-r7 USE="berkdb gdbm ipv6 ncurses readline ssl threads -bootstrap -build -doc -examples -sqlite -tk -ucs2 -wininst"
[ebuild N ] net-misc/rsync-3.0.3 USE="acl iconv ipv6 -static -xattr -xinetd"
[ebuild N ] sys-apps/coreutils-6.10-r2 USE="acl nls (-selinux) -static -vanilla -xattr"
[ebuild N ] sys-apps/acl-2.2.47 USE="nls (-nfs)"
[ebuild N ] sys-apps/attr-2.4.41 USE="nls"
[nomerge ] dev-libs/openssl-0.9.8g-r2 USE="zlib -bindist -gmp -kerberos -sse2 -test"
[ebuild N ] sys-apps/diffutils-2.8.7-r2 USE="nls -static"
[ebuild N ] sys-apps/man-pages-3.05 USE="nls" LINGUAS="-cs -da -de -es -fr -it -ja -nl -pl -ro -ru -zh_CN"
[ebuild N ] sys-apps/man-pages-posix-2003a
[nomerge ] app-misc/ca-certificates-20080514-r2
[nomerge ] sys-apps/coreutils-6.10-r2 USE="acl nls (-selinux) -static -vanilla -xattr"
[nomerge ] sys-devel/automake-1.10.1
[nomerge ] sys-apps/help2man-1.36.4 USE="nls"
[nomerge ] dev-lang/perl-5.8.8-r5 USE="berkdb gdbm -build -debug -doc -ithreads -perlsuid"
[ebuild N ] app-admin/perl-cleaner-1.05
[nomerge ] sys-apps/man-pages-posix-2003a
[ebuild N ] sys-apps/man-1.6f-r1 USE="nls"
[ebuild N ] sys-apps/groff-1.19.2-r1 USE="-X -cjk"
[nomerge ] sys-apps/coreutils-6.10-r2 USE="acl nls (-selinux) -static -vanilla -xattr"
[nomerge ] sys-libs/ncurses-5.6-r2 USE="gpm unicode -debug -doc -minimal -nocxx -profile -trace"
[ebuild N ] sys-libs/gpm-1.20.1-r6 USE="(-selinux)"
[nomerge ] dev-libs/libxml2-2.6.32 USE="ipv6 python readline -bootstrap -build -debug -doc -examples -test"
[ebuild N ] sys-libs/readline-5.2_p12-r1
[nomerge ] net-misc/rsync-3.0.3 USE="acl iconv ipv6 -static -xattr -xinetd"
[nomerge ] sys-apps/acl-2.2.47 USE="nls (-nfs)"
[ebuild N ] sys-devel/libtool-1.5.26 USE="-vanilla"
[ebuild N ] sys-devel/automake-1.10.1
[ebuild N ] sys-apps/texinfo-4.11-r1 USE="nls -static"
[nomerge ] dev-lang/python-2.5.2-r7 USE="berkdb gdbm ipv6 ncurses readline ssl threads -bootstrap -build -doc -examples -sqlite -tk -ucs2 -wininst"
[nomerge ] sys-libs/readline-5.2_p12-r1
[ebuild N ] app-shells/bash-3.2_p33 USE="nls -afs -bashlogger -plugins -vanilla"
[ebuild N ] sys-libs/ncurses-5.6-r2 USE="gpm unicode -debug -doc -minimal -nocxx -profile -trace"
[ebuild N ] sys-devel/autoconf-2.61-r2 USE="-emacs"
[nomerge ] sys-apps/coreutils-6.10-r2 USE="acl nls (-selinux) -static -vanilla -xattr"
[nomerge ] sys-devel/libtool-1.5.26 USE="-vanilla"
[ebuild N ] sys-apps/help2man-1.36.4 USE="nls"
[ebuild N ] dev-perl/Locale-gettext-1.05
[nomerge ] dev-perl/Locale-gettext-1.05
[nomerge ] dev-lang/perl-5.8.8-r5 USE="berkdb gdbm -build -debug -doc -ithreads -perlsuid"
[ebuild N ] perl-core/PodParser-1.35
[ebuild N ] perl-core/Test-Harness-3.10
[ebuild N ] sys-devel/libperl-5.8.8-r2 USE="berkdb gdbm -debug -ithreads"
[ebuild N ] dev-lang/perl-5.8.8-r5 USE="berkdb gdbm -build -debug -doc -ithreads -perlsuid"
[nomerge ] net-misc/rsync-3.0.3 USE="acl iconv ipv6 -static -xattr -xinetd"
[ebuild N ] dev-libs/popt-1.10.7 USE="nls"
[nomerge ] dev-lang/python-2.5.2-r7 USE="berkdb gdbm ipv6 ncurses readline ssl threads -bootstrap -build -doc -examples -sqlite -tk -ucs2 -wininst"
[ebuild N ] sys-libs/gdbm-1.8.3-r3 USE="berkdb"
[ebuild N ] sys-libs/db-4.5.20_p2 USE="-bootstrap -doc -java -nocxx -tcl -test"
[ebuild N ] sys-devel/binutils-2.18-r3 USE="nls -multislot -multitarget -test -vanilla"
[ebuild N ] sys-devel/binutils-config-1.9-r4
[ebuild N ] sys-apps/findutils-4.3.13 USE="nls (-selinux) -static"
[nomerge ] sys-apps/portage-2.1.4.4 USE="-build -doc -epydoc (-selinux)" LINGUAS="-pl"
[ebuild N ] sys-apps/sed-4.1.5-r1 USE="nls -static"
[nomerge ] sys-apps/coreutils-6.10-r2 USE="acl nls (-selinux) -static -vanilla -xattr"
[ebuild N ] sys-devel/m4-1.4.11 USE="nls -examples"
[ebuild N ] sys-devel/gettext-0.17 USE="acl nls openmp -doc -emacs -nocxx"
!!! Error: circular dependencies:

('ebuild', '/', 'sys-devel/automake-1.10.1', 'merge') depends on
('ebuild', '/', 'sys-apps/texinfo-4.11-r1', 'merge') (hard)
('ebuild', '/', 'sys-apps/help2man-1.36.4', 'merge') (hard)
('ebuild', '/', 'dev-lang/perl-5.8.8-r5', 'merge') (hard)
('ebuild', '/', 'sys-devel/autoconf-2.61-r2', 'merge') (hard)
('ebuild', '/', 'app-admin/python-updater-0.5', 'merge') depends on
('ebuild', '/', 'sys-apps/portage-2.1.4.4', 'merge') (medium)
('ebuild', '/', 'sys-apps/texinfo-4.11-r1', 'merge') depends on
('ebuild', '/', 'sys-devel/gettext-0.17', 'merge') (hard)
('ebuild', '/', 'sys-libs/ncurses-5.6-r2', 'merge') (hard)
('ebuild', '/', 'dev-libs/libxml2-2.6.32', 'merge') depends on
('ebuild', '/', 'sys-libs/readline-5.2_p12-r1', 'merge') (hard)
('ebuild', '/', 'dev-lang/python-2.5.2-r7', 'merge') (hard)
('ebuild', '/', 'sys-apps/findutils-4.3.13', 'merge') depends on
('ebuild', '/', 'sys-devel/gettext-0.17', 'merge') (hard)
('ebuild', '/', 'sys-apps/sed-4.1.5-r1', 'merge') depends on
('ebuild', '/', 'sys-devel/gettext-0.17', 'merge') (hard)
('ebuild', '/', 'sys-apps/portage-2.1.4.4', 'merge') depends on
('ebuild', '/', 'sys-apps/coreutils-6.10-r2', 'merge') (medium-soft)
('ebuild', '/', 'sys-apps/sed-4.1.5-r1', 'merge') (hard)
('ebuild', '/', 'app-shells/bash-3.2_p33', 'merge') (medium)
('ebuild', '/', 'net-misc/rsync-3.0.3', 'merge') (medium-soft)
('ebuild', '/', 'dev-lang/python-2.5.2-r7', 'merge') (hard)
('ebuild', '/', 'sys-libs/readline-5.2_p12-r1', 'merge') depends on
('ebuild', '/', 'sys-libs/ncurses-5.6-r2', 'merge') (hard)
('ebuild', '/', 'app-shells/bash-3.2_p33', 'merge') (hard)
('ebuild', '/', 'sys-devel/m4-1.4.11', 'merge') depends on
('ebuild', '/', 'sys-devel/gettext-0.17', 'merge') (hard)
('ebuild', '/', 'app-misc/ca-certificates-20080514-r2', 'merge') depends on
('ebuild', '/', 'dev-libs/openssl-0.9.8g-r2', 'merge') (medium)
('ebuild', '/', 'sys-apps/coreutils-6.10-r2', 'merge') (hard)
('ebuild', '/', 'sys-apps/groff-1.19.2-r1', 'merge') depends on
('ebuild', '/', 'sys-devel/automake-1.10.1', 'merge') (hard)
('ebuild', '/', 'sys-devel/autoconf-2.61-r2', 'merge') (hard)
('ebuild', '/', 'sys-apps/texinfo-4.11-r1', 'merge') (hard)
('ebuild', '/', 'sys-devel/libtool-1.5.26', 'merge') (hard)
('ebuild', '/', 'sys-devel/autoconf-2.61-r2', 'merge') depends on
('ebuild', '/', 'sys-devel/m4-1.4.11', 'merge') (hard)
('ebuild', '/', 'dev-lang/perl-5.8.8-r5', 'merge') (hard)
('ebuild', '/', 'sys-apps/texinfo-4.11-r1', 'merge') (hard)
('ebuild', '/', 'sys-apps/diffutils-2.8.7-r2', 'merge') depends on
('ebuild', '/', 'sys-devel/gettext-0.17', 'merge') (hard)
('ebuild', '/', 'sys-apps/man-pages-3.05', 'merge') (hard)
('ebuild', '/', 'dev-libs/popt-1.10.7', 'merge') depends on
('ebuild', '/', 'sys-devel/gettext-0.17', 'merge') (hard)
('ebuild', '/', 'sys-libs/gpm-1.20.1-r6', 'merge') depends on
('ebuild', '/', 'sys-libs/ncurses-5.6-r2', 'merge') (hard)
('ebuild', '/', 'app-shells/bash-3.2_p33', 'merge') depends on
('ebuild', '/', 'sys-libs/ncurses-5.6-r2', 'merge') (hard)
('ebuild', '/', 'sys-devel/libperl-5.8.8-r2', 'merge') depends on
('ebuild', '/', 'sys-libs/gdbm-1.8.3-r3', 'merge') (hard)
('ebuild', '/', 'sys-libs/db-4.5.20_p2', 'merge') (hard)
('ebuild', '/', 'dev-lang/perl-5.8.8-r5', 'merge') (medium-soft)
('ebuild', '/', 'sys-libs/db-4.5.20_p2', 'merge') depends on
('ebuild', '/', 'sys-devel/binutils-2.18-r3', 'merge') (hard)
('ebuild', '/', 'dev-lang/perl-5.8.8-r5', 'merge') depends on
('ebuild', '/', 'app-admin/perl-cleaner-1.05', 'merge') (medium-soft)
('ebuild', '/', 'perl-core/Test-Harness-3.10', 'merge') (medium-soft)
('ebuild', '/', 'sys-devel/libperl-5.8.8-r2', 'merge') (hard)
('ebuild', '/', 'sys-libs/gdbm-1.8.3-r3', 'merge') (hard)
('ebuild', '/', 'sys-libs/db-4.5.20_p2', 'merge') (hard)
('ebuild', '/', 'perl-core/PodParser-1.35', 'merge') (medium-soft)
('ebuild', '/', 'sys-devel/libtool-1.5.26', 'merge') depends on
('ebuild', '/', 'sys-devel/automake-1.10.1', 'merge') (hard)
('ebuild', '/', 'sys-devel/autoconf-2.61-r2', 'merge') (hard)
('ebuild', '/', 'sys-apps/help2man-1.36.4', 'merge') (hard)
('ebuild', '/', 'sys-devel/binutils-2.18-r3', 'merge') depends on
('ebuild', '/', 'sys-devel/gettext-0.17', 'merge') (hard)
('ebuild', '/', 'sys-devel/binutils-config-1.9-r4', 'merge') (hard)
('ebuild', '/', 'sys-apps/man-pages-posix-2003a', 'merge') depends on
('ebuild', '/', 'sys-apps/man-1.6f-r1', 'merge') (medium)
('ebuild', '/', 'sys-devel/binutils-config-1.9-r4', 'merge') depends on
('ebuild', '/', 'sys-apps/findutils-4.3.13', 'merge') (medium)
('ebuild', '/', 'app-admin/perl-cleaner-1.05', 'merge') depends on
('ebuild', '/', 'app-shells/bash-3.2_p33', 'merge') (hard)
('ebuild', '/', 'dev-lang/perl-5.8.8-r5', 'merge') (medium)
('ebuild', '/', 'sys-devel/gettext-0.17', 'merge') depends on
('ebuild', '/', 'dev-libs/libxml2-2.6.32', 'merge') (hard)
('ebuild', '/', 'sys-libs/ncurses-5.6-r2', 'merge') (hard)
('ebuild', '/', 'sys-apps/acl-2.2.47', 'merge') (hard)
('ebuild', '/', 'sys-apps/man-pages-3.05', 'merge') depends on
('ebuild', '/', 'sys-apps/man-pages-posix-2003a', 'merge') (medium-soft)
('ebuild', '/', 'sys-apps/man-1.6f-r1', 'merge') (medium)
('ebuild', '/', 'sys-apps/help2man-1.36.4', 'merge') depends on
('ebuild', '/', 'sys-devel/gettext-0.17', 'merge') (hard)
('ebuild', '/', 'dev-lang/perl-5.8.8-r5', 'merge') (hard)
('ebuild', '/', 'dev-perl/Locale-gettext-1.05', 'merge') (hard)
('ebuild', '/', 'dev-lang/python-2.5.2-r7', 'merge') depends on
('ebuild', '/', 'sys-devel/automake-1.10.1', 'merge') (hard)
('ebuild', '/', 'sys-libs/ncurses-5.6-r2', 'merge') (hard)
('ebuild', '/', 'app-admin/python-updater-0.5', 'merge') (medium-soft)
('ebuild', '/', 'sys-libs/readline-5.2_p12-r1', 'merge') (hard)
('ebuild', '/', 'sys-libs/gdbm-1.8.3-r3', 'merge') (hard)
('ebuild', '/', 'sys-libs/db-4.5.20_p2', 'merge') (hard)
('ebuild', '/', 'sys-devel/autoconf-2.61-r2', 'merge') (hard)
('ebuild', '/', 'dev-libs/openssl-0.9.8g-r2', 'merge') (hard)
('ebuild', '/', 'sys-devel/libtool-1.5.26', 'merge') (hard)
('ebuild', '/', 'dev-perl/Locale-gettext-1.05', 'merge') depends on
('ebuild', '/', 'sys-devel/gettext-0.17', 'merge') (hard)
('ebuild', '/', 'dev-lang/perl-5.8.8-r5', 'merge') (hard)
('ebuild', '/', 'sys-libs/gdbm-1.8.3-r3', 'merge') depends on
('ebuild', '/', 'sys-libs/db-4.5.20_p2', 'merge') (hard)
('ebuild', '/', 'dev-libs/openssl-0.9.8g-r2', 'merge') depends on
('ebuild', '/', 'sys-apps/diffutils-2.8.7-r2', 'merge') (hard)
('ebuild', '/', 'dev-lang/perl-5.8.8-r5', 'merge') (hard)
('ebuild', '/', 'app-misc/ca-certificates-20080514-r2', 'merge') (medium-soft)
('ebuild', '/', 'perl-core/PodParser-1.35', 'merge') depends on
('ebuild', '/', 'dev-lang/perl-5.8.8-r5', 'merge') (hard)
('ebuild', '/', 'sys-apps/man-1.6f-r1', 'merge') depends on
('ebuild', '/', 'sys-devel/gettext-0.17', 'merge') (hard)
('ebuild', '/', 'sys-apps/groff-1.19.2-r1', 'merge') (medium)
('ebuild', '/', 'sys-apps/attr-2.4.41', 'merge') depends on
('ebuild', '/', 'sys-devel/automake-1.10.1', 'merge') (hard)
('ebuild', '/', 'sys-devel/gettext-0.17', 'merge') (hard)
('ebuild', '/', 'sys-devel/autoconf-2.61-r2', 'merge') (hard)
('ebuild', '/', 'sys-devel/libtool-1.5.26', 'merge') (hard)
('ebuild', '/', 'sys-apps/acl-2.2.47', 'merge') depends on
('ebuild', '/', 'sys-devel/automake-1.10.1', 'merge') (hard)
('ebuild', '/', 'sys-devel/gettext-0.17', 'merge') (hard)
('ebuild', '/', 'sys-devel/autoconf-2.61-r2', 'merge') (hard)
('ebuild', '/', 'sys-devel/libtool-1.5.26', 'merge') (hard)
('ebuild', '/', 'sys-apps/attr-2.4.41', 'merge') (hard)
('ebuild', '/', 'sys-apps/coreutils-6.10-r2', 'merge') depends on
('ebuild', '/', 'sys-devel/automake-1.10.1', 'merge') (hard)
('ebuild', '/', 'sys-libs/ncurses-5.6-r2', 'merge') (hard)
('ebuild', '/', 'sys-apps/acl-2.2.47', 'merge') (hard)
('ebuild', '/', 'sys-devel/gettext-0.17', 'merge') (hard)
('ebuild', '/', 'sys-devel/m4-1.4.11', 'merge') (hard)
('ebuild', '/', 'sys-devel/autoconf-2.61-r2', 'merge') (hard)
('ebuild', '/', 'sys-devel/libtool-1.5.26', 'merge') (hard)
('ebuild', '/', 'perl-core/Test-Harness-3.10', 'merge') depends on
('ebuild', '/', 'dev-lang/perl-5.8.8-r5', 'merge') (hard)
('ebuild', '/', 'net-misc/rsync-3.0.3', 'merge') depends on
('ebuild', '/', 'sys-devel/automake-1.10.1', 'merge') (hard)
('ebuild', '/', 'sys-apps/acl-2.2.47', 'merge') (hard)
('ebuild', '/', 'dev-libs/popt-1.10.7', 'merge') (hard)
('ebuild', '/', 'sys-devel/autoconf-2.61-r2', 'merge') (hard)
('ebuild', '/', 'sys-devel/libtool-1.5.26', 'merge') (hard)
('ebuild', '/', 'sys-libs/ncurses-5.6-r2', 'merge') depends on
('ebuild', '/', 'sys-libs/gpm-1.20.1-r6', 'merge') (hard)

!!! Note that circular dependencies can often be avoided by temporarily
!!! disabling USE flags that trigger optional dependencies.


Computer King & CaN Mail - Sales Service Hosting Backup

http://www.computerking.ca http://www.canmail.org

NEW!!! Custom Service Packages
Secure IMAP Email - Automated Remote Backups - Photo Blogs - Online Accounting Packages
 
Old 09-12-2008, 11:31 AM
David Relson
 
Default newbie broke something

On Thu, 11 Sep 2008 19:02:10 -0600 (MDT)
RYAN vAN GINNEKEN wrote:

> Hello all gentoo newbie here i did a raid lvm quick install from the
> 2008.r1 livecd i must have missed something because i keep getting
> rc.conf file from the future errors and my /var directory was empty
> so i just uncompressed the stage 3 and recopied /var from stage three
> to my own /var. Seemed a bit messy so i figured i would try to clean
> things up a bit with emerge --sync emerge --update --deep --newuse
> world but i think i broke something
>
> now when i do an emerge --sync and it tells me to update portage, i
> tried to do so but am getting this looooooong error
>
> Calculating dependencies... done!

...[snip]...
)
>
> !!! Note that circular dependencies can often be avoided by
> temporarily !!! disabling USE flags that trigger optional
> dependencies.

Two approaches occur to me:

The circular dependencies are found during the "--deep" check. You
_could_ start with "emerge --update world" then do "emerge --update
--deep world". The first emerge would do part of the work and the
second would (I think, but am not sure) dig deeper and find
dependencies. Finally you could do an "emerge --deep --newuse world"
to apply your new use flags.

Alternately you could take the dependency list and create a shell
script that would emerge them one by one.

HTH,

David
 

Thread Tools




All times are GMT. The time now is 01:07 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org