FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 08-31-2008, 01:06 PM
Stroller
 
Default emerge -1 `eix -Iu --only-names` & removing old version of Python

On 31 Aug 2008, at 09:05, David Sveningsson wrote:

Stroller skrev:


On 30 Aug 2008, at 21:19, Alan McKinnon wrote:

...
In retrospect, it would probably have been quicker if you went the
long way
round:

emerge -e world


Tried it. Kept dying and leaving a number of packages that I just
couldn't build.


You can resume building by using "emerge --resume". If a package fails
to build you can skip it with "emerge --resume --skipfirst".


I know this, but in the case of the libexpat.so.0 problem I got loads
of packages which THEN couldn't compile because they depended upon the
first one. And the older versions no longer worked because they were
missing libexpat.so.0.


Stroller.
 
Old 09-01-2008, 10:49 AM
Mick
 
Default emerge -1 `eix -Iu --only-names` & removing old version of Python

On Sunday 31 August 2008, Neil Bothwick wrote:
> On Sun, 31 Aug 2008 09:04:03 +0100, Mick wrote:
> > $ eix -Iu --only-names
> > app-arch/lzma-utils
> > dev-libs/libsigc++
> > media-plugins/gst-plugins-x
> > media-plugins/gst-plugins-xvideo
> > sys-apps/hdparm
> > sys-kernel/gentoo-sources
> > virtual/perl-Test-Harness
> >
> > However, when I run emerge -upDv --with-deps y world I get just one
> > package:
> >
> > Where's the others gone?
>
> Probably old dependencies that are no longer needed? Did you run
> emerge --depclean -p?

No! --depclean is evil! ) (and/or my system is borked).

It tells me to remove dev-python/pycrypto, when portage seems to depend on it:

# equery depends dev-python/pycrypto
[ Searching for packages depending on dev-python/pycrypto... ]
sys-apps/portage-2.1.4.4 (!build? >=dev-python/pycrypto-2.0.1-r6)

Also, it tells me to remove hdparm-8.6. I noticed that there is a 8.7 version
available, but emerge -uDv world does not pick this up . . . why would that
be so?

# emerge -upDv hdparm

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] sys-apps/hdparm-8.9 [8.6] 75 kB

Total: 1 package (1 upgrade), Size of downloads: 75 kB
# emerge -upDv world

These are the packages that would be merged, in order:

Calculating world dependencies |
... done!

Total: 0 packages, Size of downloads: 0 kB
--
Regards,
Mick
 
Old 09-01-2008, 06:21 PM
Mick
 
Default emerge -1 `eix -Iu --only-names` & removing old version of Python

On Monday 01 September 2008, Sebastian GŁnther wrote:
> * Mick (michaelkintzios@gmail.com) [01.09.08 19:35]:

> >
> > No! --depclean is evil! ) (and/or my system is borked).
>
> Your system is borked! ;-)

That's what I fear.

> > It tells me to remove dev-python/pycrypto, when portage seems to depend
> > on it:
> >
> > # equery depends dev-python/pycrypto
> > [ Searching for packages depending on dev-python/pycrypto... ]
> > sys-apps/portage-2.1.4.4 (!build? >=dev-python/pycrypto-2.0.1-r6)
>
> Well you could just add it to your world file, but I really think there
> is something misconfigure on your system.

Where should I look?

> > Also, it tells me to remove hdparm-8.6. I noticed that there is a 8.7
> > version available, but emerge -uDv world does not pick this up . . . why
> > would that be so?
>
> hdparm is not in the world file, and since no other package is depending
> on it, portage is considering it's removal.
>
> with emerge -n hdparm you can add it.

Sure, but I had emerged (many years ago) so it should be in there, right?

--
Regards,
Mick
 
Old 09-01-2008, 09:13 PM
Neil Bothwick
 
Default emerge -1 `eix -Iu --only-names` & removing old version of Python

On Mon, 1 Sep 2008 11:49:36 +0100, Mick wrote:

> No! --depclean is evil! ) (and/or my system is borked).

Neither.

> It tells me to remove dev-python/pycrypto, when portage seems to depend
> on it:
>
> # equery depends dev-python/pycrypto
> [ Searching for packages depending on dev-python/pycrypto... ]
> sys-apps/portage-2.1.4.4 (!build? >=dev-python/pycrypto-2.0.1-r6)

equery is borked. pycrypto is a conditional dependency of portage, but
equery depends takes no accounts of that, emerge --depclean does.

> Also, it tells me to remove hdparm-8.6. I noticed that there is a 8.7
> version available, but emerge -uDv world does not pick this up . . .
> why would that be so?

hdparm used to be part of system AFAIR, it is no longer. If you want it,
add it to world.


--
Neil Bothwick

We can sympathize with a child who is afraid of the dark, but the
tragedy of life is that most people are afraid of the light.
 
Old 09-02-2008, 12:22 AM
Neil Bothwick
 
Default emerge -1 `eix -Iu --only-names` & removing old version of Python

On Mon, 1 Sep 2008 23:57:03 +0200, Sebastian GŁnther wrote:

> But it is a *negativ* condition: portage is not depending on pycrypto
> if and only if the build useflag is specified, which noone should
> specify.

portage depends on >=python-2.5 or pycrypto.

> So --depclean should not consider it to be removed.

Unless you are using python 2.5, in which case it is no longer needed.


--
Neil Bothwick

"There are no stupid questions, just too many inquisitive idiots."
 
Old 09-02-2008, 07:20 AM
Mick
 
Default emerge -1 `eix -Iu --only-names` & removing old version of Python

On Tuesday 02 September 2008, Neil Bothwick wrote:
> On Mon, 1 Sep 2008 23:57:03 +0200, Sebastian GŁnther wrote:
> > But it is a *negativ* condition: portage is not depending on pycrypto
> > if and only if the build useflag is specified, which noone should
> > specify.
>
> portage depends on >=python-2.5 or pycrypto.
>
> > So --depclean should not consider it to be removed.
>
> Unless you are using python 2.5, in which case it is no longer needed.

I have dev-lang/python-2.5.2-r6 installed and from what I recall I have run
python-updater. So, that's why I am allowed to remove
dev-python/pycrypto-2.0.1-r6 as per Neil's explanation.
--
Regards,
Mick
 
Old 09-03-2008, 08:43 AM
Stroller
 
Default emerge -1 `eix -Iu --only-names` & removing old version of Python

On 31 Aug 2008, at 09:04, Mick wrote:

...
When I tried I got:

$ eix -Iu --only-names
app-arch/lzma-utils
dev-libs/libsigc++
media-plugins/gst-plugins-x
media-plugins/gst-plugins-xvideo
sys-apps/hdparm
sys-kernel/gentoo-sources
virtual/perl-Test-Harness

However, when I run emerge -upDv --with-deps y world I get just one
package:

...
[ebuild U ] app-arch/lzma-utils-4.32.6 [4.32.5] USE="-nocxx%"
468 kB


This was approximately the same ratio of packages that each command
produced for me... except many times more in actual numbers. I think
`eix -Iu` found over a hundred outdated packages on my system when I
ran it. And updating one of them - obviously I have no idea which! -
fixed my expat problem.


Stroller.
 

Thread Tools




All times are GMT. The time now is 12:53 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org