FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 07-18-2008, 11:16 PM
"Jason Carson"
 
Default WPA encryption on my wireless network

I have installed and configured my wirelss network with MadWifi and
wpa_supllicant. However it is unencrypted. What do I have to do to setup
WPA encryption? I have followed this
(http://gentoo-wiki.com/HOWTO_Building_a_Wireless_Access_Point#WPA_Encrypt ion)
but when I run...

hostapd -dd /etc/hostapd/hostapd.conf

I get this...

Configuration file: /etc/hostapd/hostapd.conf
madwifi_set_iface_flags: dev_up=0
Using interface ath0 with hwaddr 00:19:5b:80:f2:d8 and ssid 'CarsonNet'
Flushing old station entries
madwifi_sta_deauth: addr=ff:ff:ff:ff:ff:ff reason_code=3
ioctl[unknown???]: Invalid argument
Could not connect to kernel driver.
Deauthenticate all stations
rmdir[ctrl_interface]: No such file or directory
madwifi_set_privacy: enabled=0
madwifi_set_iface_flags: dev_up=0

When I run this...

/etc/init.d/hostapd start

I get this...

* Starting hostapd ...
Configuration file: /etc/hostapd/hostapd.conf
Using interface ath0 with hwaddr 00:19:5b:80:f2:d8 and ssid 'CarsonNet'
Flushing old station entries
ioctl[unknown???]: Invalid argument
Could not connect to kernel driver.
Deauthenticate all stations
rmdir[ctrl_interface]: No such file or directory
[ !! ]


So what does this mean?

ioctl[unknown???]: Invalid argument

I can't get hostapd to startup until this is fixed.


--
gentoo-user@lists.gentoo.org mailing list
 
Old 07-18-2008, 11:43 PM
"Jason Carson"
 
Default WPA encryption on my wireless network

> Jason Carson wrote:
>> << SNIP >>
>>
>>
>> So what does this mean?
>>
>> ioctl[unknown???]: Invalid argument
>>
>> I can't get hostapd to startup until this is fixed.
>>
>>
>>
>
> No knowledge here but google may have found something.
>
> http://madwifi.org/ticket/422
>
> Hope that helps.
>
> Dale

That looked promising. There was a link on that page to another page that
looked like it would fix what was happening to me. Unforunately that last
link is broken....

http://gnudot.org/howto/wifi/madwifi-wpa_supplicant_RSN_howto/madwifi-wpa_supplicant_RSN_howto.html

> :-) :-)
> --
> gentoo-user@lists.gentoo.org mailing list
>
>


--
gentoo-user@lists.gentoo.org mailing list
 
Old 07-19-2008, 03:30 AM
Dale
 
Default WPA encryption on my wireless network

Jason Carson wrote:

<< SNIP >>


So what does this mean?

ioctl[unknown???]: Invalid argument

I can't get hostapd to startup until this is fixed.





No knowledge here but google may have found something.

http://madwifi.org/ticket/422

Hope that helps.

Dale

:-) :-)
--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 04:31 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org