FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 07-19-2008, 01:19 AM
"Walter Dnes"
 
Default dev-python/setuptools conflict when running python-updater

I did some updates today. "emerge --sync" and updated world on my
"production machine". Things went OK, including running python-updater.
Then I scp'd the contents of /usr/portage/distfiles over to my "hot
backup machine", ran "emerge --sync" (pointing at my production machine)
and updated. Just like on the main machine, /var/log/portage/elog had
an advisory to run python-updater. This time, it didn't work...

================================================== =====================
d531 elog # /usr/sbin/python-updater
* Starting Python Updater from 2.4 to 2.5 :
* Adding to list: =sys-libs/cracklib-2.8.10
* Adding to list: =net-mail/getmail-4.7.6
* Adding to list: =app-office/gnumeric-1.8.2
* Adding to list: =dev-java/java-config-1.3.7
* Adding to list: =dev-java/java-config-2.1.6
* Adding to list: =dev-python/python-fchksum-1.7.1
* Adding to list: =dev-python/docutils-0.4-r3
* Adding to list: =dev-python/setuptools-0.6_rc7-r1
* Adding to list: =dev-python/pycrypto-2.0.1-r6

These are the packages that would be merged, in order:

Calculating dependencies
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

dev-python/setuptools:0

('ebuild', '/', 'dev-python/setuptools-0.6_rc7-r1', 'merge') (no
parents)

('ebuild', '/', 'dev-python/setuptools-0.6_rc8-r1', 'merge') pulled in
by
('ebuild', '/', 'dev-python/docutils-0.4-r3', 'merge')
================================================== =====================

Masking out =dev-python/setuptools-0.6_rc7-r1 didn't work, so I'm
considering removing it. Having been burned before when unmerging
core-utils (OUCH!!!) I thought I'd ask here before doing anything
stupid. How do I get around this python-updater problem?

--
Walter Dnes <waltdnes@waltdnes.org>
--
gentoo-user@lists.gentoo.org mailing list
 
Old 07-19-2008, 01:45 PM
Allan Gottlieb
 
Default dev-python/setuptools conflict when running python-updater

At Sat, 19 Jul 2008 09:00:04 +0200 Sebastian GŁnther <samson@guenther-roetgen.de> wrote:

> * Walter Dnes (waltdnes@waltdnes.org) [19.07.08 03:20]:
>> I did some updates today. "emerge --sync" and updated world on my
>> "production machine". Things went OK, including running python-updater.
>> Then I scp'd the contents of /usr/portage/distfiles over to my "hot
>> backup machine", ran "emerge --sync" (pointing at my production machine)
>> and updated. Just like on the main machine, /var/log/portage/elog had
>> an advisory to run python-updater. This time, it didn't work...
>>
> Just make an
> # emerge -1 setuptools
> and python-updater will run smoothly
>
> If you are using gnome, also
> # emerge -1 gnome-doc-utils
>
> I hit the same bugs yesterday.
>
> The second one is because python-updater seems to miss it and you would
> get a snadbox violation.

How nice to receive a *pro*active fix. I read your mail while my
python-updater was running. It then failed just as walter's and yours
did.
I applied your fix and ...
... voila, all is well.

Thanks,
allan
--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 05:47 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org