FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 07-18-2008, 08:43 PM
"Jason Carson"
 
Default Creating a wireless router -> I got it working!

ok, I got it working without encryption. Here is what I did I configured
my kernel according to these webpages...

http://madwifi.org/wiki/Requirements
and
http://madwifi.org/wiki/UserDocs/KernelConfig

...then I configured my system as follows...

1)Add madwifi to USE flags
2)emerge wpa_supplicant
3)emerge madwifi-ng and madwifi-ng-tools
4)cp net.eth0 net.ath0
5)rc-update add net.ath0 default
6)nano /etc/modprobe.d/ath_pci and add the following...
options ath_pci autocreate=ap
7)add the following to /etc/conf.d/local.start
ifconfig ath0 down
wlanconfig ath0 destroy
wlanconfig ath0 create wlandev wifi0 wlanmode ap

8)nano /etc/conf.d/net and add
mode_ath0="Master"
essid_ath0="CarsonNet"
config_ath0=( "192.168.1.1 netmask 255.255.255.0 broadcast 192.168.1.255" )
wpa_supplicant_ath0="-Dmadwifi"

Then I configured dhcpd and bind which I won't get into and it all worked.
I now have a wireless access point with Gentoo!

So my question now is, how do I enable WPA encryption?

--
gentoo-user@lists.gentoo.org mailing list
 
Old 07-18-2008, 08:57 PM
"Jason Carson"
 
Default Creating a wireless router -> I got it working!

> ok, I got it working without encryption. Here is what I did I configured
> my kernel according to these webpages...
>
> http://madwifi.org/wiki/Requirements
> and
> http://madwifi.org/wiki/UserDocs/KernelConfig
>
> ...then I configured my system as follows...
>
> 1)Add madwifi to USE flags
> 2)emerge wpa_supplicant
> 3)emerge madwifi-ng and madwifi-ng-tools
> 4)cp net.eth0 net.ath0
> 5)rc-update add net.ath0 default
> 6)nano /etc/modprobe.d/ath_pci and add the following...
> options ath_pci autocreate=ap
> 7)add the following to /etc/conf.d/local.start

OOPS: I added it to local.stop

> ifconfig ath0 down
> wlanconfig ath0 destroy
> wlanconfig ath0 create wlandev wifi0 wlanmode ap
>
> 8)nano /etc/conf.d/net and add
> mode_ath0="Master"
> essid_ath0="CarsonNet"
> config_ath0=( "192.168.1.1 netmask 255.255.255.0 broadcast 192.168.1.255"
> )
> wpa_supplicant_ath0="-Dmadwifi"
>
> Then I configured dhcpd and bind which I won't get into and it all worked.
> I now have a wireless access point with Gentoo!
>
> So my question now is, how do I enable WPA encryption?
>
> --
> gentoo-user@lists.gentoo.org mailing list
>
>


--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 06:48 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org