Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   grub menu working but invisible (http://www.linux-archive.org/gentoo-user/124869-grub-menu-working-but-invisible.html)

"Dmitry S. Makovey" 07-14-2008 10:52 PM

grub menu working but invisible
 
On July 14, 2008, Matt Harrison wrote:
> I ran grub-install as normal and it (apparently) installed the
> bootloader without problems.
>
> However, now, when I boot up, I don't get a grub menu or anything on the
> screen. Originally I thought there was a problem and my system wouldn't
> boot but I tried pressing return and it booted up without problems.

same here on 2 independent machines. Each one exhibits same problem. It's not
completely broken but sure as heck is annoying. Did I miss some "new"
configuration step you have to do with Grub?

--
Dmitry Makovey
Web Systems Administrator
Athabasca University
(780) 675-6245

"Andrew Tchernoivanov" 07-14-2008 11:00 PM

grub menu working but invisible
 
This problem was already posted here.
The idea is that splashimage moved from /boot/grub to /usr/share/grub.

On Tue, Jul 15, 2008 at 2:52 AM, Dmitry S. Makovey <dmitry@athabascau.ca> wrote:

On July 14, 2008, Matt Harrison wrote:

> I ran grub-install as normal and it (apparently) installed the

> bootloader without problems.

>

> However, now, when I boot up, I don't get a grub menu or anything on the

> screen. Originally I thought there was a problem and my system wouldn't

> boot but I tried pressing return and it booted up without problems.



same here on 2 independent machines. Each one exhibits same problem. It's not

completely broken but sure as heck is annoying. Did I miss some "new"

configuration step you have to do with Grub?



--

Dmitry Makovey

Web Systems Administrator

Athabasca University

(780) 675-6245

Matt Harrison 07-14-2008 11:14 PM

grub menu working but invisible
 
Andrew Tchernoivanov wrote:

This problem was already posted here.
The idea is that splashimage moved from /boot/grub to /usr/share/grub.


Thats strange, when the splashimage line was incorrect it used to just
give you the menu with a black background (ie the normal menu but with
splash) as you would expect.


I'm not too keen on this new behaviour but at least it should be easy to
fix.


Thanks

Matt
--
gentoo-user@lists.gentoo.org mailing list

Matt Harrison 07-14-2008 11:16 PM

grub menu working but invisible
 
Matt Harrison wrote:
Thats strange, when the splashimage line was incorrect it used to just
give you the menu with a black background (ie the normal menu but with
splash) as you would expect.


Sorry that should read:

ie the normal menu but without splash
--
gentoo-user@lists.gentoo.org mailing list

"Andrew Tchernoivanov" 07-14-2008 11:40 PM

grub menu working but invisible
 
Are the characters on the screen readable?* I had this problem too, along with the black grub screen. If they aren't - try adding vga=0x31B to your grub.conf

On Tue, Jul 15, 2008 at 3:16 AM, Matt Harrison <iwasinnamuknow@genestate.com> wrote:

Matt Harrison wrote:


Thats strange, when the splashimage line was incorrect it used to just give you the menu with a black background (ie the normal menu but with splash) as you would expect.




Sorry that should read:



ie the normal menu but without splash

--

gentoo-user@lists.gentoo.org mailing list

Sebastian Günther 07-15-2008 06:50 AM

grub menu working but invisible
 
* Andrew Tchernoivanov (tchernoivanov@gmail.com) [15.07.08 01:41]:
> Are the characters on the screen readable? I had this problem too, along
> with the black grub screen. If they aren't - try adding vga=0x31B to your
> grub.conf
>
Why should that help with grub? Did not found any hint, that ther is a
grub option called like that.

There is a *kernel* option, called like that, but that won't help with
the grub issue.

Please correct me if I'm wrong.

Sebastian

--
" Religion ist das Opium des Volkes. " Karl Marx

SEB@STI@N GÜNTHER mailto:samson@guenther-roetgen.de

"Andrew Tchernoivanov" 07-15-2008 07:54 AM

grub menu working but invisible
 
>There is a *kernel* option, called like that, but that won't help with

>the grub issue.

Sorry, my mistake.

On Tue, Jul 15, 2008 at 10:50 AM, Sebastian Günther <samson@guenther-roetgen.de> wrote:

* Andrew Tchernoivanov (tchernoivanov@gmail.com) [15.07.08 01:41]:


> Are the characters on the screen readable? *I had this problem too, along

> with the black grub screen. If they aren't - try adding vga=0x31B to your

> grub.conf

>

Why should that help with grub? Did not found any hint, that ther is a

grub option called like that.






Please correct me if I'm wrong.



Sebastian



--

*" Religion ist das Opium des Volkes. " * * *Karl Marx



*SEB@STI@N GÜNTHER * * * * mailto:samson@guenther-roetgen.de

dhk 07-18-2008 12:47 PM

grub menu working but invisible
 
Sebastian Günther wrote:

* Andrew Tchernoivanov (tchernoivanov@gmail.com) [15.07.08 01:41]:

Are the characters on the screen readable? I had this problem too, along
with the black grub screen. If they aren't - try adding vga=0x31B to your
grub.conf

Why should that help with grub? Did not found any hint, that ther is a
grub option called like that.


There is a *kernel* option, called like that, but that won't help with
the grub issue.


Please correct me if I'm wrong.

Sebastian

So what is the solution to making grub visible again? I remember when
it changed, I didn't understand the message displayed and I still don't
know the fix.


Running emerge --config grub doesn't work.

Is it as simple as changing the path of the splash image to
/usr/share/grub/ and running grub-install?


Thanks,
Dave
--
gentoo-user@lists.gentoo.org mailing list

Matt Harrison 07-18-2008 01:10 PM

grub menu working but invisible
 
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

dhk wrote:
| So what is the solution to making grub visible again? I remember when
| it changed, I didn't understand the message displayed and I still don't
| know the fix.
|
| Running emerge --config grub doesn't work.
|
| Is it as simple as changing the path of the splash image to
| /usr/share/grub/ and running grub-install?

I changed grub.conf so it points to the splashimage on my /usr partition
like so:

splashimage=(hd0,5)/share/grub/splash.xpm.gz

Just make sure you get the partition number right, remembering that grub
counts paritions from 0, not 1. This fixed it perfectly for me.

HTH

Matt
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (MingW32)

iEYEARECAAYFAkiAlkkACgkQxNZfa+YAUWEBcwCfYTdG36hTwC Gn1GX9D9nmVTWg
UDAAoKlJFt0pM/OSsU52n5Krr9RL1tkY
=FCbQ
-----END PGP SIGNATURE-----

No virus found in this outgoing message.
Checked by AVG - http://www.avg.com
Version: 8.0.138 / Virus Database: 270.5.1/1559 - Release Date: 17/07/2008 18:08



--
gentoo-user@lists.gentoo.org mailing list

Miika Linnapuomi 07-18-2008 05:14 PM

grub menu working but invisible
 
Fri, 18 Jul 2008 12:47:52 +0000
dhk <dhkuhl@optonline.net> wrote:

> Sebastian Günther wrote:
> > * Andrew Tchernoivanov (tchernoivanov@gmail.com) [15.07.08 01:41]:
> >> Are the characters on the screen readable? I had this problem
> >> too, along with the black grub screen. If they aren't - try adding
> >> vga=0x31B to your grub.conf
> >>
> > Why should that help with grub? Did not found any hint, that ther
> > is a grub option called like that.
> >
> > There is a *kernel* option, called like that, but that won't help
> > with the grub issue.
> >
> > Please correct me if I'm wrong.
> >
> > Sebastian
> >
> So what is the solution to making grub visible again? I remember
> when it changed, I didn't understand the message displayed and I
> still don't know the fix.
>
> Running emerge --config grub doesn't work.
>
> Is it as simple as changing the path of the splash image to
> /usr/share/grub/ and running grub-install?
>
> Thanks,
> Dave


Just cp /usr/share/grub/splash.xpm.gz /boot/grub/

Or you could point to it in /usr, unless if you have /usr in lvm or
something else that grub wont be able to see


Miika


All times are GMT. The time now is 11:40 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.