FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 07-10-2008, 06:33 PM
John covici
 
Default revdep-rebuild wants to downgrade packages!

Hi. I just emerged the firefox 3.0 which required a new version also
of xulrunner. Now if I run revdep-rebuild, it wants to downgrade both
of these packages.

A number of packages seem to depend on libnss3.so.11 libsmime3.so.11
libssl3.so.11 . How can I resolve this conflict?

Thanks in advance for any ideas on this.

--
Your life is like a penny. You're going to lose it. The question is:
How do
you spend it?

John Covici
covici@ccs.covici.com
--
gentoo-user@lists.gentoo.org mailing list
 
Old 07-10-2008, 07:23 PM
Neil Bothwick
 
Default revdep-rebuild wants to downgrade packages!

On Thu, 10 Jul 2008 14:33:10 -0400, John covici wrote:

> Hi. I just emerged the firefox 3.0 which required a new version also
> of xulrunner. Now if I run revdep-rebuild, it wants to downgrade both
> of these packages.

xulrunner is slotted, so you may need 1.8 and 1.9 installed. Packages
built with -xulrunner in USE generally depend on firefox2, so make sure
you have xulrunner in your global USE flags, and no -xulrunner entries
in /etc/portage/package.use.


--
Neil Bothwick

Portable: Survives system reboot.
 
Old 07-10-2008, 10:08 PM
Joshua D Doll
 
Default revdep-rebuild wants to downgrade packages!

John covici wrote:

Hi. I just emerged the firefox 3.0 which required a new version also
of xulrunner. Now if I run revdep-rebuild, it wants to downgrade both
of these packages.

A number of packages seem to depend on libnss3.so.11 libsmime3.so.11
libssl3.so.11 . How can I resolve this conflict?

Thanks in advance for any ideas on this.


I believe you want to run revdep-rebuild with the -X option flag. Also
make sure you're using the xulrunner use flag instead of the firefox use
flag.


--Joshua Doll
--
gentoo-user@lists.gentoo.org mailing list
 
Old 07-10-2008, 10:24 PM
John covici
 
Default revdep-rebuild wants to downgrade packages!

on Thursday 07/10/2008 Joshua D Doll(joshua.doll@gmail.com) wrote
> John covici wrote:
> > Hi. I just emerged the firefox 3.0 which required a new version also
> > of xulrunner. Now if I run revdep-rebuild, it wants to downgrade both
> > of these packages.
> >
> > A number of packages seem to depend on libnss3.so.11 libsmime3.so.11
> > libssl3.so.11 . How can I resolve this conflict?
> >
> > Thanks in advance for any ideas on this.
> >
> >
> I believe you want to run revdep-rebuild with the -X option flag. Also
> make sure you're using the xulrunner use flag instead of the firefox use
> flag.
>

OK, that helped a lot, it still reports some evolution packages are
broke, but it does not rebuild them -- I don't use evolution much
anyway, so maybe it will get fixed in the next update.

Thanks much.

--
Your life is like a penny. You're going to lose it. The question is:
How do
you spend it?

John Covici
covici@ccs.covici.com
--
gentoo-user@lists.gentoo.org mailing list
 
Old 07-11-2008, 05:31 AM
Dirk Heinrichs
 
Default revdep-rebuild wants to downgrade packages!

Am Donnerstag, 10. Juli 2008 schrieb ext John covici:
> Hi. I just emerged the firefox 3.0 which required a new version also
> of xulrunner. Now if I run revdep-rebuild, it wants to downgrade both
> of these packages.
>
> A number of packages seem to depend on libnss3.so.11 libsmime3.so.11
> libssl3.so.11 . How can I resolve this conflict?
>
> Thanks in advance for any ideas on this.

I had this because of OpenOffice, which was emerged with "firefox" use flag.
In this case it wants firefox 2. I replaced the firefox use flag with
xulrunner and everything was fine.

HTH...

Dirk
--
Dirk Heinrichs | Tel: +49 (0)162 234 3408
Configuration Manager | Fax: +49 (0)211 47068 111
Capgemini Deutschland | Mail: dirk.heinrichs@capgemini.com
Wanheimerstraße 68 | Web: http://www.capgemini.com
D-40468 Düsseldorf | ICQ#: 110037733
GPG Public Key C2E467BB | Keyserver: wwwkeys.pgp.net
 

Thread Tools




All times are GMT. The time now is 12:04 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org