FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 06-23-2008, 07:34 PM
"Kevin O'Gorman"
 
Default gnucash pulls in firefox (when I already have firefox-bin)

On Mon, Jun 23, 2008 at 12:22 PM, Mark Knecht <markknecht@gmail.com> wrote:

On Mon, Jun 23, 2008 at 12:16 PM, Kevin O'Gorman <kogorman@gmail.com> wrote:

> I'm having trouble blocking gnucash from pulling in the full-compiled

> version of firefox.

> I've got package.provided with

> www-client/mozilla-firefox

> www-client/mozilla-firefox-2.0.0.14

>

> but it still insists on pulling in the ebuild. *How do I stop this?

>

> --

> Kevin O'Gorman, PhD

>



Try putting Firefox in the package.provided file.


I think I mentioned I already did that.* There's a slight typo in that there's an "=" before the one with a version number.

++ kevin



Cheers,

Mark

--

gentoo-user@lists.gentoo.org mailing list





--
Kevin O'Gorman, PhD
 
Old 06-23-2008, 07:39 PM
"Kevin O'Gorman"
 
Default gnucash pulls in firefox (when I already have firefox-bin)

I think I mentioned I already did that.* There's a slight typo in that there's an "=" before the one with a version number.


++ kevin

In fact, portage is driving me slightly nuts (or nuttier) over this.

When I as for --tree, I get

*
treat Virtual Machines # emerge -at gnucash


These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild* N*** ] app-office/gnucash-2.2.3* USE="quotes -chipcard -debug -hbci -ofx"
[ebuild* N*** ]* app-doc/gnucash-docs-2.2.0

[ebuild* N*** ]** gnome-extra/yelp-2.20.0* USE="-beagle -debug -xulrunner"
[ebuild* N*** ]*** www-client/mozilla-firefox-2.0.0.14* USE="gnome ipv6 java -bindist -debug -filepicker -iceweasel -mozdevelop -moznopango -restrict-_javascript_ -xforms -xinerama -xprint" LINGUAS="de en es fr pl -af -ar -be -bg -ca -cs -da -el -en_GB -en_US -es_AR -es_ES -eu -fi -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -it -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pt -pt_BR -pt_PT -ro -ru -sk -sl -sv -sv_SE -tr -uk -zh -zh_CN -zh_TW"


But when I try to find more about yelp, it denies needing it:
treat portage # equery -C depends* gnome-extra/yelp
[ Searching for packages depending on gnome-extra/yelp... ]
treat portage # eix yelp


++ kevin

--
Kevin O'Gorman, PhD
 
Old 06-23-2008, 07:55 PM
"Kevin O'Gorman"
 
Default gnucash pulls in firefox (when I already have firefox-bin)

On Mon, Jun 23, 2008 at 12:39 PM, Kevin O'Gorman <kogorman@gmail.com> wrote:


I think I mentioned I already did that.* There's a slight typo in that there's an "=" before the one with a version number.



++ kevin

In fact, portage is driving me slightly nuts (or nuttier) over this.

When I as for --tree, I get

*
treat Virtual Machines # emerge -at gnucash



These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild* N*** ] app-office/gnucash-2.2.3* USE="quotes -chipcard -debug -hbci -ofx"
[ebuild* N*** ]* app-doc/gnucash-docs-2.2.0


[ebuild* N*** ]** gnome-extra/yelp-2.20.0* USE="-beagle -debug -xulrunner"
[ebuild* N*** ]*** www-client/mozilla-firefox-2.0.0.14* USE="gnome ipv6 java -bindist -debug -filepicker -iceweasel -mozdevelop -moznopango -restrict-_javascript_ -xforms -xinerama -xprint" LINGUAS="de en es fr pl -af -ar -be -bg -ca -cs -da -el -en_GB -en_US -es_AR -es_ES -eu -fi -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -it -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pt -pt_BR -pt_PT -ro -ru -sk -sl -sv -sv_SE -tr -uk -zh -zh_CN -zh_TW"



But when I try to find more about yelp, it denies needing it:
treat portage # equery -C depends* gnome-extra/yelp
[ Searching for packages depending on gnome-extra/yelp... ]
treat portage # eix yelp



++ kevin

--
Kevin O'Gorman, PhD



--
Kevin O'Gorman, PhD
 
Old 06-23-2008, 08:58 PM
Miika Linnapuomi
 
Default gnucash pulls in firefox (when I already have firefox-bin)

Mon, 23 Jun 2008 12:55:51 -0700
"Kevin O'Gorman" <kogorman@gmail.com> wrote:

> On Mon, Jun 23, 2008 at 12:39 PM, Kevin O'Gorman <kogorman@gmail.com>
> wrote:
>
> >
> > I think I mentioned I already did that. There's a slight typo in
> > that
> >> there's an "=" before the one with a version number.
> >>
> >> ++ kevin
> >>
> >>> In fact, portage is driving me slightly nuts (or nuttier) over
> >>> this.
> >
> > When I as for --tree, I get
> >
> >
> > treat Virtual Machines # emerge -at gnucash
> >
> > These are the packages that would be merged, in reverse order:
> >
> > Calculating dependencies... done!
> > [ebuild N ] app-office/gnucash-2.2.3 USE="quotes -chipcard
> > -debug -hbci -ofx"
> > [ebuild N ] app-doc/gnucash-docs-2.2.0
> > [ebuild N ] gnome-extra/yelp-2.20.0 USE="-beagle -debug
> > -xulrunner" [ebuild N ] www-client/mozilla-firefox-2.0.0.14
> > USE="gnome ipv6 java -bindist -debug -filepicker -iceweasel
> > -mozdevelop -moznopango -restrict-javascript -xforms -xinerama
> > -xprint" LINGUAS="de en es fr pl -af -ar -be -bg -ca -cs -da -el
> > -en_GB -en_US -es_AR -es_ES -eu -fi -fy -fy_NL -ga -ga_IE -gu
> > -gu_IN -he -hu -it -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn
> > -nn_NO -pa -pa_IN -pt -pt_BR -pt_PT -ro -ru -sk -sl -sv -sv_SE -tr
> > -uk -zh -zh_CN -zh_TW"
> >
> >
> > But when I try to find more about yelp, it denies needing it:
> > treat portage # equery -C depends gnome-extra/yelp
> > [ Searching for packages depending on gnome-extra/yelp... ]
> > treat portage # eix yelp
> >
> > ++ kevin
> >
> > --
> > Kevin O'Gorman, PhD
> >
>
>
>

Usually USE="xulrunner -firefox" is enough. In your emerge -t output,
yelp has -xulrunner, which probably is pulling in firefox

Hope that helps

Miika
 
Old 06-23-2008, 11:17 PM
Neil Bothwick
 
Default gnucash pulls in firefox (when I already have firefox-bin)

On Mon, 23 Jun 2008 12:39:12 -0700, Kevin O'Gorman wrote:

> treat Virtual Machines # emerge -at gnucash
>
> These are the packages that would be merged, in reverse order:
>
> Calculating dependencies... done!
> [ebuild N ] app-office/gnucash-2.2.3 USE="quotes -chipcard -debug
> -hbci -ofx"
> [ebuild N ] app-doc/gnucash-docs-2.2.0
> [ebuild N ] gnome-extra/yelp-2.20.0 USE="-beagle -debug
> -xulrunner" [ebuild N ] www-client/mozilla-firefox-2.0.0.14
> USE="gnome ipv6 java

yelp is pulling in firefox because you do not have xulrunner in USE.
firefox-bin is no use, the program needs the header files for either
firefox or xulrunner. The current recommendation is to use xulrunner
instead of firefox in this situation, and in your USE flags.


--
Neil Bothwick

If at first you don't succeed, redefine success.
 
Old 06-24-2008, 04:09 AM
"Kevin O'Gorman"
 
Default gnucash pulls in firefox (when I already have firefox-bin)

On Mon, Jun 23, 2008 at 4:17 PM, Neil Bothwick <neil@digimed.co.uk> wrote:

On Mon, 23 Jun 2008 12:39:12 -0700, Kevin O'Gorman wrote:



> treat Virtual Machines # emerge -at gnucash

>

> These are the packages that would be merged, in reverse order:

>

> Calculating dependencies... done!

> [ebuild *N * *] app-office/gnucash-2.2.3 *USE="quotes -chipcard -debug

> -hbci -ofx"

> [ebuild *N * *] *app-doc/gnucash-docs-2.2.0

> [ebuild *N * *] * gnome-extra/yelp-2.20.0 *USE="-beagle -debug

> -xulrunner" [ebuild *N * *] * *www-client/mozilla-firefox-2.0.0.14

> USE="gnome ipv6 java



yelp is pulling in firefox because you do not have xulrunner in USE.

firefox-bin is no use, the program needs the header files for either

firefox or xulrunner. The current recommendation is to use xulrunner

instead of firefox in this situation, and in your USE flags.



This makes sense,* but I thought I already had that covered.* Here are the two USE lines in my
/etc/make.conf -- note the last few entries in the main one.


USE="Xaw3d aim apache2 apm bash-completion bcmath -bluetooth calendar caps cscope ctype dbm exif fastcgi foomaticdb gphoto2 guile icq imap imlib java joystick libwww mailwrapper mbox mcal mime mmap mmx motif mpi mysql nis nsplugin odbc offensive openal oscar pic posix postgres ppds ruby samba snmp sockets sse ssl svga symlink sysvipc tetex usb xpm xulrunner yahoo -firefox -seamonkey"

USE="$USE tk"********** # Mostly so that python supports fetchmailconf

I'll try explicitly tweaking the yelp USE flags, but it looks to me like some weirdness...
++ kevin


--
Kevin O'Gorman, PhD
 
Old 06-24-2008, 04:57 PM
Dan Johansson
 
Default gnucash pulls in firefox (when I already have firefox-bin)

On Tuesday 24 June 2008, Kevin O'Gorman wrote:
> On Mon, Jun 23, 2008 at 4:17 PM, Neil Bothwick <neil@digimed.co.uk> wrote:
> > On Mon, 23 Jun 2008 12:39:12 -0700, Kevin O'Gorman wrote:
> > > treat Virtual Machines # emerge -at gnucash
> > >
> > > These are the packages that would be merged, in reverse order:
> > >
> > > Calculating dependencies... done!
> > > [ebuild N ] app-office/gnucash-2.2.3 USE="quotes -chipcard -debug
> > > -hbci -ofx"
> > > [ebuild N ] app-doc/gnucash-docs-2.2.0
> > > [ebuild N ] gnome-extra/yelp-2.20.0 USE="-beagle -debug
> > > -xulrunner" [ebuild N ] www-client/mozilla-firefox-2.0.0.14
> > > USE="gnome ipv6 java
> >
> > yelp is pulling in firefox because you do not have xulrunner in USE.
> > firefox-bin is no use, the program needs the header files for either
> > firefox or xulrunner. The current recommendation is to use xulrunner
> > instead of firefox in this situation, and in your USE flags.
>
> This makes sense, but I thought I already had that covered. Here are the
> two USE lines in my
> /etc/make.conf -- note the last few entries in the main one.
>
> USE="Xaw3d aim apache2 apm bash-completion bcmath -bluetooth calendar caps
> cscope ctype dbm exif fastcgi foomaticdb gphoto2 guile icq imap imlib java
> joystick libwww mailwrapper mbox mcal mime mmap mmx motif mpi mysql nis
> nsplugin odbc offensive openal oscar pic posix postgres ppds ruby samba
> snmp sockets sse ssl svga symlink sysvipc tetex usb xpm xulrunner yahoo
> -firefox -seamonkey"

Is all this on one line and the MUA has folded the line or are you missing the
on each line?

--
Dan Johansson, <http://www.dmj.nu>
************************************************** *
This message is printed on 100% recycled electrons!
************************************************** *
--
gentoo-user@lists.gentoo.org mailing list
 
Old 06-25-2008, 10:40 PM
Allan Gottlieb
 
Default gnucash pulls in firefox (when I already have firefox-bin)

At Tue, 24 Jun 2008 00:17:36 +0100 Neil Bothwick <neil@digimed.co.uk> wrote:

> yelp is pulling in firefox because you do not have xulrunner in USE.
> firefox-bin is no use, the program needs the header files for either
> firefox or xulrunner. The current recommendation is to use xulrunner
> instead of firefox in this situation, and in your USE flags.

Neil,

I am currently having no problems. I use gnucash extensively and use
firefox (not -bin) as well. Is the recommendation to switch and add
xulrunner to USE? If the purpose is to avoid the need for firefox,
that is not relevant to me. If, however, xulrunner in some way
improves gnucash, I might well want to try it.

thanks in advance and thanks for all your previous help and thoughtful
comments.

allan
--
gentoo-user@lists.gentoo.org mailing list
 
Old 06-25-2008, 11:14 PM
Neil Bothwick
 
Default gnucash pulls in firefox (when I already have firefox-bin)

On Wed, 25 Jun 2008 18:40:41 -0400, Allan Gottlieb wrote:

> > yelp is pulling in firefox because you do not have xulrunner in USE.
> > firefox-bin is no use, the program needs the header files for either
> > firefox or xulrunner. The current recommendation is to use xulrunner
> > instead of firefox in this situation, and in your USE flags.

> I am currently having no problems. I use gnucash extensively and use
> firefox (not -bin) as well. Is the recommendation to switch and add
> xulrunner to USE? If the purpose is to avoid the need for firefox,
> that is not relevant to me. If, however, xulrunner in some way
> improves gnucash, I might well want to try it.

It is to avoid the need for Firefox 2 installed from source, which is a
problem if you use Firefox 3 or firefox-bin. the xulrunner flag make
GnuCash, and other apps, build against xunrunner instead of the firefox 2
headers.

--
Neil Bothwick

Top Oxymorons Number 22: Childproof
 
Old 06-25-2008, 11:46 PM
"James Ausmus"
 
Default gnucash pulls in firefox (when I already have firefox-bin)

On Wed, Jun 25, 2008 at 4:14 PM, Neil Bothwick <neil@digimed.co.uk> wrote:
> On Wed, 25 Jun 2008 18:40:41 -0400, Allan Gottlieb wrote:
>
>> > yelp is pulling in firefox because you do not have xulrunner in USE.
>> > firefox-bin is no use, the program needs the header files for either
>> > firefox or xulrunner. The current recommendation is to use xulrunner
>> > instead of firefox in this situation, and in your USE flags.
>
>> I am currently having no problems. I use gnucash extensively and use
>> firefox (not -bin) as well. Is the recommendation to switch and add
>> xulrunner to USE? If the purpose is to avoid the need for firefox,
>> that is not relevant to me. If, however, xulrunner in some way
>> improves gnucash, I might well want to try it.
>
> It is to avoid the need for Firefox 2 installed from source, which is a
> problem if you use Firefox 3 or firefox-bin. the xulrunner flag make
> GnuCash, and other apps, build against xunrunner instead of the firefox 2
> headers.

Also, if you're going to use FF3, with xulrunner, FF3 will compile
against xulrunner, thus reducing the FF3 build to time to a few
minutes, as the LONG build already happened with xulrunner...

-James



>
> --
> Neil Bothwick
>
> Top Oxymorons Number 22: Childproof
>
--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 12:06 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org