FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 06-23-2008, 12:16 PM
Redouane Boumghar
 
Default Openssh and Zlib version check

Hello everyone,

I am trying to upgrade openssh from version 4.5_p1 to version 4.7_p1
but installation of version 4.7_p1 always crashes at the zlib version check.

openssh 4.7_p1 seems to require zlib version 1.2.3 or greater
that I did have installed since the dinosaurs disappeared.
I keep having this message :

"
checking for possibly buggy zlib... yes
configure: error: *** zlib too old - check config.log ***
"

Whereas my zlib version is : 1.2.3
Installed thanks to ebuild : sys-libs/zlib-1.2.3-r1

So should I hack the ebuild to take the given advice ? :

"./configure --without-zlib-version-check".

Has anyone solved that ? Or is it just my problem ?

Thanks in advance,

:-)
Redouane.

--
gentoo-user@lists.gentoo.org mailing list
 
Old 06-23-2008, 09:57 PM
Enrico Weigelt
 
Default Openssh and Zlib version check

* Redouane Boumghar <redouane.boumghar@magellium.fr> wrote:

Hi,

> I am trying to upgrade openssh from version 4.5_p1 to version 4.7_p1
> but installation of version 4.7_p1 always crashes at the zlib version check.
>
> openssh 4.7_p1 seems to require zlib version 1.2.3 or greater
> that I did have installed since the dinosaurs disappeared.
> I keep having this message :
>
> "
> checking for possibly buggy zlib... yes
> configure: error: *** zlib too old - check config.log ***
> "

Just have a look at openssl's configure.ac ... it's simply crap.
They still didn't learn how to write proper configure scripts.

File a bug the upstream and mask out that version.


cu
--
---------------------------------------------------------------------
Enrico Weigelt == metux IT service - http://www.metux.de/
---------------------------------------------------------------------
Please visit the OpenSource QM Taskforce:
http://wiki.metux.de/public/OpenSource_QM_Taskforce
Patches / Fixes for a lot dozens of packages in dozens of versions:
http://patches.metux.de/
---------------------------------------------------------------------
--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 06:37 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org