FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 06-17-2008, 05:53 PM
Grant
 
Default Downgrading glib

I downgraded from glib-2.17.2 to glib-2.14.6 and had problems so I
went back to 2.17.2. How can I make this downgrade successfully?

- Grant
--
gentoo-user@lists.gentoo.org mailing list
 
Old 06-17-2008, 06:22 PM
"Hemmann, Volker Armin"
 
Default Downgrading glib

On Dienstag, 17. Juni 2008, Grant wrote:
> I downgraded from glib-2.17.2 to glib-2.14.6 and had problems so I
> went back to 2.17.2. How can I make this downgrade successfully?
>
> - Grant

revdep-rebuilt afterwards?
--
gentoo-user@lists.gentoo.org mailing list
 
Old 06-18-2008, 01:16 AM
Grant
 
Default Downgrading glib

>> I downgraded from glib-2.17.2 to glib-2.14.6 and had problems so I
>> went back to 2.17.2. How can I make this downgrade successfully?
>>
>> - Grant
>
> revdep-rebuilt afterwards?

Yeah revdep-rebuild only comes up with transmission (which could have
needed a rebuild before messing with glib), and transmission fails to
build. The main problem is with gdm. It won't load with an
unresolved symbol error (I think) and won't rebuild either.

Would more specific errors be helpful here or should this be
approached a different way?

- Grant
--
gentoo-user@lists.gentoo.org mailing list
 
Old 06-18-2008, 03:25 AM
Volker Armin Hemmann
 
Default Downgrading glib

On Wednesday 18 June 2008, Grant wrote:
> >> I downgraded from glib-2.17.2 to glib-2.14.6 and had problems so I
> >> went back to 2.17.2. How can I make this downgrade successfully?
> >>
> >> - Grant
> >
> > revdep-rebuilt afterwards?
>
> Yeah revdep-rebuild only comes up with transmission (which could have
> needed a rebuild before messing with glib), and transmission fails to
> build. The main problem is with gdm. It won't load with an
> unresolved symbol error (I think) and won't rebuild either.
>
> Would more specific errors be helpful here or should this be
> approached a different way?

you could grep for the old lib in /usr and rebuild everything which has its
name somewhere.
--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 09:23 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org