Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   Emerge -puv really slow? (http://www.linux-archive.org/gentoo-user/107060-emerge-puv-really-slow.html)

Paul Sobey 06-15-2008 08:40 AM

Emerge -puv really slow?
 
For the last couple of weeks I've noticed that emerge -puv world takes
an absolute age on my machine (currently at 5 mins and counting), while
the cpu gows to 100%. The little emerge rotator bar that spins while it
calculates dependencies moves extremely slowly. Is there any known bug
that causes this? How can I go about troubleshooting?


Cheers,
Paul
--
gentoo-user@lists.gentoo.org mailing list

Daniel Pielmeier 06-15-2008 09:21 AM

Emerge -puv really slow?
 
Paul Sobey schrieb:
For the last couple of weeks I've noticed that emerge -puv world takes
an absolute age on my machine (currently at 5 mins and counting), while
the cpu gows to 100%. The little emerge rotator bar that spins while it
calculates dependencies moves extremely slowly. Is there any known bug
that causes this? How can I go about troubleshooting?


Cheers,
Paul



My guess is you have removed the portage-cache before using emerge.
Normally this happens when a previous emerge --sync fails because of an
error or there are identical timestamps on the server and the local machine.


When this happens you have no portage-cache because portage deletes the
cache first when syncing. If the timestamps are identical the cache is
not regenerated. If there is an error while syncing the cache is missing
too, because the regeneration of the cache is done in the end of the sync.


So the cache is regenerated when doing the first emerge and this takes
quite a while. Even on a Core2Duo 6600@2.40GHz i takes more then three
minutes :-).


In case of the timestamp issue i think it is a bug [1]. I think portage
should first check the timestamps and if they are different it should
delete the cache!


[1] http://bugs.gentoo.org/show_bug.cgi?id=202535

Regards,

Daniel
--
gentoo-user@lists.gentoo.org mailing list

Paul Sobey 06-15-2008 06:55 PM

Emerge -puv really slow?
 
Daniel Pielmeier wrote:

Paul Sobey schrieb:
For the last couple of weeks I've noticed that emerge -puv world takes
an absolute age on my machine (currently at 5 mins and counting),
while the cpu gows to 100%. The little emerge rotator bar that spins
while it calculates dependencies moves extremely slowly. Is there any
known bug that causes this? How can I go about troubleshooting?


Cheers,
Paul



My guess is you have removed the portage-cache before using emerge.
Normally this happens when a previous emerge --sync fails because of an
error or there are identical timestamps on the server and the local
machine.


When this happens you have no portage-cache because portage deletes the
cache first when syncing. If the timestamps are identical the cache is
not regenerated. If there is an error while syncing the cache is missing
too, because the regeneration of the cache is done in the end of the sync.


So the cache is regenerated when doing the first emerge and this takes
quite a while. Even on a Core2Duo 6600@2.40GHz i takes more then three
minutes :-).


In case of the timestamp issue i think it is a bug [1]. I think portage
should first check the timestamps and if they are different it should
delete the cache!


Interesting idea - I've been running eix-sync in my crontab. Perhaps
that hasn't been updating the edb cache. I've changed it eix-sync -r,
perhaps that will fix things.


Paul

--
gentoo-user@lists.gentoo.org mailing list

"Paul Sobey" 06-17-2008 08:48 AM

Emerge -puv really slow?
 
> Daniel Pielmeier wrote:
>> In case of the timestamp issue i think it is a bug [1]. I think portage
>> should first check the timestamps and if they are different it should
>> delete the cache!
>
> Interesting idea - I've been running eix-sync in my crontab. Perhaps
> that hasn't been updating the edb cache. I've changed it eix-sync -r,
> perhaps that will fix things.

Follow up - you were spot on. I have my server --sync every Friday
evening, and my desktop was syncing against that on a daily basis. Thanks
for your help, that was driving me nuts.

Paul


--
gentoo-user@lists.gentoo.org mailing list


All times are GMT. The time now is 03:57 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.