FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 06-14-2008, 03:17 PM
Peter Wood
 
Default emerge does not update

Hi,
I just ran eix-sync and it informs me that there are updates available
for 2 packages (Archiv-Tar and Archive-Zip). Both packages are pulled in
by othe packages that are either in world or system. The current
versions are not locked anywhere, nor are the new ones masked as far as
I can tell. Still,

emerge --update --deep world
and
emerge --update --deep system
tell me that there are no updates to install.
I did emerge --metadata and emerge --regen, but the result is the same.
Does anybody have any idea what I might be doing wrong?
Thanks,
Peter
--
gentoo-user@lists.gentoo.org mailing list
 
Old 06-14-2008, 03:23 PM
"Edward Hades"
 
Default emerge does not update

I don't know what the underlying cause is, I've asked multiple times
of it, but got no reply. The portage does miss some of the updatable
packages.

I can only recommend something like 'eix -u --only-names | xargs
emerge -u', or less automated 'emerge -pev world | grep " U "', then
emerge listed packages.

On Sat, Jun 14, 2008 at 7:17 PM, Peter Wood <p2wood@uwaterloo.ca> wrote:
> Hi,
> I just ran eix-sync and it informs me that there are updates available for 2
> packages (Archiv-Tar and Archive-Zip). Both packages are pulled in by othe
> packages that are either in world or system. The current versions are not
> locked anywhere, nor are the new ones masked as far as I can tell. Still,
> emerge --update --deep world
> and
> emerge --update --deep system
> tell me that there are no updates to install.
> I did emerge --metadata and emerge --regen, but the result is the same.
> Does anybody have any idea what I might be doing wrong?
> Thanks,
> Peter
> --
> gentoo-user@lists.gentoo.org mailing list
>
>



--
Henny Youngman - "When I told my doctor I couldn't afford an
operation, he offered to touch-up my X-rays."
--
gentoo-user@lists.gentoo.org mailing list
 
Old 06-14-2008, 03:40 PM
Peter Alfredsen
 
Default emerge does not update

On Saturday 14 June 2008, Peter Wood wrote:
> Hi,
> I just ran eix-sync and it informs me that there are updates
> available for 2 packages (Archiv-Tar and Archive-Zip). Both packages
> are pulled in by othe packages that are either in world or system.
> The current versions are not locked anywhere, nor are the new ones
> masked as far as I can tell. Still,
> emerge --update --deep world
> and
> emerge --update --deep system
> tell me that there are no updates to install.
> I did emerge --metadata and emerge --regen, but the result is the
> same. Does anybody have any idea what I might be doing wrong?

Does
emerge --with-bdeps y -uDNav world
Do it for you?

The problem comes from Portage not updating build-dependencies until a
package is rebuilt. --with-bdeps y makes portage consider both build
and runtime-dependencies.

--
/PA
 
Old 06-15-2008, 03:09 AM
Peter Wood
 
Default emerge does not update

Thanks Peter,
yes, with-bdeps pulls the packes in that were ignored before.


Peter Alfredsen wrote:

On Saturday 14 June 2008, Peter Wood wrote:


Hi,
I just ran eix-sync and it informs me that there are updates
available for 2 packages (Archiv-Tar and Archive-Zip). Both packages
are pulled in by othe packages that are either in world or system.
The current versions are not locked anywhere, nor are the new ones
masked as far as I can tell. Still,
emerge --update --deep world
and
emerge --update --deep system
tell me that there are no updates to install.
I did emerge --metadata and emerge --regen, but the result is the
same. Does anybody have any idea what I might be doing wrong?



Does
emerge --with-bdeps y -uDNav world
Do it for you?


The problem comes from Portage not updating build-dependencies until a
package is rebuilt. --with-bdeps y makes portage consider both build
and runtime-dependencies.




--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 01:23 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org