FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo User

 
 
LinkBack Thread Tools
 
Old 06-08-2008, 10:52 AM
"Dirk Uys"
 
Default Subversion emerge fails

Hi everyone.

When I emerge subversion, i get the following error:

<snip>
checking for availability of Berkeley DB... no
configure: error: Berkeley DB 4.0.14 wasn't found.

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/dev-util/subversion-1.5.0_rc5/work/subversion-1.5.0-rc5/config.log
*
* ERROR: dev-util/subversion-1.5.0_rc5 failed.
...
</snip>

Here is the output of eix sys-libs/db:

<snip>
[D] sys-libs/db
Available versions:
(1) *1.85-r1 1.85-r3
(3) 3.2.9-r11
(4.2) 4.2.52_p4-r2
(4.3) 4.3.29-r2
(4.4) (~)4.4.20_p4
(4.5) 4.5.20_p2
(4.6) (~)4.6.19 (~)4.6.21
{bootstrap doc elibc_FreeBSD java nocxx tcl test}
Installed versions: 4.3.29-r2(4.3)(02:52:26 04/20/07)(-bootstrap
-doc -elibc_FreeBSD -java -nocxx -tcl -test)
4.5.20_p2(4.5)(22:43:07 04/14/08)(-bootstrap
-doc -elibc_FreeBSD -java -nocxx -tcl -test)
4.6.21_p1(4.6)(20:12:09 06/07/08)(-bootstrap
-doc -elibc_FreeBSD -java -nocxx -tcl -test)
Homepage:
http://www.oracle.com/technology/software/products/berkeley-db/index.html
Description: Oracle Berkeley DB
</snip>

I'm running ~x86, so I don't expect things to always work. Is this a
bug, or is there something else wrong?

Regards
Dirk
--
gentoo-user@lists.gentoo.org mailing list
 
Old 06-09-2008, 07:37 AM
Florian Philipp
 
Default Subversion emerge fails

On Sun, 8 Jun 2008 12:52:03 +0200
"Dirk Uys" <dirkcuys@gmail.com> wrote:

> Hi everyone.
>
> When I emerge subversion, i get the following error:
>
> <snip>
> checking for availability of Berkeley DB... no
> configure: error: Berkeley DB 4.0.14 wasn't found.
>
> !!! Please attach the following file when seeking support:
> !!! /var/tmp/portage/dev-util/subversion-1.5.0_rc5/work/subversion-1.5.0-rc5/config.log
> *
> * ERROR: dev-util/subversion-1.5.0_rc5 failed.
> ...
> </snip>
>
> Here is the output of eix sys-libs/db:
>
> <snip>
> [D] sys-libs/db
> Available versions:
> (1) *1.85-r1 1.85-r3
> (3) 3.2.9-r11
> (4.2) 4.2.52_p4-r2
> (4.3) 4.3.29-r2
> (4.4) (~)4.4.20_p4
> (4.5) 4.5.20_p2
> (4.6) (~)4.6.19 (~)4.6.21
> {bootstrap doc elibc_FreeBSD java nocxx tcl test}
> Installed versions: 4.3.29-r2(4.3)(02:52:26 04/20/07)(-bootstrap
> -doc -elibc_FreeBSD -java -nocxx -tcl -test)
> 4.5.20_p2(4.5)(22:43:07 04/14/08)(-bootstrap
> -doc -elibc_FreeBSD -java -nocxx -tcl -test)
> 4.6.21_p1(4.6)(20:12:09 06/07/08)(-bootstrap
> -doc -elibc_FreeBSD -java -nocxx -tcl -test)
> Homepage:
> http://www.oracle.com/technology/software/products/berkeley-db/index.html
> Description: Oracle Berkeley DB
> </snip>
>
> I'm running ~x86, so I don't expect things to always work. Is this a
> bug, or is there something else wrong?
>
> Regards
> Dirk


Why don't you just disable the berkdb USE-flag? The usage of
subversion's database backend is discouraged anyway (for most use
cases).
 
Old 06-10-2008, 05:55 PM
Enrico Weigelt
 
Default Subversion emerge fails

* Dirk Uys <dirkcuys@gmail.com> wrote:
> Hi everyone.
>
> When I emerge subversion, i get the following error:
>
> <snip>
> checking for availability of Berkeley DB... no
> configure: error: Berkeley DB 4.0.14 wasn't found.

hmm, probably

a) broken ebuild (missing bdb dep)
b) broken ./configure script (which can't find existing bdb)


cu
--
---------------------------------------------------------------------
Enrico Weigelt == metux IT service - http://www.metux.de/
---------------------------------------------------------------------
Please visit the OpenSource QM Taskforce:
http://wiki.metux.de/public/OpenSource_QM_Taskforce
Patches / Fixes for a lot dozens of packages in dozens of versions:
http://patches.metux.de/
---------------------------------------------------------------------
--
gentoo-user@lists.gentoo.org mailing list
 
Old 06-11-2008, 12:17 PM
"Dirk Uys"
 
Default Subversion emerge fails

> hmm, probably
>
> a) broken ebuild (missing bdb dep)
> b) broken ./configure script (which can't find existing bdb)
>
>
> cu
> --
> ---------------------------------------------------------------------
> Enrico Weigelt == metux IT service - http://www.metux.de/

For now I masked the version of subversion giving the problems, I only
occasionally use subversion on that machine. I would however like to
contribute if it's something useful. Should I log a bug for this, or
wouldn't there be many people trying to emerge subversion with berkly
db support?

Regards
Dirk
--
gentoo-user@lists.gentoo.org mailing list
 
Old 06-11-2008, 01:09 PM
Florian Philipp
 
Default Subversion emerge fails

On Wed, 11 Jun 2008 14:17:44 +0200
"Dirk Uys" <dirkcuys@gmail.com> wrote:

> > hmm, probably
> >
> > a) broken ebuild (missing bdb dep)
> > b) broken ./configure script (which can't find existing bdb)
> >
> >
> > cu
> > --
> > ---------------------------------------------------------------------
> > Enrico Weigelt == metux IT service - http://www.metux.de/
>
> For now I masked the version of subversion giving the problems, I only
> occasionally use subversion on that machine. I would however like to
> contribute if it's something useful. Should I log a bug for this, or
> wouldn't there be many people trying to emerge subversion with berkly
> db support?
>
> Regards
> Dirk

Sure, post it. It's clearly a bug. Every little piece helps
 
Old 06-11-2008, 07:53 PM
"Dirk Uys"
 
Default Subversion emerge fails

On Wed, Jun 11, 2008 at 3:09 PM, Florian Philipp
<lists@f_philipp.fastmail.net> wrote:
> On Wed, 11 Jun 2008 14:17:44 +0200
> "Dirk Uys" <dirkcuys@gmail.com> wrote:
>
>>
>> For now I masked the version of subversion giving the problems, I only
>> occasionally use subversion on that machine. I would however like to
>> contribute if it's something useful. Should I log a bug for this, or
>> wouldn't there be many people trying to emerge subversion with berkly
>> db support?
>>
>> Regards
>> Dirk
>
> Sure, post it. It's clearly a bug. Every little piece helps
>

The bug is already filed (221185). Turns out you have to emerge
apr-utils. Next time I'll check bugzilla first.

So much for filing my first bug.

Regards
Dirk
--
gentoo-user@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 07:55 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org