Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo User (http://www.linux-archive.org/gentoo-user/)
-   -   x86_64 apache problem (http://www.linux-archive.org/gentoo-user/10175-x86_64-apache-problem.html)

David Relson 12-01-2007 09:09 PM

x86_64 apache problem
 
"/etc/init.d/apache2 start" runs without any output

"/etc/init.d/apache2 status" then reports:

* status: stopped

Looking up localhost
Making HTTP connection to localhost
Alert!: Unable to connect to remote host.

lynx: Can't access startfile http://localhost/server-status

"/etc/init.d/apache2 configtest" seems happy:

* Checking Apache Configuration ...
[ ok ]

"/etc/init.d/apache2 graceful" also seems happy

* Gracefully restarting apache2 ...
[ ok ]

"/etc/init.d/apache2 modules" reports 49 modules plus "Syntax OK".

Even with "start", "configtest", and "graceful" reporting no errors,
apache isn't running.

What am I overlooking?

Regards,

David

FWIW, my cpu is an AMD 64 X2 5000, kernel is 2.6.22-gentoo-r9 (SMP),
apache version is 2.2.6.>
--
gentoo-user@gentoo.org mailing list

Mick 12-02-2007 02:12 PM

x86_64 apache problem
 
On Saturday 01 December 2007, David Relson wrote:
> "/etc/init.d/apache2 start" runs without any output
>
> "/etc/init.d/apache2 status" then reports:
>
> * status: stopped
>
> Looking up localhost
> Making HTTP connection to localhost
> Alert!: Unable to connect to remote host.
>
> lynx: Can't access startfile http://localhost/server-status
>
> "/etc/init.d/apache2 configtest" seems happy:
>
> * Checking Apache Configuration ...
> [ ok ]
>
> "/etc/init.d/apache2 graceful" also seems happy
>
> * Gracefully restarting apache2 ...
> [ ok ]
>
> "/etc/init.d/apache2 modules" reports 49 modules plus "Syntax OK".
>
> Even with "start", "configtest", and "graceful" reporting no errors,
> apache isn't running.
>
> What am I overlooking?
>
> Regards,
>
> David
>
> FWIW, my cpu is an AMD 64 X2 5000, kernel is 2.6.22-gentoo-r9 (SMP),
> apache version is 2.2.6.>

I get the same result like you. This is because I do not have a file called
server-status:

# ls -la /var/www/localhost/
total 6
drwxr-xr-x 6 apache apache 144 Aug 9 07:46 .
drwxr-xr-x 5 root root 136 Aug 23 22:05 ..
drwxr-xr-x 2 apache apache 144 Oct 13 15:26 cgi-bin
drwxr-xr-x 3 apache apache 976 Aug 9 07:46 error
drwxr-xr-x 3 apache apache 1432 Oct 14 11:26 htdocs
drwxr-xr-x 3 apache apache 4600 Aug 9 07:46 icons

However, launching links on the server and going to the LAN IP address of the
server I get the apache index.html page.
--
Regards,
Mick

David Relson 12-02-2007 03:10 PM

x86_64 apache problem
 
On Sun, 2 Dec 2007 15:12:33 +0000
Mick wrote:

> On Saturday 01 December 2007, David Relson wrote:
> > "/etc/init.d/apache2 start" runs without any output
> >
> > "/etc/init.d/apache2 status" then reports:
> >
> > * status: stopped
> >
> > Looking up localhost
> > Making HTTP connection to localhost
> > Alert!: Unable to connect to remote host.
> >
> > lynx: Can't access startfile http://localhost/server-status
> >
> > "/etc/init.d/apache2 configtest" seems happy:
> >
> > * Checking Apache Configuration ...
> > [ ok ]
> >
> > "/etc/init.d/apache2 graceful" also seems happy
> >
> > * Gracefully restarting apache2 ...
> > [ ok ]
> >
> > "/etc/init.d/apache2 modules" reports 49 modules plus "Syntax OK".
> >
> > Even with "start", "configtest", and "graceful" reporting no errors,
> > apache isn't running.
> >
> > What am I overlooking?
> >
> > Regards,
> >
> > David
> >
> > FWIW, my cpu is an AMD 64 X2 5000, kernel is 2.6.22-gentoo-r9 (SMP),
> > apache version is 2.2.6.>
>
> I get the same result like you. This is because I do not have a file
> called server-status:
>
> # ls -la /var/www/localhost/
> total 6
> drwxr-xr-x 6 apache apache 144 Aug 9 07:46 .
> drwxr-xr-x 5 root root 136 Aug 23 22:05 ..
> drwxr-xr-x 2 apache apache 144 Oct 13 15:26 cgi-bin
> drwxr-xr-x 3 apache apache 976 Aug 9 07:46 error
> drwxr-xr-x 3 apache apache 1432 Oct 14 11:26 htdocs
> drwxr-xr-x 3 apache apache 4600 Aug 9 07:46 icons
>
> However, launching links on the server and going to the LAN IP
> address of the server I get the apache index.html page.
> --
> Regards,
> Mick

Hi Mick,

That explains the "lynx can't access startfile ... server-status"
message. Have you any idea why apache doesn't start?

David

--
David Relson Osage Software Systems, Inc.
relson@osagesoftware.com Ann Arbor, MI 48103
www.osagesoftware.com tel: 734.821.8800
--
gentoo-user@gentoo.org mailing list


All times are GMT. The time now is 07:24 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.