FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor


 
 
LinkBack Thread Tools
 
Old 03-03-2011, 03:27 PM
Michael
 
Default Patch problem

Hi,

I'm playing around with writing a patch to allow emerge to automatically
resolve use deps.

The basics appear to be working:

Calculating dependencies... done!
[ebuild R ] x11-libs/qt-webkit-4.6.3-r1 USE="dbus exceptions pch* (-
aqua) -debug -kde*" 0 kB [0]
[ebuild N ] app-misc/mytest-1.0.0 USE="kde" 0 kB [1]

however, not quite:

The following USE changes are necessary to proceed:
#required by =app-misc/mytest-1.0.0, required by mytest (argument)
=x11-libs/qt-webkit-4.6.3-r1 pch


Any pointers in the right direction would be much appreciated.


-Michael
 

Thread Tools




All times are GMT. The time now is 01:35 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org