Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo Hardened (http://www.linux-archive.org/gentoo-hardened/)
-   -   hardened-sources and gradm (http://www.linux-archive.org/gentoo-hardened/639534-hardened-sources-gradm.html)

"Tóth Attila" 03-01-2012 08:26 PM

hardened-sources and gradm
 
I've installed hardened-sources-3.2.7 and gradm-2.9.201202232055.
After booting the kernel, I cannot change to the admin role, because the
system reports incompatible version of gradm and grsecurity. However the
RBAC system is still turned on.
Last time I got into version mismatch, the RBAC was not enabled, so I
shouldn't have to boot and older kernel.

Which version of gradm is ought to be compatbile with hardened-sources-3.2.7?

Regards,
Dw.
--
dr Tóth Attila, Radiológus, 06-20-825-8057
Attila Toth MD, Radiologist, +36-20-825-8057

"Anthony G. Basile" 03-02-2012 12:32 PM

hardened-sources and gradm
 
On 03/01/2012 04:26 PM, "Tóth Attila" wrote:

Which version of gradm is ought to be compatbile with hardened-sources-3.2.7?


h.s-3.2.7 needs gradm-2.9* Upstream just jumped to grsec 2.9 so I'm not
surprised that there may be bugs.


Can you please open a bug and I'll cc upstream on it. Include steps to
reproduce the issue and I'll try at my end and work with Brad to find
out what's going on.


--

"Tóth Attila" 03-02-2012 05:32 PM

hardened-sources and gradm
 
Dear Blueness,

I've opened a bug:
https://bugs.gentoo.org/show_bug.cgi?id=406633
I hope the symptoms can be reproduced.
I can also imagine, that this is actually a feature. Previously the system
left open in case of incompatible versions. It might make sense to try to
apply the policy despite the incompatible versions to keep the system
safer.

Regards:
Dw.
--
dr Tóth Attila, Radiológus, 06-20-825-8057
Attila Toth MD, Radiologist, +36-20-825-8057

2012.Március 2.(P) 14:32 idÅ‘pontban Anthony G. Basile ezt Ã*rta:
> On 03/01/2012 04:26 PM, "Tóth Attila" wrote:
>> Which version of gradm is ought to be compatbile with
>> hardened-sources-3.2.7?
>
> h.s-3.2.7 needs gradm-2.9* Upstream just jumped to grsec 2.9 so I'm not
> surprised that there may be bugs.
>
> Can you please open a bug and I'll cc upstream on it. Include steps to
> reproduce the issue and I'll try at my end and work with Brad to find
> out what's going on.
>
> --
>
>


All times are GMT. The time now is 05:28 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.