Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo Hardened (http://www.linux-archive.org/gentoo-hardened/)
-   -   "/usr/bin/install: cannot stat `id.mo': No such file or directory" when installing policycoreutils (http://www.linux-archive.org/gentoo-hardened/589133-usr-bin-install-cannot-stat-id-mo-no-such-file-directory-when-installing-policycoreutils.html)

"J. Roeleveld" 10-19-2011 12:32 PM

"/usr/bin/install: cannot stat `id.mo': No such file or directory" when installing policycoreutils
 
Hi All,

I am following the selinux-guide Sven updated recently on a VM with a
clean install.
I started with the hardened stage 3 as recommended and am using the latest
stable hardened sources.

At step 4.2.2 (Install policies and utilities) the emerge fails with the
error:

/usr/bin/install: cannot stat `id.mo': No such file or directory

for the policycoreutils.
The failure occurs during the install step.

On Google, I found this error in a debian bugreport [1]. Has anyone run
into this yet and is there a solution to this with Gentoo?

Many thanks,

Joost

[1] http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=640630

Sven Vermeulen 10-19-2011 12:35 PM

"/usr/bin/install: cannot stat `id.mo': No such file or directory" when installing policycoreutils
 
On Wed, Oct 19, 2011 at 02:32:14PM +0200, J. Roeleveld wrote:
> I am following the selinux-guide Sven updated recently on a VM with a
> clean install.
> I started with the hardened stage 3 as recommended and am using the latest
> stable hardened sources.
>
> At step 4.2.2 (Install policies and utilities) the emerge fails with the
> error:
>
> /usr/bin/install: cannot stat `id.mo': No such file or directory
>
> for the policycoreutils.
> The failure occurs during the install step.

Yes, this should be fixed in policycoreutils-2.0.82-r1 (and higher) but it
is still in ~arch. I'll see to it that it gets stabilized.

Wkr,
Sven Vermeulen

"J. Roeleveld" 10-19-2011 12:44 PM

"/usr/bin/install: cannot stat `id.mo': No such file or directory" when installing policycoreutils
 
On Wed, October 19, 2011 2:35 pm, Sven Vermeulen wrote:
> On Wed, Oct 19, 2011 at 02:32:14PM +0200, J. Roeleveld wrote:
>> I am following the selinux-guide Sven updated recently on a VM with a
>> clean install.
>> I started with the hardened stage 3 as recommended and am using the
>> latest
>> stable hardened sources.
>>
>> At step 4.2.2 (Install policies and utilities) the emerge fails with the
>> error:
>>
>> /usr/bin/install: cannot stat `id.mo': No such file or directory
>>
>> for the policycoreutils.
>> The failure occurs during the install step.
>
> Yes, this should be fixed in policycoreutils-2.0.82-r1 (and higher) but it
> is still in ~arch. I'll see to it that it gets stabilized.

Thanks. I'll continue my testing with "policycoreutils-2.0.82-r1".

--
Joost


All times are GMT. The time now is 09:33 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.