Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo Embedded (http://www.linux-archive.org/gentoo-embedded/)
-   -   ANNOUNCE: cross-capable nodejs-0.6.7.ebuild, v8-3.6.4.ebuild (http://www.linux-archive.org/gentoo-embedded/621896-announce-cross-capable-nodejs-0-6-7-ebuild-v8-3-6-4-ebuild.html)

Sergey Mironov 01-17-2012 01:26 PM

ANNOUNCE: cross-capable nodejs-0.6.7.ebuild, v8-3.6.4.ebuild
 
Hi. I've fixed arm-related cross-compiling issues in node.js ebuld (at least it works on arm system). Here they are:
nodejs-0.6.7.ebuild*https://github.com/ierton/uemd-overlay/blob/master/net-libs/nodejs/nodejs-0.6.7.ebuild
v8-3.6.4.ebuild*https://github.com/ierton/uemd-overlay/blob/master/dev-lang/v8/v8-3.6.4.ebuild
To make it work, I had to enable*armeabi=soft in the v8. Also nodejs-0.6.7 is known to not work with recent v8 - i've fixed RDEPEND.

Sergey


All times are GMT. The time now is 09:38 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.