FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Embedded

 
 
LinkBack Thread Tools
 
Old 09-20-2010, 07:01 PM
Joakim Tjernlund
 
Default where is libgcc_so.1?

Maybe I am just stupid (too long since I used crossdev) but
I cannot find libgcc_so.1 after building:
crossdev
-s3
--ex-gdb
--libc 2.11.2
--binutils 2.20.1-r1
--gcc 4.4.4-r2
--kernel 2.6.30-r1
--target powerpc-e300c2_softfloat-linux-gnu

As I recall NPTL want libgcc_so.1 no matter what I do. Isn't that
true in newer toolchains?

Jocke
 
Old 09-20-2010, 08:01 PM
Mike Frysinger
 
Default where is libgcc_so.1?

On Monday, September 20, 2010 15:01:24 Joakim Tjernlund wrote:
> Maybe I am just stupid (too long since I used crossdev) but
> I cannot find libgcc_so.1 after building:
> crossdev
> -s3
> --ex-gdb
> --libc 2.11.2
> --binutils 2.20.1-r1
> --gcc 4.4.4-r2
> --kernel 2.6.30-r1
> --target powerpc-e300c2_softfloat-linux-gnu
>
> As I recall NPTL want libgcc_so.1 no matter what I do. Isn't that
> true in newer toolchains?

did you typo the name ? gcc for most linux targets install a libgcc_s.so.1.
-mike
 
Old 09-20-2010, 08:46 PM
Joakim Tjernlund
 
Default where is libgcc_so.1?

Mike Frysinger <vapier@gentoo.org> wrote on 2010/09/20 22:01:24:
>
> On Monday, September 20, 2010 15:01:24 Joakim Tjernlund wrote:
> > Maybe I am just stupid (too long since I used crossdev) but
> > I cannot find libgcc_so.1 after building:
> > crossdev
> > -s3
> > --ex-gdb
> > --libc 2.11.2
> > --binutils 2.20.1-r1
> > --gcc 4.4.4-r2
> > --kernel 2.6.30-r1
> > --target powerpc-e300c2_softfloat-linux-gnu
> >
> > As I recall NPTL want libgcc_so.1 no matter what I do. Isn't that
> > true in newer toolchains?
>
> did you typo the name ? gcc for most linux targets install a libgcc_s.so.1.

Yes, I meant libgcc_s.so.1. I cannot find it under /usr/lib/gcc/powerpc-e300c2_softfloat-linux-gnu
nor /usr/powerpc-e300c2_softfloat-linux-gnu/

There is a /usr/lib/gcc/powerpc-e300c2_softfloat-linux-gnu/4.4.4/libgcc.a though.

There is one for my old powerpc cross compiler, gcc-3.4.6

Jocke
 

Thread Tools




All times are GMT. The time now is 01:46 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org