Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo Embedded (http://www.linux-archive.org/gentoo-embedded/)
-   -   Problems using crossdev (http://www.linux-archive.org/gentoo-embedded/349765-problems-using-crossdev.html)

Daniel Vergien 03-31-2010 12:32 PM

Problems using crossdev
 
Hi list,

I just try to use sys-devel/crossdev. I follow the embedded handbook
(http://www.gentoo.org/proj/en/base/embedded/handbook/index.xml)


I've created a toolchain with:

crossdev -t i686-pc-linux-uclibc

Using the i686-pc-linux-uclibc-gcc also worked like in the handbook.

As the next step I wanted to get the cross-emerge like in section 3.

I've set:
CBUILD=i686-pc-linux-gnu
CHOST=i686-pc-linux-uclibc
SYSROOT=/usr/i686-pc-linux-uclibc
ROOT=$SYSROOT
PORTAGE_CONFIGROOT=$SYSROOT

and added sys-devel/crossdev ~* to my package.keywords

but "emerge crossdev" fails like this:

gentoo-dev ~ # emerge --verbose --pretend crossdev


!!! /usr/i686-pc-linux-uclibc/etc/make.profile is not a symlink and
will probably prevent most merges.

!!! It should point into a profile within /usr/portage/profiles/
!!! (You can safely ignore this message when syncing. It's harmless.)


!!! If you have just changed your profile configuration, you should revert
!!! back to the previous configuration. Due to your current profile being
!!! invalid, allowed actions are limited to --help, --info, --sync, and
!!! --version.


Have I done something wrong with the environment settings? Since It's
not really clear to me if I have to have them all.


Regards

Daniel

Mirage ha 03-31-2010 04:28 PM

Problems using crossdev
 
Hi Daniel,

I did not try the steps in the handbook
but i tried the following two steps to get the cross-compile environment:

#emerge crossdev-wrappers
#emerge-wrapper --init

If this succeeded,you can now cross-emerge. if you check* /usr/${CTARGET} you will find cross-

compile environment including portage configuration files in /usr/${CTARGET}/etc.

I hope this helps you.

Mirage.

On Wed, Mar 31, 2010 at 2:32 PM, Daniel Vergien <daniel.vergien@rrz.uni-hamburg.de> wrote:

Hi list,



I just try to use sys-devel/crossdev. I follow the embedded handbook (http://www.gentoo.org/proj/en/base/embedded/handbook/index.xml)




I've created a toolchain with:



crossdev -t i686-pc-linux-uclibc



Using the i686-pc-linux-uclibc-gcc also worked like in the handbook.



As the next step I wanted to get the cross-emerge like in section 3.



I've set:

CBUILD=i686-pc-linux-gnu

CHOST=i686-pc-linux-uclibc

SYSROOT=/usr/i686-pc-linux-uclibc

ROOT=$SYSROOT

PORTAGE_CONFIGROOT=$SYSROOT



and added sys-devel/crossdev ~* to my package.keywords



but "emerge crossdev" fails like this:



gentoo-dev ~ # emerge --verbose --pretend crossdev





!!! /usr/i686-pc-linux-uclibc/etc/make.profile is not a symlink and will probably prevent most merges.

!!! It should point into a profile within /usr/portage/profiles/

!!! (You can safely ignore this message when syncing. It's harmless.)





!!! If you have just changed your profile configuration, you should revert

!!! back to the previous configuration. Due to your current profile being

!!! invalid, allowed actions are limited to --help, --info, --sync, and

!!! --version.





Have I done something wrong with the environment settings? Since It's not really clear to me if I have to have them all.



Regards



Daniel





--
Never Think Hard About Past,It brings"Tears" Don't think more about future, It brings"Fears" Live this moment with a Smile, It brings"Cheers".

Daniel Vergien 04-01-2010 06:00 AM

Problems using crossdev
 
Hi,


#emerge crossdev-wrappers
#emerge-wrapper --init

If this succeeded,you can now cross-emerge. if you check
/usr/${CTARGET} you will find cross-
compile environment including portage configuration files in
/usr/${CTARGET}/etc.


thanks for the hint. crossdev-wrappers seems to be part of crossdev. At
least I can't find a crossdev-wrappers ebuild, but emerge-wrapper is
there. Now I get the following error:

# emerge-wrapper --init
# i686-pc-linux-uclibc-emerge findutils

<snip>

* Wrong EM_TYPE. Expected EM_X86
EM_386 ./usr/bin/xargs
EM_386 ./usr/bin/find
EM_386 ./usr/bin/oldfind


I get something like this for every Package I try. I have not changed
one of the config files in /usr/$CHOST/etc


Regards

Daniel

Mirage ha 04-06-2010 08:04 AM

Problems using crossdev
 
On Thu, Apr 1, 2010 at 8:00 AM, Daniel Vergien <daniel.vergien@rrz.uni-hamburg.de> wrote:

thanks for the hint. crossdev-wrappers seems to be part of crossdev. At least I can't find a crossdev-wrappers ebuild, but emerge-wrapper is there. Now I get the following error:


# emerge-wrapper --init

# i686-pc-linux-uclibc-emerge findutils



<snip>



* Wrong EM_TYPE. Expected EM_X86

EM_386 ./usr/bin/xargs

EM_386 ./usr/bin/find

EM_386 ./usr/bin/oldfind





I get something like this for every Package I try. I have not changed one of the config files in /usr/$CHOST/etc




Hi
Sorry i can't help in this, but please check your variables in in /usr/${CTARGET}/etc/make.conf.

Regards,
M.
--
Never Think Hard About Past,It brings"Tears" Don't think more about future, It brings"Fears" Live this moment with a Smile, It brings"Cheers".


All times are GMT. The time now is 09:29 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.