FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Embedded

 
 
LinkBack Thread Tools
 
Old 12-29-2007, 02:44 PM
Janusz Syrytczyk
 
Default uClibc, locales and ntfs-3g.

Hi,
I've created x86 appliance based on uClibc and busybox. I was to compile also
ntfs-3g for ntfs write support. Everything runs perfectly, smoothly and
without troubles (but of course I got some issues when configuring
this ;-) ).

The question I got is about locales in the system:

I can mount ntfs filesystem with default locale and all files without national
characters are ok.

But when I mount a filesystem with national (in my example - Polish)
characters I cannot see any files with those characters. So when in / of
mounted ntfs partition I have i.e. "zdjęcia" I won't see it as well as its
subdirectories.

How to create/install locales for the uClibc system so ntfs-3g does not
complain about missing locales?

Janusz
--
gentoo-embedded@gentoo.org mailing list
 
Old 12-29-2007, 04:57 PM
Marc Blumentritt
 
Default uClibc, locales and ntfs-3g.

Hi,

Janusz Syrytczyk schrieb:
How to create/install locales for the uClibc system so ntfs-3g does not
complain about missing locales?


have a look at the uclibc ebuild and search for locale. This will
perhaps give you an idea. I have not tried this out, but using
USE=userlocales and setting up /etc/locales.build correct should do the
trick.


Regards,
Marc

--
gentoo-embedded@gentoo.org mailing list
 
Old 01-08-2008, 09:32 PM
Janusz Syrytczyk
 
Default uClibc, locales and ntfs-3g.

Saturday 29 of December 2007 16:44:05 Janusz Syrytczyk napisał(a):

> have a look at the uclibc ebuild and search for locale. This will
> perhaps give you an idea. I have not tried this out, but using
> USE=userlocales and setting up /etc/locales.build correct should do the
> trick.

hey,
it gave me hint, indeed, but there were still some issues with the ebuild
(didn't want to generate locales, pregen wasn't working at all, unmasked
iconv messed the script...). I was able to find newer in Bugzilla, but at
last I didn't use it.

I was able to compile uclibc with locales using savedconfig option instead.
The fastest way was to unpack, configure with make menuconfig and then copy
the config to the place where ebuild expects it (not default portage, huh :-)

Janusz.
--
gentoo-embedded@lists.gentoo.org mailing list
 

Thread Tools




All times are GMT. The time now is 10:02 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org