FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 09-16-2012, 04:12 PM
Ben de Groot
 
Default Lastrites: media-libs/gmyth, media-plugins/gst-plugins-mythtv, net-libs/libmonetra, dev-php/pecl-mcve, dev-vcs/svk, net-im/jabberd, net-p2p/sancho-bin, media-sound/xfi-drivers, app-misc/rio, media-sound/audtty, net-ftp/netkit-tftp, g

On 16 September 2012 23:40, Peter Stuge <peter@stuge.se> wrote:
> Pacho Ramos wrote:
>> # Pacho Ramos <pacho@gentoo.org> (16 Sep 2012)
>> # Upstream keeps inactive for ages and, then, it has broke again
>> # now with gnutls-3 (#421385). Removal in a month.
>> net-im/jabberd
>
> What about the 1.4 version? It depends on openssl, so maybe it
> doesn't have the gnutls issue.
>
> I kinda like jabberd.

So step up and take on maintainership of that package.

--
Cheers,

Ben | yngwin
Gentoo developer
Gentoo Qt project lead, Gentoo Wiki admin
 
Old 09-17-2012, 08:24 AM
Ben de Groot
 
Default Lastrites: media-libs/gmyth, media-plugins/gst-plugins-mythtv, net-libs/libmonetra, dev-php/pecl-mcve, dev-vcs/svk, net-im/jabberd, net-p2p/sancho-bin, media-sound/xfi-drivers, app-misc/rio, media-sound/audtty, net-ftp/netkit-tftp, g

On 17 September 2012 13:56, Peter Stuge <peter@stuge.se> wrote:
> Ben de Groot wrote:
>> On 16 September 2012 23:40, Peter Stuge <peter@stuge.se> wrote:
>> > Pacho Ramos wrote:
>> >> # Pacho Ramos <pacho@gentoo.org> (16 Sep 2012)
>> >> # Upstream keeps inactive for ages and, then, it has broke again
>> >> # now with gnutls-3 (#421385). Removal in a month.
>> >> net-im/jabberd
>> >
>> > What about the 1.4 version? It depends on openssl, so maybe it
>> > doesn't have the gnutls issue.
>> >
>> > I kinda like jabberd.
>>
>> So step up and take on maintainership of that package.
>
> I would have, had I been a developer.
>
> I still haven't finished the recruitment process. It requires so much
> concentrated effort that it is a significant project which I can not
> fit into my schedule without cutting into too many other things.

You don't have to be a developer:
http://www.gentoo.org/proj/en/qa/proxy-maintainers/

--
Cheers,

Ben | yngwin
Gentoo developer
Gentoo Qt project lead, Gentoo Wiki admin
 
Old 09-17-2012, 11:47 AM
Samuli Suominen
 
Default Lastrites: media-libs/gmyth, media-plugins/gst-plugins-mythtv, net-libs/libmonetra, dev-php/pecl-mcve, dev-vcs/svk, net-im/jabberd, net-p2p/sancho-bin, media-sound/xfi-drivers, app-misc/rio, media-sound/audtty, net-ftp/netkit-tftp, g

On 17/09/12 12:03, Peter Stuge wrote:

Pacho Ramos wrote:

# Pacho Ramos <pacho@gentoo.org> (16 Sep 2012)
# Upstream keeps inactive for ages and, then, it has broke again
# now with gnutls-3 (#421385). Removal in a month.
net-im/jabberd


What about the 1.4 version? It depends on openssl, so maybe it
doesn't have the gnutls issue.


I really doubt even oldest 1.4 version will have less unresolved bugs
than current (already unmaintained and buggy) 1.6.x versions


Should you check that, before removing it?


That would be a job for the maintainer of the package, not member of the
treecleaners...


-Samuli
 
Old 09-17-2012, 02:37 PM
Rich Freeman
 
Default Lastrites: media-libs/gmyth, media-plugins/gst-plugins-mythtv, net-libs/libmonetra, dev-php/pecl-mcve, dev-vcs/svk, net-im/jabberd, net-p2p/sancho-bin, media-sound/xfi-drivers, app-misc/rio, media-sound/audtty, net-ftp/netkit-tftp, g

On Mon, Sep 17, 2012 at 5:02 AM, Peter Stuge <peter@stuge.se> wrote:
> Ben de Groot wrote:
>> >> > I kinda like jabberd.
>> >>
>> >> So step up and take on maintainership of that package.
>> >
>> > I would have, had I been a developer.
>>
>> You don't have to be a developer:
>> http://www.gentoo.org/proj/en/qa/proxy-maintainers/
>
> And still be dependent on someone else?
>
> No, that's not the reason I use Gentoo.
>

Well, as a user there are only two ways to get or keep your favorite
package in the tree:

1. Get a developer to maintain it.
2. Get a proxy-maintainer to maintain it.

That's it. Whether you pay them, beg, appeal to their God, or
whatever, if you don't do one or the other your package will get
pruned eventually.

If your favorite package isn't in the tree you can:

1. Keep your own ebuild in /usr/local/portage or whatever.
2. Publish your own overlay.
3. Use somebody else's overlay.
3a. Use sunrise.

You're never forced to stay in-tree, though you'll find that your life
might be easier if you do (more eyeballs, if somebody renames a dep or
does something big to the tree they'll fix your ebuild for you, etc).

I don't think there is any realistic alternative. Our users expect
packages in the tree to meet basic QA standards, which requires
maintainers. Other distros use similar approaches - in fact it seems
like if anything Gentoo keeps quite a bit of stuff in the main tree
that many other distros push out into their equivalents of overlays.

Rich
 
Old 09-17-2012, 07:15 PM
Pacho Ramos
 
Default Lastrites: media-libs/gmyth, media-plugins/gst-plugins-mythtv, net-libs/libmonetra, dev-php/pecl-mcve, dev-vcs/svk, net-im/jabberd, net-p2p/sancho-bin, media-sound/xfi-drivers, app-misc/rio, media-sound/audtty, net-ftp/netkit-tftp, g

El lun, 17-09-2012 a las 14:47 +0300, Samuli Suominen escribió:
> On 17/09/12 12:03, Peter Stuge wrote:
> > Pacho Ramos wrote:
> >>>>>> # Pacho Ramos <pacho@gentoo.org> (16 Sep 2012)
> >>>>>> # Upstream keeps inactive for ages and, then, it has broke again
> >>>>>> # now with gnutls-3 (#421385). Removal in a month.
> >>>>>> net-im/jabberd
> >>>>>
> >>>>> What about the 1.4 version? It depends on openssl, so maybe it
> >>>>> doesn't have the gnutls issue.
> >>
> >> I really doubt even oldest 1.4 version will have less unresolved bugs
> >> than current (already unmaintained and buggy) 1.6.x versions
> >
> > Should you check that, before removing it?
>
> That would be a job for the maintainer of the package, not member of the
> treecleaners...
>
> -Samuli
>
>

You also would need to provide a fix for existing bug, not keep it as-is
forever
 

Thread Tools




All times are GMT. The time now is 10:03 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org