Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo Development (http://www.linux-archive.org/gentoo-development/)
-   -   Use slot deps for all gstreamer package dependencies (including plugins); preparation for gstreamer-1.0 (http://www.linux-archive.org/gentoo-development/701433-use-slot-deps-all-gstreamer-package-dependencies-including-plugins-preparation-gstreamer-1-0-a.html)

Mart Raudsepp 09-07-2012 01:52 PM

Use slot deps for all gstreamer package dependencies (including plugins); preparation for gstreamer-1.0
 
Hello,

The release of a new major GStreamer 1.0 release is going to happen
soon. It will be parallel-installable with the 0.10 series, so it will
be eventually introduced as a separate SLOT and co-exist for a while.

As such, if you maintain any packages that have any dependencies on

media-libs/gstreamer
media-libs/gst-plugins-*
media-plugins/gst-plugins-*

please get ready for it by pinning the dependencies to the appropriate
SLOT, which should currently be 0.10 in all cases.
Use SLOT deps if at all possible with your used EAPI, or at least a
=media-plugins/gst-plugins-foo-0.10* kind of dependency.

This way I'll have less package maintainers to chase around and bugs to
file once it's actually time to introduce the new SLOTs to the tree
(having all currently packages properly slot depend on 0.10 is
considered a blocker for 1.0 introducing).

media-libs/gst-plugins-bad used to be SLOT=0 accidentally, but this has
been slotmoved now, so SLOT 0.10 dep there as well.


Thanks,
Mart Raudsepp


All times are GMT. The time now is 11:36 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.