FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 05-06-2012, 01:55 AM
Ben
 
Default add global useflag: webkit

On 6 May 2012 08:34, hasufell <hasufell@gentoo.org> wrote:
> # grep :webkit use.local.desc | wc -l
> 33
>
> I would vote to make this a global useflag:
>
> webkit - Adds support for the webkit library/module
>

IIRC this was already voted on ~2 years ago (before I retired). It's
just waiting for someone to implement it.
See also bug #285743.

Cheers,
Ben | yngwin
 
Old 05-06-2012, 09:29 AM
Markos Chandras
 
Default add global useflag: webkit

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

On 05/06/2012 02:55 AM, Ben wrote:
> On 6 May 2012 08:34, hasufell <hasufell@gentoo.org> wrote:
>> # grep :webkit use.local.desc | wc -l 33
>>
>> I would vote to make this a global useflag:
>>
>> webkit - Adds support for the webkit library/module
>>
>
> IIRC this was already voted on ~2 years ago (before I retired).
> It's just waiting for someone to implement it. See also bug
> #285743.
>
> Cheers, Ben | yngwin
>
Any logs about that? I don't remember but to be honest there is
nothing to discuss here. 33 packages are more than enough to justify a
new global use flag. The description also looks good to me

- --
Regards,
Markos Chandras / Gentoo Linux Developer / Key ID: B4AFF2C2
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.19 (GNU/Linux)

iQIcBAEBCgAGBQJPpkSXAAoJEPqDWhW0r/LC5kIP/1WL9bcKcXdQS7/J47YrckNj
//lv/7fBUdXwroF37b1snSzREflLNoaIhqPAqB6jukB0cApUMbRHEPu PARV/hro/
OWjCU6UfBYC6Sr8fiw98xeScKH1UitUj1PWArGdM0B6gM2RGY6 PB1UR0FxRKZPrA
2abD3jRngvPjHkuCJ2iic6CAeo2C2NrX4lSSTsNNM4NNLqPh0H c3OmUk/A/cp9jx
0z8U4PxoWTWxhFx9E2mkg2fE9Fsyf+/9gVVZpSml2RD2NVtk9Nw5S3acVlSrooX4
xpIL5hkQaU+a31ELa3cB9Hn3XUA5muAxLQwmkVTHF5srsRlFHj qF20IoCmLwt+oe
dGg3uC4bxHw8lnnDzQMaP4NaZjkBRFaGYmE5Hb5V5k0ZTGmSm/DCj1TPGETLFJ/l
K/CjDxsWmKJpaxAHEQD+VKqS8KiD6U3FrIoWfKsSNk+0Y+tDwCKa xuUDZjGvUZER
jbJIQqmwaSD2GXQU1qEpoNn8Sjg9CpwNhwOiUjEIc/3To5vRFuIjgTYw4TdXw+JO
z+ftLC/9SXeCkd1dfh7GwaoxKGOl2GoOdUpROmzaXjTGdaeAKoNHc0Y4Y 4IZQr97
jYjraY11v/c53bYA+mi8lvlheOP9PPL1r5K/IqX270/xCXjMYn+3G57k3pJW3+Zc
mv4iWudewyjJrLYSFQwU
=RJdP
-----END PGP SIGNATURE-----
 
Old 05-06-2012, 10:52 AM
Davide Pesavento
 
Default add global useflag: webkit

On Sun, May 6, 2012 at 2:34 AM, hasufell <hasufell@gentoo.org> wrote:
> # grep :webkit use.local.desc | wc -l
> 33
>
> I would vote to make this a global useflag:
>
> webkit - Adds support for the webkit library/module
>

I suggest the following description:

"Add support for the WebKit HTML rendering/layout engine."

Otherwise +1 from me.

Thanks,
Davide
 
Old 05-07-2012, 12:47 AM
Arfrever Frehtes Taifersar Arahesis
 
Default add global useflag: webkit

2012-05-06 02:34:26 hasufell napisał(a):
> # grep :webkit use.local.desc | wc -l
> 33
>
> I would vote to make this a global useflag:
>
> webkit - Adds support for the webkit library/module

I suggest to use separate qt-webkit (or webkit-qt) and webkit-gtk USE flags.

--
Arfrever Frehtes Taifersar Arahesis
 
Old 05-07-2012, 01:00 AM
hasufell
 
Default add global useflag: webkit

On 05/07/2012 02:47 AM, Arfrever Frehtes Taifersar Arahesis wrote:
> 2012-05-06 02:34:26 hasufell napisał(a):
>> # grep :webkit use.local.desc | wc -l 33
>>
>> I would vote to make this a global useflag:
>>
>> webkit - Adds support for the webkit library/module
>
> I suggest to use separate qt-webkit (or webkit-qt) and webkit-gtk
> USE flags.
>

You mean that for example KDE users who set +webkit in make.conf would
possibly get some weird gtk-deps too?
 
Old 05-07-2012, 01:35 AM
Arfrever Frehtes Taifersar Arahesis
 
Default add global useflag: webkit

2012-05-07 03:00:31 hasufell napisał(a):
> On 05/07/2012 02:47 AM, Arfrever Frehtes Taifersar Arahesis wrote:
> > 2012-05-06 02:34:26 hasufell napisał(a):
> >> # grep :webkit use.local.desc | wc -l 33
> >>
> >> I would vote to make this a global useflag:
> >>
> >> webkit - Adds support for the webkit library/module
> >
> > I suggest to use separate qt-webkit (or webkit-qt) and webkit-gtk
> > USE flags.
> >
>
> You mean that for example KDE users who set +webkit in make.conf would
> possibly get some weird gtk-deps too?

16 packages have "webkit" USE flag, which enables dependency on net-libs/webkit-gtk:
app-misc/gramps
app-office/gnucash
app-pda/gtkpod
app-text/xiphos
dev-java/swt
dev-util/geany-plugins
dev-util/mono-tools
gnome-extra/avant-window-navigator-extras
gnome-extra/zenity
mail-client/balsa
media-gfx/gimp
media-sound/gmusicbrowser
media-sound/gpodder
media-sound/rhythmbox
net-im/empathy
x11-misc/google-gadgets

15 packages have "webkit" USE flag, which enables dependency on x11-libs/qt-webkit:
dev-python/PyQt4
dev-python/pyside
kde-base/kget
kde-base/perlqt
kde-base/qtruby
kde-base/qyoto
kde-base/smokeqt
net-im/psi
net-im/qutim
net-irc/quassel
sci-chemistry/ball
sci-geosciences/merkaartor
x11-libs/qt-assistant
x11-libs/qt-declarative
x11-libs/qt-demo

--
Arfrever Frehtes Taifersar Arahesis
 
Old 05-07-2012, 03:14 AM
Ben
 
Default add global useflag: webkit

On 7 May 2012 08:47, Arfrever Frehtes Taifersar Arahesis
<arfrever.fta@gmail.com> wrote:
> I suggest to use separate qt-webkit (or webkit-qt) and webkit-gtk USE flags.

I don't think that is necessary.

Ben | yngwin
 
Old 05-07-2012, 06:36 AM
Jess J. Guerrero Botella
 
Default add global useflag: webkit

So we have 31 packages that can optionally support webkit, and none of them lets you choose between the qt and gtk branches at compile time. I fail to see the benefit of splitting the flag.


---

Jess Guerrero Botella

El 07/05/2012 05:16, "Ben" <yngwin@gmail.com> escribi:
On 7 May 2012 08:47, Arfrever Frehtes Taifersar Arahesis

<arfrever.fta@gmail.com> wrote:

> I suggest to use separate qt-webkit (or webkit-qt) and webkit-gtk USE flags.



I don't think that is necessary.



Ben | yngwin
 
Old 05-07-2012, 08:30 AM
Samuli Suominen
 
Default add global useflag: webkit

On 05/07/2012 04:00 AM, hasufell wrote:

On 05/07/2012 02:47 AM, Arfrever Frehtes Taifersar Arahesis wrote:

2012-05-06 02:34:26 hasufell napisał(a):

# grep :webkit use.local.desc | wc -l 33

I would vote to make this a global useflag:

webkit - Adds support for the webkit library/module


I suggest to use separate qt-webkit (or webkit-qt) and webkit-gtk
USE flags.



You mean that for example KDE users who set +webkit in make.conf would
possibly get some weird gtk-deps too?



KDE shouldn't be trying to avoid GTK+ in any case, as USE="gtk" is
enabled in the default desktop profile and is a graphical toolkit which
may be the only graphical toolkit available for an package (and likely
is). It's not like it's "straightup" GNOME.


-1 for separating them
 
Old 05-07-2012, 06:11 PM
Zac Medico
 
Default add global useflag: webkit

On 05/06/2012 05:47 PM, Arfrever Frehtes Taifersar Arahesis wrote:
> 2012-05-06 02:34:26 hasufell napisał(a):
>> # grep :webkit use.local.desc | wc -l
>> 33
>>
>> I would vote to make this a global useflag:
>>
>> webkit - Adds support for the webkit library/module
>
> I suggest to use separate qt-webkit (or webkit-qt) and webkit-gtk USE flags.

Another possible way to model this kind of relationship would be to us
REQUIRED_USE to enforce relationships with the qt and gtk flags:

REQUIRED_USE="webkit? ( qt ) !webkit? ( !qt ) qt? ( webkit ) !qt? (
!webkit )"

versus

REQUIRED_USE="webkit? ( gtk ) !webkit? ( !gtk ) gtk? ( webkit ) !gtk? (
!webkit )"

It's pretty awkward with the existing operators, but we could extend the
REQUIRED_USE syntax to support an equivalent operator in a future EAPI.
--
Thanks,
Zac
 

Thread Tools




All times are GMT. The time now is 01:18 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org