FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 02-13-2012, 12:34 PM
"Paweł Hajdan, Jr."
 
Default dev-java/ant-core slot conflicts

I'm getting an annoying slot conflict while arch testing:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-java/ant-core:0

(dev-java/ant-core-1.7.1-r4::gentoo, ebuild scheduled for merge)
pulled in by
~dev-java/ant-core-1.7.1 required by
(dev-java/ant-junit4-1.7.1::gentoo, ebuild scheduled for merge)

(dev-java/ant-core-1.8.1::gentoo, ebuild scheduled for merge) pulled in by
>=dev-java/ant-core-1.8.0 required by
(dev-java/groovy-1.7.5::gentoo, ebuild scheduled for merge)
~dev-java/ant-core-1.8.1 required by
(dev-java/ant-junit-1.8.1::gentoo, ebuild scheduled for merge)
(and 4 more with the same problems)

I'm pretty sure this isn't a problem with my system, but rather a
dependency problem (using the "~" at the beginning of the dependency).

What's the best way to get this fixed?
 

Thread Tools




All times are GMT. The time now is 03:26 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ę2007 - 2008, www.linux-archive.org