FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 01-09-2012, 08:36 AM
Samuli Suominen
 
Default Lastrite: ogle, ogle-gui, goggles, zfs-fuse and ripmake

# Samuli Suominen <ssuominen@gentoo.org> (09 Jan 2012)
# Fails to compile against recent glibc and multiple other issues.
# No maintainer to take care of the package. Removal in 30 days.
# Bugs 325331, 284369, 380749, 388741, 381539, 358697, and 332395.
sys-fs/zfs-fuse

# Samuli Suominen <ssuominen@gentoo.org> (08 Jan 2012)
# Incompatible with upstream libdvdread without custom
# patching the UDF symbols in again wrt bug #387813.
# Multiple other issues. Bugs 262084, 165700, 340739,
# 369775 and 339965. No upstream or hope for new releases
# anymore either. Removal in 30 days.
media-video/ogle
media-video/ogle-gui
media-video/goggles

# Samuli Suominen <ssuominen@gentoo.org> (06 Jan 2012)
# Incompatible with stable transcode-1.1.7 wrt #397375 and
# last upstream release 2004.
# Removal in 30 days.
media-video/ripmake

# Samuli Suominen <ssuominen@gentoo.org> (02 Jan 2012)
# Unused backward compability library (for Xfce 4.6 packages in Xfce 4.8)
# Removal in 30 days
xfce-extra/thunar-vfs
 
Old 01-09-2012, 07:04 PM
Francesco Riosa
 
Default Lastrite: ogle, ogle-gui, goggles, zfs-fuse and ripmake

2012/1/9 Samuli Suominen <ssuominen@gentoo.org>:
> # Samuli Suominen <ssuominen@gentoo.org> (09 Jan 2012)
> # Fails to compile against recent glibc and multiple other issues.
> # No maintainer to take care of the package. Removal in 30 days.
> # Bugs 325331, 284369, 380749, 388741, 381539, 358697, and 332395.
> sys-fs/zfs-fuse

this is un-fortunate, it would be possible to replace it with the zfs
module, there are ebuilds in some overlay for the couple sys-devel/spl
+ sys-fs/zfs which work well with some adjustment up to kernel 3.1.8.

For example "pinkbyte" overlay (mentioned @
http://wiki.gentoo.org/wiki/ZFS) has good version of them, the only
changes needed where:
1) <= automake to 1.10
2) - --with-linux-obj="${KERNEL_DIR}"
+ --with-linux-obj="${KBUILD_OUTPUT}"
3) maybe spl should register for "module-rebuild" but it does not (not sure)
 
Old 01-10-2012, 09:39 AM
Samuli Suominen
 
Default Lastrite: ogle, ogle-gui, goggles, zfs-fuse and ripmake

On 01/09/2012 10:04 PM, Francesco Riosa wrote:

2012/1/9 Samuli Suominen<ssuominen@gentoo.org>:

# Samuli Suominen<ssuominen@gentoo.org> (09 Jan 2012)
# Fails to compile against recent glibc and multiple other issues.
# No maintainer to take care of the package. Removal in 30 days.
# Bugs 325331, 284369, 380749, 388741, 381539, 358697, and 332395.
sys-fs/zfs-fuse


this is un-fortunate, it would be possible to replace it with the zfs
module, there are ebuilds in some overlay for the couple sys-devel/spl
+ sys-fs/zfs which work well with some adjustment up to kernel 3.1.8.

For example "pinkbyte" overlay (mentioned @
http://wiki.gentoo.org/wiki/ZFS) has good version of them, the only
changes needed where:
1)<= automake to 1.10
2) - --with-linux-obj="${KERNEL_DIR}"
+ --with-linux-obj="${KBUILD_OUTPUT}"
3) maybe spl should register for "module-rebuild" but it does not (not sure)



I support the idea of someone rescuing this.

Fact is that it has been on life support since 2008 when the original
zfs-fuse maintainer stopped caring about the package.


So anyone: Feel free. I'm not going to fix it anymore. Already did that
for couple of years. Not using or testing it anymore. Simply no time.
 
Old 01-10-2012, 11:33 AM
Pacho Ramos
 
Default Lastrite: ogle, ogle-gui, goggles, zfs-fuse and ripmake

El mar, 10-01-2012 a las 12:39 +0200, Samuli Suominen escribió:
> On 01/09/2012 10:04 PM, Francesco Riosa wrote:
> > 2012/1/9 Samuli Suominen<ssuominen@gentoo.org>:
> >> # Samuli Suominen<ssuominen@gentoo.org> (09 Jan 2012)
> >> # Fails to compile against recent glibc and multiple other issues.
> >> # No maintainer to take care of the package. Removal in 30 days.
> >> # Bugs 325331, 284369, 380749, 388741, 381539, 358697, and 332395.
> >> sys-fs/zfs-fuse
> >
> > this is un-fortunate, it would be possible to replace it with the zfs
> > module, there are ebuilds in some overlay for the couple sys-devel/spl
> > + sys-fs/zfs which work well with some adjustment up to kernel 3.1.8.
> >
> > For example "pinkbyte" overlay (mentioned @
> > http://wiki.gentoo.org/wiki/ZFS) has good version of them, the only
> > changes needed where:
> > 1)<= automake to 1.10
> > 2) - --with-linux-obj="${KERNEL_DIR}"
> > + --with-linux-obj="${KBUILD_OUTPUT}"
> > 3) maybe spl should register for "module-rebuild" but it does not (not sure)
> >
>
> I support the idea of someone rescuing this.
>
> Fact is that it has been on life support since 2008 when the original
> zfs-fuse maintainer stopped caring about the package.
>
> So anyone: Feel free. I'm not going to fix it anymore. Already did that
> for couple of years. Not using or testing it anymore. Simply no time.
>
>

Francesco, maybe you could contact
http://www.gentoo.org/proj/en/qa/proxy-maintainers/ :-/
 

Thread Tools




All times are GMT. The time now is 02:22 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org