FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 11-24-2011, 11:38 AM
Pacho Ramos
 
Default Packages up for grabs due loki_val retirement

Due loki_val retirement the following packages need a new maintainer:

app-text/pdfshuffler
dev-util/lafilefixer


Thanks for taking them
 
Old 11-24-2011, 01:47 PM
"Paweł Hajdan, Jr."
 
Default Packages up for grabs due loki_val retirement

On 11/24/11 1:38 PM, Pacho Ramos wrote:
> Due loki_val retirement the following packages need a new maintainer:
>
> dev-util/lafilefixer

Do we still need lafilefixer? I think it's been integrated into portage,
right?
 
Old 11-24-2011, 02:34 PM
Rich Freeman
 
Default Packages up for grabs due loki_val retirement

On Thu, Nov 24, 2011 at 9:47 AM, "Paweł Hajdan, Jr."
<phajdan.jr@gentoo.org> wrote:
> Do we still need lafilefixer? I think it's been integrated into portage,
> right?

Not until it is stabilized and made the default. I'm not sure what
the plans are for that.

Rich
 
Old 11-24-2011, 02:37 PM
Brian Dolbec
 
Default Packages up for grabs due loki_val retirement

On Thu, 2011-11-24 at 15:47 +0100, "Paweł Hajdan, Jr." wrote:
> On 11/24/11 1:38 PM, Pacho Ramos wrote:
> > Due loki_val retirement the following packages need a new maintainer:
> >
> > dev-util/lafilefixer
>
> Do we still need lafilefixer? I think it's been integrated into portage,
> right?
>

I believe it is still needed as a standalone utility to fix existing
installations broken by pkg upgrades. The integrated one fixes new
pkgs, not existing ones.

I still see those problems coming up in the forums, although not nearly
as often as before.
--
Brian Dolbec <dolsen@gentoo.org>
 
Old 11-24-2011, 02:50 PM
 
Default Packages up for grabs due loki_val retirement

On Thu, 24 Nov 2011, Pacho Ramos wrote:

app-text/pdfshuffler

I'll take this one

Andrey
 
Old 11-24-2011, 03:14 PM
Pacho Ramos
 
Default Packages up for grabs due loki_val retirement

El jue, 24-11-2011 a las 07:37 -0800, Brian Dolbec escribió:
> On Thu, 2011-11-24 at 15:47 +0100, "Paweł Hajdan, Jr." wrote:
> > On 11/24/11 1:38 PM, Pacho Ramos wrote:
> > > Due loki_val retirement the following packages need a new maintainer:
> > >
> > > dev-util/lafilefixer
> >
> > Do we still need lafilefixer? I think it's been integrated into portage,
> > right?
> >
>
> I believe it is still needed as a standalone utility to fix existing
> installations broken by pkg upgrades. The integrated one fixes new
> pkgs, not existing ones.
>
> I still see those problems coming up in the forums, although not nearly
> as often as before.

Also maybe it could still be needed by people using other package
manager (but I am a portage user and don't know how these problems are
solved in pkgcore/paludis :-/)
 
Old 11-24-2011, 03:51 PM
Brian Dolbec
 
Default Packages up for grabs due loki_val retirement

On Thu, 2011-11-24 at 17:14 +0100, Pacho Ramos wrote:
> El jue, 24-11-2011 a las 07:37 -0800, Brian Dolbec escribió:
> > On Thu, 2011-11-24 at 15:47 +0100, "Paweł Hajdan, Jr." wrote:
> > > On 11/24/11 1:38 PM, Pacho Ramos wrote:
> > > > Due loki_val retirement the following packages need a new maintainer:
> > > >
> > > > dev-util/lafilefixer
> > >
> > > Do we still need lafilefixer? I think it's been integrated into portage,
> > > right?
> > >
> >
> > I believe it is still needed as a standalone utility to fix existing
> > installations broken by pkg upgrades. The integrated one fixes new
> > pkgs, not existing ones.
> >
> > I still see those problems coming up in the forums, although not nearly
> > as often as before.
>
> Also maybe it could still be needed by people using other package
> manager (but I am a portage user and don't know how these problems are
> solved in pkgcore/paludis :-/)

pkgcore has an lafilefixer integrated too.
--
Brian Dolbec <dolsen@gentoo.org>
 
Old 11-24-2011, 04:26 PM
Ciaran McCreesh
 
Default Packages up for grabs due loki_val retirement

On Thu, 24 Nov 2011 17:14:01 +0100
Pacho Ramos <pacho@gentoo.org> wrote:
> Also maybe it could still be needed by people using other package
> manager (but I am a portage user and don't know how these problems are
> solved in pkgcore/paludis :-/)

Paludis doesn't want you to run lafilefixer since it breaks VDB, and
won't integrate any functionality along these lines unless it's EAPI
controlled and well specified.

--
Ciaran McCreesh
 
Old 11-24-2011, 04:53 PM
Ulrich Mueller
 
Default Packages up for grabs due loki_val retirement

>>>>> On Thu, 24 Nov 2011, Ciaran McCreesh wrote:

> Paludis doesn't want you to run lafilefixer since it breaks VDB, and
> won't integrate any functionality along these lines unless it's EAPI
> controlled and well specified.

IIUC, Portage fixes libtool archives after the src_install phase but
before merging. So these files should still have valid VDB entries.

Ulrich
 
Old 11-24-2011, 04:53 PM
Zac Medico
 
Default Packages up for grabs due loki_val retirement

On 11/24/2011 07:34 AM, Rich Freeman wrote:
> On Thu, Nov 24, 2011 at 9:47 AM, "Paweł Hajdan, Jr."
> <phajdan.jr@gentoo.org> wrote:
>> Do we still need lafilefixer? I think it's been integrated into portage,
>> right?
>
> Not until it is stabilized and made the default. I'm not sure what
> the plans are for that.

It's been enabled by default in stable since portage-2.1.9.24 was
stabilized about a year ago:

https://bugs.gentoo.org/show_bug.cgi?id=346819
--
Thanks,
Zac
 

Thread Tools




All times are GMT. The time now is 08:04 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org