FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 10-19-2011, 11:40 PM
Alexandre Rostovtsev
 
Default dev-python/pygobject slotting

dev-python/pygobject:3 has been added to gx86 (package.masked for
now). It provides only gobject-introspection based bindings ("from
gi.repository import GLib"). Per upstream decision, pygobject:2,
starting with 2.28.6-r50, will install only "classic" bindings
("import glib"), since its old gi module heavily collides with
pygobject:3. To make the transition a bit easier for users who are
doing their own python development, the introspection USE flag on
pygobject-2.28.6-r50 pulls in pygobject-3 for the new gi module (in
lieu of installing pygobject-2's internal gi).

See http://www.daa.com.au/pipermail/pygtk/2011-August/019920.html for
an introduction to pygobject:3 porting.

Many existing ebuilds will need to have their pygobject dependency
slotted appropriately. I can take care of adding a slot to the
dependency list myself, but wanted to give a heads up in advance.

The following packages will need to depend on pygobject:2 :
app-admin/system-config-printer-common
app-backup/backintime
app-cdr/gcdemu
app-i18n/ibus
app-i18n/libtomoe-gtk
app-office/gtg
app-pda/synce-sync-engine
app-portage/pms-test-suite
dev-libs/keybinder
dev-python/bpython
dev-python/dbus-python
dev-python/gst-python
dev-python/papyon
dev-python/pyclutter
dev-python/pyclutter-gst
dev-python/pygtk
dev-python/pynotifier
dev-python/python-gudev
dev-python/pyudev
dev-python/pywebkitgtk
dev-util/dissy
dev-util/xesam-tools
dev-vcs/rabbitvcs
games-board/pychess
gnome-extra/gdesklets-core
gnome-extra/gnome-dvb-daemon
media-gfx/gnome-specimen
media-libs/gst-rtsp-server
media-libs/libgpod
media-radio/radiotray
media-sound/exaile
media-sound/soundconverter
net-firewall/ufw-frontends
net-libs/gupnp-igd
net-libs/telepathy-farsight
net-misc/blogtk
net-misc/cnetworkmanager
net-misc/neatx
net-misc/ups-monitor
net-misc/wicd
net-p2p/deluge
net-print/hplip
net-wireless/blueman
sys-auth/pam_usb
sys-fs/udiskie
www-client/uzbl
x11-misc/zim

The following gnome-3.0-era packages make use of a probably
incompatible mixture of classic and introspection bindings, so
gnome-3.2-era versions (that use introspection only) will need to be
moved to portage from the gnome overlay:
app-editors/gedit-3.0.6
app-editors/gedit-plugins-3.0.7
dev-libs/libpeas-1.0.0
media-sound/rhythmbox-2.90.1_pre20111001
media-video/totem-3.0.1

-Alexandre Rostovtsev
 
Old 10-20-2011, 03:32 PM
Mark Loeser
 
Default dev-python/pygobject slotting

Alexandre Rostovtsev <tetromino@gentoo.org> said:
> dev-python/pygobject:3 has been added to gx86 (package.masked for
> now). It provides only gobject-introspection based bindings ("from
> gi.repository import GLib"). Per upstream decision, pygobject:2,
> starting with 2.28.6-r50, will install only "classic" bindings
> ("import glib"), since its old gi module heavily collides with
> pygobject:3. To make the transition a bit easier for users who are
> doing their own python development, the introspection USE flag on
> pygobject-2.28.6-r50 pulls in pygobject-3 for the new gi module (in
> lieu of installing pygobject-2's internal gi).

I'd recommend you open a tracker bug for this porting effort. No one is
going to be able to follow exactly what has been done via the mailing
list

--
Mark Loeser
email - halcy0n AT gentoo DOT org
email - mark AT halcy0n DOT com
web - http://www.halcy0n.com
 

Thread Tools




All times are GMT. The time now is 11:59 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org