FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 01-25-2011, 10:20 AM
Tomáš Chvátal
 
Default EAPI usage in main tree

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi,
I would like to upgrade tree-wide policy for EAPI usage in main tree.
Currently we say that developers can use any named version they wish or
find sufficient.
I would on other hand like to have all ebuilds to use Latest EAPI
version possible (given the eclasses support it [hint hint maintainers
of eclasses should always try to support latest :P]) with expection for
base-system or more specialy depgraph for portage that needs to be
EAPI0. [[ And here we need to find out some upgrade proccess that would
work for everyone so we could somehow migrate them too ]]

With this usually new developers should be aware only of latest EAPI and
wont need to memorize what which EAPI support. Heck even I sometimes
forget what i can do with some version and whatnot.

Winner for being PITA in this race is python.eclass that HAS completely
different behavior based on EAPI version used...

Cheers

Tomas
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.17 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

iEYEARECAAYFAk0+sf4ACgkQHB6c3gNBRYeR6wCeNKsc8LnLw3 ltkc1KKllzMP3u
bXMAnRlbWZjGpQ7Zc2abdxtoJFKRVszS
=lkXl
-----END PGP SIGNATURE-----
 

Thread Tools




All times are GMT. The time now is 11:49 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org