FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 10-24-2010, 12:07 PM
Samuli Suominen
 
Default gentoo-x86 commit in dev-lang/php/files/eblits: src_configure-v1.eblit src_configure-v2.eblit

On 10/24/2010 02:48 PM, Matti Bickel (mabi) wrote:
> mabi 10/10/24 11:48:42
>
> Modified: src_configure-v1.eblit src_configure-v2.eblit
> Log:
> enable pdo-sqlite via USE="sqlite3" not USE="sqlite"
> (Portage version: 2.1.8.3/cvs/Linux x86_64)
> - phpconfutils_extension_with "pdo-sqlite" "sqlite" 1 "/usr"
> + phpconfutils_extension_with "pdo-sqlite" "sqlite3" 1 "/usr"

That's a regression (because USE="sqlite3" is deprecated).
USE="sqlite" is for sqlite 3.x, and sqlite 2.x shouldn't be used if
sqlite 3.x is supported by said package.
 
Old 10-24-2010, 03:01 PM
Matti Bickel
 
Default gentoo-x86 commit in dev-lang/php/files/eblits: src_configure-v1.eblit src_configure-v2.eblit

On 10/24/2010 02:07 PM, Samuli Suominen wrote:
> On 10/24/2010 02:48 PM, Matti Bickel (mabi) wrote:
>> - phpconfutils_extension_with "pdo-sqlite" "sqlite" 1 "/usr"
>> + phpconfutils_extension_with "pdo-sqlite" "sqlite3" 1 "/usr"
>
> That's a regression (because USE="sqlite3" is deprecated).

Thanks, didn't know that. Here's why I still think this is the best
choice at least for the time being (until the next php upstream release):
PHP upstream enables both sqlite and sqlite3 by default. We decided to
stick with upstream as much as possible, because it makes reporting bugs
so much easier and is nice to our users.

Additionally, I dare say that they're probably still some people using
sqlite2 with PHP (maybe as session storage - that's only available with
sqlite2). I don't want to take a perfectly fine option (for now) from them.

That said, sqlite2 is deprecated upstream and will show as such in
whatever their next release will be. I'll gladly drop the sqlite2
extension as soon as upstream does.
 

Thread Tools




All times are GMT. The time now is 07:20 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org