FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 10-01-2010, 01:15 PM
Peter Volkov
 
Default gentoo-x86 commit in net-libs/libproxy: ChangeLog libproxy-0.4.6.ebuild

В Срд, 29/09/2010 в 20:43 +0000, Pacho Ramos (pacho) пишет:
> pkg_setup() {
> if use python; then
> python_set_active_version 2
> fi

It's much shorter and clearer to write

use python && python_set_active_version 2

--
Peter.
 
Old 10-01-2010, 05:05 PM
Arfrever Frehtes Taifersar Arahesis
 
Default gentoo-x86 commit in net-libs/libproxy: ChangeLog libproxy-0.4.6.ebuild

2010-10-01 15:15:56 Peter Volkov napisał(a):
> В Срд, 29/09/2010 в 20:43 +0000, Pacho Ramos (pacho) пишет:
> > pkg_setup() {
> > if use python; then
> > python_set_active_version 2
> > fi
>
> It's much shorter and clearer to write
>
> use python && python_set_active_version 2

Calling python_pkg_setup() is required in EAPI >=4, so I suggest:

pkg_setup() {
if use python; then
python_set_active_version 2
python_pkg_setup
fi
}

--
Arfrever Frehtes Taifersar Arahesis
 

Thread Tools




All times are GMT. The time now is 08:03 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org