FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 08-23-2010, 08:25 PM
Torsten Veller
 
Default gentoo-x86 commit in perl-core/IO-Compress:

* "Mike Frysinger (vapier)" <vapier@gentoo.org>:
> vapier 10/08/23 20:01:12
>
> Modified: IO-Compress-2.027.ebuild IO-Compress-2.024.ebuild
> IO-Compress-2.026.ebuild ChangeLog
> IO-Compress-2.025.ebuild IO-Compress-2.030.ebuild
> IO-Compress-2.021.ebuild
> Log:
> Add proper blockers to old split packages #274443.

> RDEPEND="virtual/perl-Scalar-List-Utils
> >=virtual/perl-Compress-Raw-Zlib-${PV}
> - >=virtual/perl-Compress-Raw-Bzip2-${PV}"
> + >=virtual/perl-Compress-Raw-Bzip2-${PV}
> + !perl-core/Compress-Zlib
> + !perl-core/IO-Compress-Zlib
> + !perl-core/IO-Compress-Bzip2
> + !perl-core/IO-Compress-Base"
> DEPEND="${RDEPEND}"
> # test? ( dev-perl/Test-Pod )"

How long do you think the blockers should exist?
12 months ago they were removed from perl-core.
16 months ago they were moved from dev-perl to perl-core. Do you want to
block them too?

Why didn't anybody reply to
mid.gmane.org/20100803082816.TAc2b81f.tv@veller.net
It's the same problem.

--
Regards
 
Old 08-23-2010, 09:06 PM
Mike Frysinger
 
Default gentoo-x86 commit in perl-core/IO-Compress:

On Monday, August 23, 2010 16:25:37 Torsten Veller wrote:
> * "Mike Frysinger (vapier)" <vapier@gentoo.org>:
> > Log:
> > Add proper blockers to old split packages #274443.
> >
> > RDEPEND="virtual/perl-Scalar-List-Utils
> > >=virtual/perl-Compress-Raw-Zlib-${PV}
> > - >=virtual/perl-Compress-Raw-Bzip2-${PV}"
> > + >=virtual/perl-Compress-Raw-Bzip2-${PV}
> > + !perl-core/Compress-Zlib
> > + !perl-core/IO-Compress-Zlib
> > + !perl-core/IO-Compress-Bzip2
> > + !perl-core/IO-Compress-Base"
>
> How long do you think the blockers should exist?
> 12 months ago they were removed from perl-core.
> 16 months ago they were moved from dev-perl to perl-core. Do you want to
> block them too?

i re-added them because i just hit them on a box that while not kept up-to-
date every week, i wouldnt consider "old". i also dont think the "12 months"
quote there fully encapsulates the time frame of things being in stable. this
box certainly was up-to-date less than 12 months ago and it apparently missed
this blocker time frame.

personally, i'd let these blockers sit for quite some time since it is really
no overhead and doesnt require maintenance.
-mike
 

Thread Tools




All times are GMT. The time now is 12:28 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org