Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo Development (http://www.linux-archive.org/gentoo-development/)
-   -   USE flags (http://www.linux-archive.org/gentoo-development/415324-use-flags.html)

Jim Ramsay 08-19-2010 05:00 PM

USE flags
 
With the advent of vim-7.3 that I just threw at the tree, we now
have optional python-3 support for this package. But how to
model this in USE flags?

The upstream ./configure has --enable-pythoninterp and
--enable-python3interp, the former for python2 support (via the
vim ':py' command) and the latter for python3 support (via the
vim ':py3' command). You can enable one, or the other, or both,
or none.

So, I can see a couple ways of doing this:

Option 1: IUSE="python python3"

Where python -> --enable-pythoninterp
And python3 -> --enable-python3interp

This means if you want python3 support and not python2 support
you would need USE="-python +python3" A bit confusing, perhaps?
Or if I set the local flag description properly, is it okay?

Option 2: IUSE="python2 python3"

Just get rid of the 'python' USE flag entirely, which is a bit
odd in its own way...

Any other suggestions or comments on these two?

--
Jim Ramsay
Gentoo/Linux Developer (rox/fluxbox/gkrellm/vim)

Fabian Groffen 08-19-2010 05:48 PM

USE flags
 
On 19-08-2010 17:00:17 +0000, Jim Ramsay wrote:
> Any other suggestions or comments on these two?

Maybe automagically enable it based on what's installed, kinda like what
python packages do these days? I guess it translates into: vim now has
SUPPORT_PYTHON_ABIS="2.* 3.*" or something.


--
Fabian Groffen
Gentoo on a different level

Duncan 08-19-2010 07:58 PM

USE flags
 
Jim Ramsay posted on Thu, 19 Aug 2010 17:00:17 +0000 as excerpted:

> Option 1: IUSE="python python3"
>
> Where python -> --enable-pythoninterp And python3 ->
> --enable-python3interp
>
> This means if you want python3 support and not python2 support you would
> need USE="-python +python3" A bit confusing, perhaps? Or if I set the
> local flag description properly, is it okay?

What about USE=python indicating "maintainer's choice" of version? You
could then have either python2 or python3 flags for the other one.

This sounds a bit more like a policy that should be workable on a longer
and more global scale, and similar to what kde and gtk, among others, have
done in the past (tho I'm not sure this is exactly right, either, see
next).

I'd strongly suggest consulting with the kde and gtk projects (others?)
and coordinating a global python versioned USE flag policy, as there's
definitely some gotchas in doing it wrong, that they've had to live with
and ultimately correct as time went on and the preferred version became
the new one, with the old one eventually deprecated and ultimately removed
from the tree. There's definitely some wisdom of experience there that
can save python based packages some pain in the long term (3+ years out,
tho it's hard to see a scenario where python2 was actually removed from
the tree in anything less than 5, if ever, but never say never).

--
Duncan - List replies preferred. No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master." Richard Stallman

Peter Volkov 08-20-2010 05:56 AM

USE flags
 
В Чтв, 19/08/2010 в 19:58 +0000, Duncan пишет:
> Jim Ramsay posted on Thu, 19 Aug 2010 17:00:17 +0000 as excerpted:
>
> > Option 1: IUSE="python python3"
> >
> > Where python -> --enable-pythoninterp And python3 ->
> > --enable-python3interp
> >
> > This means if you want python3 support and not python2 support you would
> > need USE="-python +python3" A bit confusing, perhaps? Or if I set the
> > local flag description properly, is it okay?
>
> What about USE=python indicating "maintainer's choice" of version?

++ But not maintainer's choice, but _upstream's choice_.

> You could then have either python2 or python3 flags for the other one.

Yup. This allows people to have best python support if they don't care
about version and those who care have USE flag for additional feature.

--
Peter.

Mike Auty 08-20-2010 09:04 AM

USE flags
 
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

I'd thought that the new eclass was designed to ensure that if you asked
for USE="python" it was built for as many different python ABIs as was
installed on your system (so python2 and python3 if they're both
installed). I believe it's possible to ask the eclass which ABIs are
installed, and ask for the either in-use or highest versions of those.

If they're not mutually exclusive, and if vim won't break if they go
away, then why should the user choose which ones to enable and disable?
Why not just get them to say whether they want python support or not,
and try to accomodate them for as many python versions as
installed/possible.

I realize there may be some controversy surrounding the new python
eclass, however that does seem to be how most python packages work these
days, so I'd say it's better to keep everything working the same way.

Mike 5:)
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.16 (GNU/Linux)

iEYEARECAAYFAkxuRQEACgkQu7rWomwgFXrpJQCgiMBnn9bWdb wtE4xcFsNmmKkV
IV0An3FC4w3eImueLxZ7bwC3tLkv8+YC
=uCL+
-----END PGP SIGNATURE-----

Silvio Siefke 07-25-2012 04:55 PM

Use Flags
 
Hello,

after longer time want update my Gentoo PC. But ever come error msg with
the USE Flags. I not know what say me Gentoo with the message.

gentoo-desk ~ # emerge -uDN world
Calculating dependencies... done!

!!! The ebuild selected to satisfy "media-libs/sdl-mixer[mikmod]" has unmet requirements.
- media-libs/sdl-mixer-1.2.12-r1::gentoo USE="mikmod wav -flac -fluidsynth -mad -midi -mod -modplug -mp3 -playtools -smpeg -static-libs -timidity -vorbis"

The following REQUIRED_USE flag constraints are unsatisfied:
mikmod? ( mod )

The above constraints are a subset of the following complete expression:
midi? ( any-of ( timidity fluidsynth ) ) timidity? ( midi ) fluidsynth? ( midi ) mp3? ( any-of ( smpeg mad ) ) smpeg? ( mp3 ) mad? ( mp3 ) mod? ( any-of ( mikmod modplug ) ) mikmod? ( mod ) modplug? ( mod )

(dependency required by "games-kids/tuxmath-1.7.2" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


gentoo-desk ~ # cat /etc/portage/package.use | grep sdl-mixer
media-libs/sdl-mixer mikmod wav -flac -fluidsynth -mad -midi -mod -modplug -mp3 -playtools -smpeg -static-libs -timidity -vorbis

I understand not what want me say the system?


Thanks for help.

Regards
Silvio

Yohan Pereira 07-25-2012 05:07 PM

Use Flags
 
On 07/25/12 at 06:55pm, Silvio Siefke wrote:
>
> The following REQUIRED_USE flag constraints are unsatisfied:
> mikmod? ( mod )

Hi,
The above messages is telling you that, if the 'mikmod' useflag is set
the 'mod' use flag neeeds to be set too.

> gentoo-desk ~ # cat /etc/portage/package.use | grep sdl-mixer
> media-libs/sdl-mixer mikmod wav -flac -fluidsynth -mad -midi -mod -modplug -mp3 -playtools -smpeg -static-libs -timidity -vorbis

You need to add the 'mod' useflag like this.

media-libs/sdl-mixer mikmod wav mod -flac -fluidsynth -mad -midi -modplug -mp3 -playtools -smpeg -static-libs -timidity -vorbis

--

- Yohan Pereira

Alan McKinnon 07-26-2012 06:42 AM

Use Flags
 
On Wed, 25 Jul 2012 18:55:58 +0200
Silvio Siefke <siefke_listen@web.de> wrote:

> Hello,
>
> after longer time want update my Gentoo PC. But ever come error msg
> with the USE Flags. I not know what say me Gentoo with the message.
>
> gentoo-desk ~ # emerge -uDN world
> Calculating dependencies... done!
>
> !!! The ebuild selected to satisfy "media-libs/sdl-mixer[mikmod]" has
> unmet requirements.
> - media-libs/sdl-mixer-1.2.12-r1::gentoo USE="mikmod wav -flac
> -fluidsynth -mad -midi -mod -modplug -mp3 -playtools -smpeg
> -static-libs -timidity -vorbis"
>
> The following REQUIRED_USE flag constraints are unsatisfied:
> mikmod? ( mod )
>
> The above constraints are a subset of the following complete
> expression: midi? ( any-of ( timidity fluidsynth ) ) timidity? ( midi
> ) fluidsynth? ( midi ) mp3? ( any-of ( smpeg mad ) ) smpeg? ( mp3 )
> mad? ( mp3 ) mod? ( any-of ( mikmod modplug ) ) mikmod? ( mod )
> modplug? ( mod )
>
> (dependency required by "games-kids/tuxmath-1.7.2" [installed])
> (dependency required by "@selected" [set])
> (dependency required by "@world" [argument])
>
>
> gentoo-desk ~ # cat /etc/portage/package.use | grep sdl-mixer
> media-libs/sdl-mixer mikmod wav -flac -fluidsynth -mad -midi -mod
> -modplug -mp3 -playtools -smpeg -static-libs -timidity -vorbis
>
> I understand not what want me say the system?
>
>
> Thanks for help.
>
> Regards
> Silvio
>

Your USE for media-libs/sdl-mixer has this: "mikmod -mod"

The system wants "mod" if "mikmod" is set, or both to be off.

Add this to /etc/portage/package.mask:


media-libs/sdl-mixer mod


--
Alan McKinnon
alan.mckinnon@gmail.com

Allan Gottlieb 07-26-2012 01:22 PM

Use Flags
 
On Thu, Jul 26 2012, Alan McKinnon wrote:

> On Wed, 25 Jul 2012 18:55:58 +0200
> Silvio Siefke <siefke_listen@web.de> wrote:
>
>> Hello,
>>
>> after longer time want update my Gentoo PC. But ever come error msg
>> with the USE Flags. I not know what say me Gentoo with the message.
>>
>> gentoo-desk ~ # emerge -uDN world
>> Calculating dependencies... done!
>>
>> !!! The ebuild selected to satisfy "media-libs/sdl-mixer[mikmod]" has
>> unmet requirements.
>> - media-libs/sdl-mixer-1.2.12-r1::gentoo USE="mikmod wav -flac
>> -fluidsynth -mad -midi -mod -modplug -mp3 -playtools -smpeg
>> -static-libs -timidity -vorbis"
>>
>> The following REQUIRED_USE flag constraints are unsatisfied:
>> mikmod? ( mod )
>>
>> The above constraints are a subset of the following complete
>> expression: midi? ( any-of ( timidity fluidsynth ) ) timidity? ( midi
>> ) fluidsynth? ( midi ) mp3? ( any-of ( smpeg mad ) ) smpeg? ( mp3 )
>> mad? ( mp3 ) mod? ( any-of ( mikmod modplug ) ) mikmod? ( mod )
>> modplug? ( mod )
>>
>> (dependency required by "games-kids/tuxmath-1.7.2" [installed])
>> (dependency required by "@selected" [set])
>> (dependency required by "@world" [argument])
>>
>>
>> gentoo-desk ~ # cat /etc/portage/package.use | grep sdl-mixer
>> media-libs/sdl-mixer mikmod wav -flac -fluidsynth -mad -midi -mod
>> -modplug -mp3 -playtools -smpeg -static-libs -timidity -vorbis
>>
>> I understand not what want me say the system?
>>
>>
>> Thanks for help.
>>
>> Regards
>> Silvio
>>
>
> Your USE for media-libs/sdl-mixer has this: "mikmod -mod"
>
> The system wants "mod" if "mikmod" is set, or both to be off.
>
> Add this to /etc/portage/package.mask:
>
>
> media-libs/sdl-mixer mod

Don't you mean /etc/portage/package.use not .mask ?

allan

Alan McKinnon 07-26-2012 06:53 PM

Use Flags
 
On Thu, 26 Jul 2012 09:22:25 -0400
Allan Gottlieb <gottlieb@nyu.edu> wrote:


>
> > Your USE for media-libs/sdl-mixer has this: "mikmod -mod"
> >
> > The system wants "mod" if "mikmod" is set, or both to be off.
> >
> > Add this to /etc/portage/package.mask:
> >
> >
> > media-libs/sdl-mixer mod
>
> Don't you mean /etc/portage/package.use not .mask ?


Yes indeed, that's what I meant. Good catch :-)


--
Alan McKinnon
alan.mckinnon@gmail.com


All times are GMT. The time now is 08:22 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.