FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 06-16-2010, 11:41 AM
Pacho Ramos
 
Default Does libtool really support parallel make installs?

Hello

Trying to move the following bug to upstream:
http://bugs.gentoo.org/show_bug.cgi?id=253862

He replied the following:
"libtool doesn't support parallel make installs. Please file a bug
upstream."
https://bugs.freedesktop.org/show_bug.cgi?id=28108#c1


Is it true? Should -j1 be forced then for all installs relaying on
libtool?

Thanks a lot for the information
 
Old 06-16-2010, 07:47 PM
Mike Frysinger
 
Default Does libtool really support parallel make installs?

On Wed, Jun 16, 2010 at 7:41 AM, Pacho Ramos wrote:
> Trying to move the following bug to upstream:
> http://bugs.gentoo.org/show_bug.cgi?id=253862
>
> He replied the following:
> "libtool doesn't support parallel make installs. Please file a bug
> upstream."
> https://bugs.freedesktop.org/show_bug.cgi?id=28108#c1
>
>
> Is it true? Should -j1 be forced then for all installs relaying on
> libtool?

ive seen no information to show that this isnt true. Lennart needs to
provide real information explaining why he thinks his statement is
true.

at any rate, why is this bug still open and why are you pushing it
upstream ? it only applies to <=0.11, and 0.22 is stable in the tree.
-mike
 
Old 06-16-2010, 07:54 PM
Pacho Ramos
 
Default Does libtool really support parallel make installs?

El mi, 16-06-2010 a las 15:47 -0400, Mike Frysinger escribi:
> On Wed, Jun 16, 2010 at 7:41 AM, Pacho Ramos wrote:
> > Trying to move the following bug to upstream:
> > http://bugs.gentoo.org/show_bug.cgi?id=253862
> >
> > He replied the following:
> > "libtool doesn't support parallel make installs. Please file a bug
> > upstream."
> > https://bugs.freedesktop.org/show_bug.cgi?id=28108#c1
> >
> >
> > Is it true? Should -j1 be forced then for all installs relaying on
> > libtool?
>
> ive seen no information to show that this isnt true. Lennart needs to
> provide real information explaining why he thinks his statement is
> true.
>
> at any rate, why is this bug still open and why are you pushing it
> upstream ? it only applies to <=0.11, and 0.22 is stable in the tree.
> -mike
>

It doesn't apply only to <=0.11, as can be seen in duplicates, it still
affects to recent version appearing on some setups from time to time :-/
 
Old 06-16-2010, 08:11 PM
Mike Frysinger
 
Default Does libtool really support parallel make installs?

On Wed, Jun 16, 2010 at 3:54 PM, Pacho Ramos wrote:
> El mi, 16-06-2010 a las 15:47 -0400, Mike Frysinger escribi:
>> On Wed, Jun 16, 2010 at 7:41 AM, Pacho Ramos wrote:
>> > Trying to move the following bug to upstream:
>> > http://bugs.gentoo.org/show_bug.cgi?id=253862
>> >
>> > He replied the following:
>> > "libtool doesn't support parallel make installs. Please file a bug
>> > upstream."
>> > https://bugs.freedesktop.org/show_bug.cgi?id=28108#c1
>> >
>> >
>> > Is it true? Should -j1 be forced then for all installs relaying on
>> > libtool?
>>
>> ive seen no information to show that this isnt true. *Lennart needs to
>> provide real information explaining why he thinks his statement is
>> true.
>>
>> at any rate, why is this bug still open and why are you pushing it
>> upstream ? *it only applies to <=0.11, and 0.22 is stable in the tree.
>
> It doesn't apply only to <=0.11, as can be seen in duplicates, it still
> affects to recent version appearing on some setups from time to time :-/

not all of those dupes are correct, or the same issue. like Bug
287389 which is a bug in the configure step due to a broken toolchain
(which is already fixed and is a dupe of a different bug). or libltdl
which features prominently in the oldest and no longer exists in
recent versions.

at any rate, you really should clean it up with the latest error, or
simply punt it in favor of only the latest relevant information (like
Bug 282730).
-mike
 
Old 06-16-2010, 08:16 PM
Peter Volkov
 
Default Does libtool really support parallel make installs?

В Срд, 16/06/2010 в 13:41 +0200, Pacho Ramos пишет:
> Trying to move the following bug to upstream:
> http://bugs.gentoo.org/show_bug.cgi?id=253862

AFAIR this was never libtool bug, but automake and with recent enough
automake (1.10 for sure) everything should just work.

--
Peter.
 
Old 06-16-2010, 09:21 PM
Mike Frysinger
 
Default Does libtool really support parallel make installs?

On Wed, Jun 16, 2010 at 4:16 PM, Peter Volkov wrote:
> В Срд, 16/06/2010 в 13:41 +0200, Pacho Ramos пишет:
>> Trying to move the following bug to upstream:
>> http://bugs.gentoo.org/show_bug.cgi?id=253862
>
> AFAIR this was never libtool bug, but automake and with recent enough
> automake (1.10 for sure) everything should just work.

this log shows automake-1.11.1:
http://bugs.gentoo.org/attachment.cgi?id=231409
-mike
 
Old 06-16-2010, 09:26 PM
Peter Volkov
 
Default Does libtool really support parallel make installs?

В Срд, 16/06/2010 в 17:21 -0400, Mike Frysinger пишет:
> On Wed, Jun 16, 2010 at 4:16 PM, Peter Volkov wrote:
> > В Срд, 16/06/2010 в 13:41 +0200, Pacho Ramos пишет:
> >> Trying to move the following bug to upstream:
> >> http://bugs.gentoo.org/show_bug.cgi?id=253862
> >
> > AFAIR this was never libtool bug, but automake and with recent enough
> > automake (1.10 for sure) everything should just work.
>
> this log shows automake-1.11.1:
> http://bugs.gentoo.org/attachment.cgi?id=231409

I mean there was bug in automake itself. Since package fails it is
automake usage that is broken. I'll try to check that.

--
Peter.
 
Old 06-17-2010, 12:05 PM
Pacho Ramos
 
Default Does libtool really support parallel make installs?

El jue, 17-06-2010 a las 01:26 +0400, Peter Volkov escribió:
> В Срд, 16/06/2010 в 17:21 -0400, Mike Frysinger пишет:
> > On Wed, Jun 16, 2010 at 4:16 PM, Peter Volkov wrote:
> > > В Срд, 16/06/2010 в 13:41 +0200, Pacho Ramos пишет:
> > >> Trying to move the following bug to upstream:
> > >> http://bugs.gentoo.org/show_bug.cgi?id=253862
> > >
> > > AFAIR this was never libtool bug, but automake and with recent enough
> > > automake (1.10 for sure) everything should just work.
> >
> > this log shows automake-1.11.1:
> > http://bugs.gentoo.org/attachment.cgi?id=231409
>
> I mean there was bug in automake itself. Since package fails it is
> automake usage that is broken. I'll try to check that.
>

Thanks Peter and Mike for your help on this :-)
 

Thread Tools




All times are GMT. The time now is 03:05 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org