Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo Development (http://www.linux-archive.org/gentoo-development/)
-   -   Packages pulling in python-3*, also they dont require it (http://www.linux-archive.org/gentoo-development/343671-packages-pulling-python-3-also-they-dont-require.html)

Thomas Sachau 03-18-2010 06:20 PM

Packages pulling in python-3*, also they dont require it
 
Hi,

i would like to see a discussion and, if needed, a decision on the following topic:

Currently, some packages just depend on "dev-lang/python". Arfrever claims it to be right, but this
dependency does pull in python-3*, even if the package does not require it (or does not even work
with it). Since the real dep is either "=dev-lang/python-2*" or "|| ( dev-lang/python:3.1
dev-lang/python:2.7 dev-lang/python-2.6 dev-lang/python:2.5 )", it means in both cases, that my
install of python-2.6* should meet the requirement, so the package should not pull in the unneeded
and not used python-3*.

There are 2 ways to fix this issue:

-fix the dependency string for those packages (including the lines in distutils.eclass)

or (since Arfrever claims current portage behaviour is wrong)
-change portage behaviour to be satisfied with a python slot and to not require other slots.

--
Thomas Sachau

Gentoo Linux Developer

Fabian Groffen 03-18-2010 06:24 PM

Packages pulling in python-3*, also they dont require it
 
On 18-03-2010 20:20:02 +0100, Thomas Sachau wrote:
> There are 2 ways to fix this issue:
>
> -fix the dependency string for those packages (including the lines in distutils.eclass)
>
> or (since Arfrever claims current portage behaviour is wrong)
> -change portage behaviour to be satisfied with a python slot and to not require other slots.

Since the last option will take time in any case, I guess the first
option is the best to achieve the desired goal: make sure Python 3 stays
as far away as possible from any system that doesn't need it.


--
Fabian Groffen
Gentoo on a different level

Ciaran McCreesh 03-18-2010 06:28 PM

Packages pulling in python-3*, also they dont require it
 
On Thu, 18 Mar 2010 20:20:02 +0100
Thomas Sachau <tommy@gentoo.org> wrote:
> -change portage behaviour to be satisfied with a python slot and to
> not require other slots.

But then you'll never get new slots for the majority of dependencies
where you do usually want the newest version. If Portage were to take
existing slots, most users would still be using Python 2.4 to
satisfy dependencies, and would never have had 2.5+ installed...

--
Ciaran McCreesh

Arfrever Frehtes Taifersar Arahesis 03-18-2010 06:33 PM

Packages pulling in python-3*, also they dont require it
 
2010-03-18 20:20:02 Thomas Sachau napisał(a):
> Currently, some packages just depend on "dev-lang/python". Arfrever claims it to be right

It's correct only for packages (e.g. dev-python/setuptools), which support all
versions of Python (including Python 3).

> Arfrever claims current portage behaviour is wrong

I claim that Portage behavior is correct.

--
Arfrever Frehtes Taifersar Arahesis

Thomas Sachau 03-18-2010 06:43 PM

Packages pulling in python-3*, also they dont require it
 
On 03/18/2010 08:28 PM, Ciaran McCreesh wrote:
> On Thu, 18 Mar 2010 20:20:02 +0100
> Thomas Sachau <tommy@gentoo.org> wrote:
>> -change portage behaviour to be satisfied with a python slot and to
>> not require other slots.
>
> But then you'll never get new slots for the majority of dependencies
> where you do usually want the newest version. If Portage were to take
> existing slots, most users would still be using Python 2.4 to
> satisfy dependencies, and would never have had 2.5+ installed...
>

I know this part, this option was just the result of Arfrever telling me that just "dev-lang/python"
is the right dependency and the PM being wrong, when pulling in something unneeded.
python-3* might be a special case, since it is incompactible with 2* versions and wont be set as the
default python during install. But this results in it being useless and not needed, until either a
package or a user does require it explicitly.

So my vote goes for changing the dependency strings for affected packages.

--
Thomas Sachau

Gentoo Linux Developer

Thomas Sachau 03-18-2010 06:47 PM

Packages pulling in python-3*, also they dont require it
 
On 03/18/2010 08:33 PM, Arfrever Frehtes Taifersar Arahesis wrote:
> 2010-03-18 20:20:02 Thomas Sachau napisał(a):
>> Currently, some packages just depend on "dev-lang/python". Arfrever claims it to be right
>
> It's correct only for packages (e.g. dev-python/setuptools), which support all
> versions of Python (including Python 3).

Can you tell us any benefit for the normal user, when you require him to install python-3* and to
install the python related packages additionally for python-3*, while the system python is still
2.6* and wont change in the near future?

>
>> Arfrever claims current portage behaviour is wrong
>
> I claim that Portage behavior is correct.
>

So you want everyone to install python-3*? See above question.

--
Thomas Sachau

Gentoo Linux Developer

Arfrever Frehtes Taifersar Arahesis 03-18-2010 06:55 PM

Packages pulling in python-3*, also they dont require it
 
2010-03-18 20:47:35 Thomas Sachau napisał(a):
> On 03/18/2010 08:33 PM, Arfrever Frehtes Taifersar Arahesis wrote:
> > 2010-03-18 20:20:02 Thomas Sachau napisał(a):
> >> Currently, some packages just depend on "dev-lang/python". Arfrever claims it to be right
> >
> > It's correct only for packages (e.g. dev-python/setuptools), which support all
> > versions of Python (including Python 3).
>
> Can you tell us any benefit for the normal user, when you require him to install python-3*

I don't require it. It's only a side effect of correct dependencies.

--
Arfrever Frehtes Taifersar Arahesis

Petteri Rty 03-18-2010 07:02 PM

Packages pulling in python-3*, also they dont require it
 
On 03/18/2010 09:43 PM, Thomas Sachau wrote:
>
> So my vote goes for changing the dependency strings for affected packages.
>

Here's some thoughts on the matter:

- dev-lang/python is correct if the package works with all python
versions in tree

- in general we want new slots of packages like gcc being pulled in

Here's how we could change Portage behavior for pulling new slots that
are not strictly required:

- for packages in the world file install as soon as available

- for dependencies install the new slot if everything works with the new
slot

This would mean that Portage would stay with 2.6 as long as you have
something that doesn't work with 3.x installed.

Regards,
Petteri

Ciaran McCreesh 03-18-2010 07:10 PM

Packages pulling in python-3*, also they dont require it
 
On Thu, 18 Mar 2010 22:02:38 +0200
Petteri Rty <betelgeuse@gentoo.org> wrote:
> Here's how we could change Portage behavior for pulling new slots that
> are not strictly required:
>
> - for packages in the world file install as soon as available
>
> - for dependencies install the new slot if everything works with the
> new slot
>
> This would mean that Portage would stay with 2.6 as long as you have
> something that doesn't work with 3.x installed.

Why would you want the majority of your packages that can use a newer,
shinier version of a library to continue using the old version? Do you
really want to stick with Qt3 until every single app you have supports
Qt4?

--
Ciaran McCreesh

Thomas Sachau 03-18-2010 07:13 PM

Packages pulling in python-3*, also they dont require it
 
On 03/18/2010 08:55 PM, Arfrever Frehtes Taifersar Arahesis wrote:
> 2010-03-18 20:47:35 Thomas Sachau napisał(a):
>> On 03/18/2010 08:33 PM, Arfrever Frehtes Taifersar Arahesis wrote:
>>> 2010-03-18 20:20:02 Thomas Sachau napisał(a):
>>>> Currently, some packages just depend on "dev-lang/python". Arfrever claims it to be right
>>>
>>> It's correct only for packages (e.g. dev-python/setuptools), which support all
>>> versions of Python (including Python 3).
>>
>> Can you tell us any benefit for the normal user, when you require him to install python-3*
>
> I don't require it. It's only a side effect of correct dependencies.
>

Wrong. Correct dependencies only require the set of packages they need, they dont pull in packages
nor versions, which are not used or needed.
Since you claim portage behaviour being right and you dont want to change "dev-lang/python"
dependency, you want to force all users to install python-3*, also it is not needed nor used nor is
there any benefit from it being installed.

--
Thomas Sachau

Gentoo Linux Developer


All times are GMT. The time now is 07:58 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.