FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 03-03-2010, 05:45 PM
Mart Raudsepp
 
Default Remove cups from default profile to solve circular deps

On E, 2010-03-01 at 13:40 -0800, Zac Medico wrote:
> On 03/01/2010 01:24 PM, Ben de Groot wrote:
> > For some reason beyond my understanding, we have the cups useflag
> > enabled by default in profiles. This has started to generate circular
> > dependencies, at least for desktop profile users (gtk -> cups ->
> > poppler -> gtk). I propose we no longer enable the cups useflag.
>
> If you don't want to disable the cups flag globally, you might
> choose to disable for gtk+ by default in profiles/base/package.use
> like this:
>
> x11-libs/gtk+ -cups
>
> That can be overridden by user's USE=cups setting in make.conf, so
> the only effect would be to break the circular dependency by default.

I don't think there was any such problem until poppler maintainers
decided to unsplit poppler into one big packages with USE flags again
instead of the nice split poppler, poppler-glib (that should have been
named poppler-cairo probably instead), poppler-qt3, poppler-qt4 and
poppler-utils.
I don't believe we should selectively cripple one GUI toolkit with not
having proper printing support out of the box on a desktop profile,
while others do, just because maintainers are lazy.


--
Mart Raudsepp
Gentoo Developer
Mail: leio@gentoo.org
Weblog: http://blogs.gentoo.org/leio
 
Old 03-04-2010, 04:02 PM
Mart Raudsepp
 
Default Remove cups from default profile to solve circular deps

On N, 2010-03-04 at 12:50 +0100, Ben de Groot wrote:
> 2010/3/4 Dawid Węgliński <cla@gentoo.org>:
> > On Wednesday 03 March 2010 22:51:10 Ben de Groot wrote:
> >> I'm not talking about selectively disabling cups. My proposal is
> >> to no longer enable the cups useflag in the base profile.
> >
> > How is that going to fix circular dependency problem? What will you do if every
> > user add cups to USE in make.conf? Say "we don't support cups turned on by
> > default"? I hope no. Removing this flag from profile will not fix any problem but
> > hide it.
>
> It will fix the "out of the box" circular dependency for people who
> switch to a default desktop profile. This is the main problem we
> need to solve now.

The main problem to solve here is the circular dependency that you
yourself introduced as a co-maintainer of poppler, by converting poppler
to be monolithic. This from the outside looks like it was done to reduce
your maintenance workload in the (possibly accidental) expense of users
who are now getting circular dependencies in a fairly common setup.

If cups should be enabled in the desktop profile or not is a completely
different question.

The correct solution here is to fix the core problem that is now
happening - not to start removing common desktop needed USE flags from
the desktop profiles to delay the correct fix for this circular
dependency you guys have introduced for us.

> Certain useflag and package combinations
> will trigger a circular dep, that is a know occurrence in Gentoo.
> But at least with a default configuration things should work out of
> the box. For other configurations there are workarounds (in this
> case: install gtk+ without cups, or poppler without cairo enabled
> first).

Circular dependencies shouldn't happen in any situation. I claim there
is always a solution to avoid it. A different question is if the cost of
the solution is acceptable compared to the problems it causes. I believe
an inconvenience for the poppler maintainers is completely justified
here for the benefit of users in the form of properly split packages,
considering how this affects a majority of desktop users (problem hidden
by default or not).


I'll later make sure there is a bug for fixing this circular dependency
mess properly. I believe the only possible fix is to split poppler back
to at least core, bindings and utils, as it seems to be a problem due to
poppler-utils requirement by cups. It doesn't need poppler-glib, so
utils and bindings being a separate package, as it always was before,
would nicely solve it.


--
Mart Raudsepp
Gentoo Developer
Mail: leio@gentoo.org
Weblog: http://blogs.gentoo.org/leio
 

Thread Tools




All times are GMT. The time now is 07:41 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org