FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 02-24-2010, 11:45 AM
Hanno Böck
 
Default news regarding mysql 5.1 incomplete

Hi,

Just noticed yesterday an issue with the upgrade documentation in the news
regarding mysql 5.1 and revdep-rebuild.

It suggests running
# revdep-rebuild --library libmysqlclient.so.15
but this is not enough. mysql has more than one library and not all
applications link against the main lib.

On a server system (which uses as-needed), I encountered two packages (apr-
util and mysql-python) only linking against libmysqlclient_r.so.

So at least when mysql 5.1 gets stable, we should correct this.

--
Hanno Böck Blog: http://www.hboeck.de/
GPG: 3DBD3B20 Jabber/Mail: hanno@hboeck.de
 
Old 02-24-2010, 11:44 PM
"Robin H. Johnson"
 
Default news regarding mysql 5.1 incomplete

On Wed, Feb 24, 2010 at 01:45:31PM +0100, Hanno Böck wrote:
> Just noticed yesterday an issue with the upgrade documentation in the news
> regarding mysql 5.1 and revdep-rebuild.
>
> It suggests running
> # revdep-rebuild --library libmysqlclient.so.15
> but this is not enough. mysql has more than one library and not all
> applications link against the main lib.
>
> On a server system (which uses as-needed), I encountered two packages (apr-
> util and mysql-python) only linking against libmysqlclient_r.so.
>
> So at least when mysql 5.1 gets stable, we should correct this.
News item updated now. It looks like qt-sql might have been linking to
libmysqlclient_r too.

I didn't catch it myself as I used the @preserved-rebuild support in
newer Portage.

--
Robin Hugh Johnson
Gentoo Linux: Developer, Trustee & Infrastructure Lead
E-Mail : robbat2@gentoo.org
GnuPG FP : 11AC BA4F 4778 E3F6 E4ED F38E B27B 944E 3488 4E85
 
Old 02-25-2010, 12:00 AM
Nikos Chantziaras
 
Default news regarding mysql 5.1 incomplete

On 02/25/2010 02:44 AM, Robin H. Johnson wrote:

On Wed, Feb 24, 2010 at 01:45:31PM +0100, Hanno Böck wrote:

Just noticed yesterday an issue with the upgrade documentation in the news
regarding mysql 5.1 and revdep-rebuild.

It suggests running
# revdep-rebuild --library libmysqlclient.so.15
but this is not enough. mysql has more than one library and not all
applications link against the main lib.

On a server system (which uses as-needed), I encountered two packages (apr-
util and mysql-python) only linking against libmysqlclient_r.so.

So at least when mysql 5.1 gets stable, we should correct this.

News item updated now. It looks like qt-sql might have been linking to
libmysqlclient_r too.

I didn't catch it myself as I used the @preserved-rebuild support in
newer Portage.


Doesn't revdep-rebuild support regular expressions? You might want to
use one to catch all linkages.
 

Thread Tools




All times are GMT. The time now is 03:18 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org