FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 02-15-2010, 08:21 PM
"Robin H. Johnson"
 
Default News item: MySQL 5.1 bump

This is my last blocker for getting MySQL 5.1 series into ~arch status.

====
itle: MySQL 5.1 unmasking
Author: "Robin H. Johnson" <robbat2@gentoo.rog>
Content-Type: text/plain
Posted: 2010-02-15
Revision: 1
News-Item-Format: 1.0
Display-If-Installed: <dev-db/mysql-5.1

The 5.1 series of MySQL is going to be unmasked at the same time as the release
of this news item. When upgrading from an older major version, you will be
required to rebuild everything linked to the libmysqlclient.so.15.
====

--
Robin Hugh Johnson
Gentoo Linux: Developer, Trustee & Infrastructure Lead
E-Mail : robbat2@gentoo.org
GnuPG FP : 11AC BA4F 4778 E3F6 E4ED F38E B27B 944E 3488 4E85
 
Old 02-15-2010, 08:32 PM
Samuli Suominen
 
Default News item: MySQL 5.1 bump

On 02/15/2010 11:21 PM, Robin H. Johnson wrote:
> This is my last blocker for getting MySQL 5.1 series into ~arch status.
>
> ====
> itle: MySQL 5.1 unmasking
> Author: "Robin H. Johnson" <robbat2@gentoo.rog>
> Content-Type: text/plain
> Posted: 2010-02-15
> Revision: 1
> News-Item-Format: 1.0
> Display-If-Installed: <dev-db/mysql-5.1
>
> The 5.1 series of MySQL is going to be unmasked at the same time as the release
> of this news item. When upgrading from an older major version, you will be
> required to rebuild everything linked to the libmysqlclient.so.15.

You can do this by installing gentoolkit and running:

revdep-rebuild --library libmysqlclient.so.15

> ====
>

Perhaps?

-Samuli
 
Old 02-15-2010, 08:41 PM
"Robin H. Johnson"
 
Default News item: MySQL 5.1 bump

On Mon, Feb 15, 2010 at 11:32:10PM +0200, Samuli Suominen wrote:
> On 02/15/2010 11:21 PM, Robin H. Johnson wrote:
> > This is my last blocker for getting MySQL 5.1 series into ~arch status.
> >
> > ====
> > itle: MySQL 5.1 unmasking
> > Author: "Robin H. Johnson" <robbat2@gentoo.rog>
> > Content-Type: text/plain
> > Posted: 2010-02-15
> > Revision: 1
> > News-Item-Format: 1.0
> > Display-If-Installed: <dev-db/mysql-5.1
> >
> > The 5.1 series of MySQL is going to be unmasked at the same time as the release
> > of this news item. When upgrading from an older major version, you will be
> > required to rebuild everything linked to the libmysqlclient.so.15.
You can do this by installing gentoolkit and running:
# revdep-rebuild --library libmysqlclient.so.15

If you use the Portage 2.2 series, you may also use:
# emerge @preserved-rebuild

--
Robin Hugh Johnson
Gentoo Linux: Developer, Trustee & Infrastructure Lead
E-Mail : robbat2@gentoo.org
GnuPG FP : 11AC BA4F 4778 E3F6 E4ED F38E B27B 944E 3488 4E85
 
Old 02-15-2010, 08:51 PM
Nikos Chantziaras
 
Default News item: MySQL 5.1 bump

On 02/15/2010 11:21 PM, Robin H. Johnson wrote:

This is my last blocker for getting MySQL 5.1 series into ~arch status.

====
itle: MySQL 5.1 unmasking
Author: "Robin H. Johnson"<robbat2@gentoo.rog>
Content-Type: text/plain
Posted: 2010-02-15
Revision: 1
News-Item-Format: 1.0
Display-If-Installed:<dev-db/mysql-5.1

The 5.1 series of MySQL is going to be unmasked at the same time as the release
of this news item. When upgrading from an older major version, you will be
required to rebuild everything linked to the libmysqlclient.so.15.
====


I assume "older major version" means 4.x versions and older, not 5.0, right?
 
Old 02-15-2010, 09:03 PM
Ulrich Mueller
 
Default News item: MySQL 5.1 bump

>>>>> On Mon, 15 Feb 2010, Robin H Johnson wrote:

> itle: MySQL 5.1 unmasking
> Author: "Robin H. Johnson" <robbat2@gentoo.rog>

Typo: ^^^

And the real name shouldn't be quoted (news items aren't e-mail).

Ulrich
 
Old 02-15-2010, 09:06 PM
Dawid Węgliński
 
Default News item: MySQL 5.1 bump

On Monday 15 February 2010 22:21:36 Robin H. Johnson wrote:
> This is my last blocker for getting MySQL 5.1 series into ~arch status.
>
> ====
> itle: MySQL 5.1 unmasking

Is there an "upgrade path" for databases itself?

--
Cheers
Dawid Węgliński
 
Old 02-15-2010, 09:12 PM
"Robin H. Johnson"
 
Default News item: MySQL 5.1 bump

On Mon, Feb 15, 2010 at 11:51:59PM +0200, Nikos Chantziaras wrote:
> On 02/15/2010 11:21 PM, Robin H. Johnson wrote:
> >This is my last blocker for getting MySQL 5.1 series into ~arch status.
> >
> >====
> >itle: MySQL 5.1 unmasking
> >Author: "Robin H. Johnson"<robbat2@gentoo.rog>
> >Content-Type: text/plain
> >Posted: 2010-02-15
> >Revision: 1
> >News-Item-Format: 1.0
> >Display-If-Installed:<dev-db/mysql-5.1
> >
> >The 5.1 series of MySQL is going to be unmasked at the same time as the release
> >of this news item. When upgrading from an older major version, you will be
> >required to rebuild everything linked to the libmysqlclient.so.15.
> >====
> I assume "older major version" means 4.x versions and older, not 5.0, right?
The following transitions required rebuilds:
3.23 -> 4.0
4.0 -> 4.1
4.1 -> 5.0
5.0 -> 5.1

5.1 -> 5.[45] don't require anything at present, but 5.x -> 6.0 may.

Major version in the context of upstream MySQL is the first TWO digits.

--
Robin Hugh Johnson
Gentoo Linux: Developer, Trustee & Infrastructure Lead
E-Mail : robbat2@gentoo.org
GnuPG FP : 11AC BA4F 4778 E3F6 E4ED F38E B27B 944E 3488 4E85
 
Old 02-15-2010, 09:15 PM
"Robin H. Johnson"
 
Default News item: MySQL 5.1 bump

On Mon, Feb 15, 2010 at 11:06:37PM +0100, Dawid Węgliński wrote:
> On Monday 15 February 2010 22:21:36 Robin H. Johnson wrote:
> > This is my last blocker for getting MySQL 5.1 series into ~arch status.
> >
> > ====
> > itle: MySQL 5.1 unmasking
>
> Is there an "upgrade path" for databases itself?
The official upgrade docs are:
http://dev.mysql.com/doc/refman/5.1/en/upgrade.html

My unofficial recommendation is just doing a backup before and running
'mysql_upgrade' after.

--
Robin Hugh Johnson
Gentoo Linux: Developer, Trustee & Infrastructure Lead
E-Mail : robbat2@gentoo.org
GnuPG FP : 11AC BA4F 4778 E3F6 E4ED F38E B27B 944E 3488 4E85
 
Old 02-15-2010, 09:54 PM
Dawid Węgliński
 
Default News item: MySQL 5.1 bump

On Monday 15 February 2010 23:15:02 Robin H. Johnson wrote:
> On Mon, Feb 15, 2010 at 11:06:37PM +0100, Dawid Węgliński wrote:
> > On Monday 15 February 2010 22:21:36 Robin H. Johnson wrote:
> > > This is my last blocker for getting MySQL 5.1 series into ~arch status.
> > >
> > > ====
> > > itle: MySQL 5.1 unmasking
> >
> > Is there an "upgrade path" for databases itself?
>
> The official upgrade docs are:
> http://dev.mysql.com/doc/refman/5.1/en/upgrade.html
>
> My unofficial recommendation is just doing a backup before and running
> 'mysql_upgrade' after.

I'd like to see this link in news item. Thanks.

--
Cheers
Dawid Węgliński
 
Old 02-15-2010, 11:08 PM
Thilo Bangert
 
Default News item: MySQL 5.1 bump

"Robin H. Johnson" <robbat2@gentoo.org> said:
> On Mon, Feb 15, 2010 at 11:32:10PM +0200, Samuli Suominen wrote:
> > On 02/15/2010 11:21 PM, Robin H. Johnson wrote:
> > > This is my last blocker for getting MySQL 5.1 series into ~arch
> > > status.
> > >
> > > ====
> > > itle: MySQL 5.1 unmasking
> > > Author: "Robin H. Johnson" <robbat2@gentoo.rog>
> > > Content-Type: text/plain
> > > Posted: 2010-02-15
> > > Revision: 1
> > > News-Item-Format: 1.0
> > > Display-If-Installed: <dev-db/mysql-5.1
> > >
> > > The 5.1 series of MySQL is going to be unmasked at the same time as
> > > the release of this news item. When upgrading from an older major
> > > version, you will be required to rebuild everything linked to the
> > > libmysqlclient.so.15.
>
> You can do this by installing gentoolkit and running:

FQPN: app-portage/gentoolkit

thanks
Thilo
 

Thread Tools




All times are GMT. The time now is 12:56 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org