FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 01-30-2010, 11:19 AM
Hanno Bck
 
Default openssl 1.0.0 quick test

Hi,

I recently installed the masked openssl 1.0.0_beta5 and tried to rebuild
everything against the new version of openssl.

I know it's probably not very urgend to get on that, but I thought others
might be interested in the status.
- php fails, fix is trivial. I've sent it upstream and it got already applied
to upstream svn:
http://bugs.php.net/bug.php?id=50859
- wvstreams fails, fix also trivial and sent upstream, no reply yet:
http://code.google.com/p/wvstreams/issues/detail?id=27
- ruby fails (both the 1.8/1.9 versions from the tree and the latest from the
ruby-overlay), fix seems to be non-trivial. There is some upstream work on it
I haven't tested:
http://redmine.ruby-lang.org/issues/show/2022

So all in all it's not that much. I'll leave it up to the maintainers of php
and wvstreams if they want to patch their packages or wait till upstream fixes
arrive.

cu,

--
Hanno Bck Blog: http://www.hboeck.de/
GPG: 3DBD3B20 Jabber/Mail: hanno@hboeck.de
 
Old 02-01-2010, 08:07 AM
Peter Volkov
 
Default openssl 1.0.0 quick test

В Сбт, 30/01/2010 в 13:19 +0100, Hanno Böck пишет:
> - php fails, fix is trivial. I've sent it upstream and it got already applied
> to upstream svn:
> http://bugs.php.net/bug.php?id=50859
> - wvstreams fails, fix also trivial and sent upstream, no reply yet:
> http://code.google.com/p/wvstreams/issues/detail?id=27
> - ruby fails (both the 1.8/1.9 versions from the tree and the latest from the
> ruby-overlay), fix seems to be non-trivial. There is some upstream work on it
> I haven't tested:
> http://redmine.ruby-lang.org/issues/show/2022
>
> So all in all it's not that much. I'll leave it up to the maintainers of php
> and wvstreams if they want to patch their packages or wait till upstream fixes
> arrive.

Please report this issues in our bugzilla. And it's good idea to start
openssl-1.x tracker.

--
Peter.
 

Thread Tools




All times are GMT. The time now is 07:57 AM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org