FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 03-22-2009, 04:24 PM
Mounir Lamouri
 
Default please stop using foo-${PV}-bar.patch in other ebuild versions than ${PV}

On Sun, Mar 22, 2009 at 1:18 PM, Ulrich Mueller <ulm@gentoo.org> wrote:
>>>>>> On Sun, 22 Mar 2009, mrness wrote:
>
>> Please do not apply patches that have ${P} prefix in other ebuild
>> versions than ${PV}.
>> Is that hard to create a new patch with a proper name?
>
> And multiply number and total size of files in ${FILESDIR}?
>
> Ulrich
>
>

Or just rename it ${PN}-bar.patch instead of ${P}-bar.patch if it is a
patch for more than one ebuild version.
But older ebuild has to be changed to make it works.

Mounir
 
Old 03-22-2009, 05:22 PM
Nirbheek Chauhan
 
Default please stop using foo-${PV}-bar.patch in other ebuild versions than ${PV}

On Sun, Mar 22, 2009 at 10:54 PM, Mounir Lamouri
<mounir.lamouri@gmail.com> wrote:
> Or just rename it ${PN}-bar.patch instead of ${P}-bar.patch if it is a
> patch for more than one ebuild version.
> But older ebuild has to be changed to make it works.
>

The ${PV} in the patch name is a quick indication of the age of a
patch, the gnome herd especially *encourages* this behavior.

--
~Nirbheek Chauhan
 

Thread Tools




All times are GMT. The time now is 08:14 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright 2007 - 2008, www.linux-archive.org