Carsten Lohrke wrote:
> On Sonntag, 22. Februar 2009, Petteri Ršty wrote:
> Running it, I got the message everything would be fine, but after uninstalling
> Sun's 1.4 JDK, Portage told me it'll be still needed. So after a bit package
> masking and uninstalling
Did you read the email? The the new java-check-environment is not in yet
and doesn't the news item say that 1.4 might still be needed?
> I got
> For more information, see the MASKED PACKAGES section in the emerge
> man page or refer to the Gentoo Handbook.
> (dependency required by "dev-java/tomcat-servlet-api-5.5.27" [installed])
> (dependency required by "dev-util/eclipse-sdk-3.4-r2" [installed])
> (dependency required by "@world" [argument])
> and after looking at the tomcat-servlet-api ebuild I finally found that
> setting a java5 use flag and re-emerging the ebuild would be required, et
We don't want to turn on java5 use flag by default because of
Any way in your case the user is expected to decide that he still needs
1.4 and leave it installed.
> It's really great that the Java team managed to convert all packages, but I do
> not call the above procedure user friendly.
Well nothing breaks if you don't do anything. Guess that should be
reflected better in the news item. You will just have extra stuff in
your $PATH most likely etc.