FAQ Search Today's Posts Mark Forums Read
» Video Reviews

» Linux Archive

Linux-archive is a website aiming to archive linux email lists and to make them easily accessible for linux users/developers.


» Sponsor

» Partners

» Sponsor

Go Back   Linux Archive > Gentoo > Gentoo Development

 
 
LinkBack Thread Tools
 
Old 02-22-2009, 09:24 PM
Petteri Ršty
 
Default Fwd: News item: Generation 1 deprecation

Now with the right address. Original was CCed to pr already so this is not.

---------- Forwarded Message ----------

Subject: News item: Generation 1 deprecation
Date: Monday 23 February 2009
From: Petteri Ršty <petsku@petteriraty.eu>
To: gentoo-dev@lists.gentoo.org

We are getting near to having all generation 1 Java ebuilds gone from
the main tree so we made a news item in order to instruct how to remove
left over things if wanted (nothing breaks if you don't).

Last bugs to fix before we commit the new java-config-wrapper and the
news item:
http://bugs.gentoo.org/showdependencytree.cgi?id=176781&hide_resolved=1

The news item will go in at the same time with the new
java-config-wrapper that is adjusted to check for deprecated generation
1 files.

Regards,
Petteri

-------------------------------------------------------
Title: Generation 1 Java Setup Deprecated
Author: Petteri Räty <betelgeuse@gentoo.org>
Content-Type: text/plain
Posted: yyyy-mm-dd
Revision: 1
News-Item-Format: 1
Display-If-Installed: >=dev-java/java-config-wrapper-0.16

For a long time the Java team required a 1.4 JDK to be
installed in order for old java ebuilds to work. All these
ebuilds are now gone from the main tree so the requirement
to have a 1.4 JDK installed has been lifted.

In order to remove things left over by the generation 1
setup please run java-check-environment and follow the
instructions.

If you want to remove 1.4 JDKs, you should use emerge --depclean.
Depending on what you have installed you might not need a
1.4 JDK any more. To see if you still need a 1.4 JDK use:

emerge -av --depclean virtual/jdk:1.4

If don't need virtual/jdk:1.4 any more then you can remove the
individual JDKs. First get the list of installed JDKs with
eselect and then remove with depclean, for example:

eselect java-vm list
emerge -av --depclean sun-jdk:1.4
 
Old 02-22-2009, 10:29 PM
Carsten Lohrke
 
Default Fwd: News item: Generation 1 deprecation

On Sonntag, 22. Februar 2009, Petteri Ršty wrote:
> java-check-environment

Running it, I got the message everything would be fine, but after uninstalling
Sun's 1.4 JDK, Portage told me it'll be still needed. So after a bit package
masking and uninstalling

dev-java/sun-jdk:1.4
=dev-java/java-sdk-docs-1.4*
virtual/jdk:1.4
virtual/jre:1.4

I got

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.
(dependency required by "dev-java/tomcat-servlet-api-5.5.27" [installed])
(dependency required by "dev-util/eclipse-sdk-3.4-r2" [installed])
(dependency required by "@world" [argument])

and after looking at the tomcat-servlet-api ebuild I finally found that
setting a java5 use flag and re-emerging the ebuild would be required, et
voila...


It's really great that the Java team managed to convert all packages, but I do
not call the above procedure user friendly.


Carsten
 
Old 02-22-2009, 11:07 PM
Petteri Ršty
 
Default Fwd: News item: Generation 1 deprecation

Carsten Lohrke wrote:
> On Sonntag, 22. Februar 2009, Petteri Ršty wrote:
>> java-check-environment
>
> Running it, I got the message everything would be fine, but after uninstalling
> Sun's 1.4 JDK, Portage told me it'll be still needed. So after a bit package
> masking and uninstalling
>

Did you read the email? The the new java-check-environment is not in yet
and doesn't the news item say that 1.4 might still be needed?

> dev-java/sun-jdk:1.4
> =dev-java/java-sdk-docs-1.4*
> virtual/jdk:1.4
> virtual/jre:1.4
>
> I got
>
> For more information, see the MASKED PACKAGES section in the emerge
> man page or refer to the Gentoo Handbook.
> (dependency required by "dev-java/tomcat-servlet-api-5.5.27" [installed])
> (dependency required by "dev-util/eclipse-sdk-3.4-r2" [installed])
> (dependency required by "@world" [argument])
>
> and after looking at the tomcat-servlet-api ebuild I finally found that
> setting a java5 use flag and re-emerging the ebuild would be required, et
> voila...
>

We don't want to turn on java5 use flag by default because of
http://bugs.gentoo.org/show_bug.cgi?id=161622

Any way in your case the user is expected to decide that he still needs
1.4 and leave it installed.

>
> It's really great that the Java team managed to convert all packages, but I do
> not call the above procedure user friendly.
>

Well nothing breaks if you don't do anything. Guess that should be
reflected better in the news item. You will just have extra stuff in
your $PATH most likely etc.

Regards,
Petteri
 
Old 02-23-2009, 12:52 PM
Jan KundrŠt
 
Default Fwd: News item: Generation 1 deprecation

See the patch.

--
cd /local/pub && more beer > /dev/mouth
--- generation1-deprecation.orig 2009-02-23 14:50:37.920591164 +0100
+++ generation1-deprecation 2009-02-23 14:51:25.180617090 +0100
@@ -21,9 +21,9 @@

emerge -av --depclean virtual/jdk:1.4

-If don't need virtual/jdk:1.4 any more then you can remove the
+If you don't need virtual/jdk:1.4 any more then you can remove the
individual JDKs. First get the list of installed JDKs with
-eselect and then remove with depclean, for example:
+eselect and then remove those that are not needed anymore with depclean, for example:

eselect java-vm list
emerge -av --depclean sun-jdk:1.4
 
Old 02-24-2009, 11:32 AM
Petteri Ršty
 
Default Fwd: News item: Generation 1 deprecation

Jan KundrŠt wrote:
> See the patch.
>

applied
 

Thread Tools




All times are GMT. The time now is 12:42 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.
Copyright ©2007 - 2008, www.linux-archive.org