Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo Desktop (http://www.linux-archive.org/gentoo-desktop/)
-   -   kde-base/kdebase-kioslaves-3.5.10-r1 and hal USE flag (http://www.linux-archive.org/gentoo-desktop/551621-kde-base-kdebase-kioslaves-3-5-10-r1-hal-use-flag.html)

Alex Schuster 07-12-2011 04:32 PM

kde-base/kdebase-kioslaves-3.5.10-r1 and hal USE flag
 
Hi there!

Yes, there are still people using KDE 3.5, from the kde-sunset overlay.
Auto-mounting of external media like CDs does not work, I assume it's
because I have no HAL support for kioslaves:

leela ~ # USE=hal emerge -pv kde-base/kdebase-kioslaves:3.5

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] kde-base/kdebase-kioslaves-3.5.10-r1 USE="ldap samba -
debug (-hal) -kdehiddenvisibility -openexr" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
[0] /var/portage/tree
[1] /var/portage/layman/kde-sunset

The (-hal) probably means that this USE flag is disabled by profile. Is
there a way to enable it? Or does one have to mount CDs manually with KDE
3.5 now?

I tried to put -hal in package.use.mask, and hal in package.use.force
(whatever thsi is). And in package.use of course, but this does not help.
When I look into the ebuild, it seems that sys-apps/dbus has to be compiled
with qt3, but there is no such USE flag for this package. Maybe that's why
hal is masked in the first place.

So, is there anything I can do about it?

Wonko

Brent Busby 07-13-2011 10:29 PM

kde-base/kdebase-kioslaves-3.5.10-r1 and hal USE flag
 
On Tue, 12 Jul 2011, Alex Schuster wrote:


Yes, there are still people using KDE 3.5, from the kde-sunset overlay.
Auto-mounting of external media like CDs does not work, I assume it's
because I have no HAL support for kioslaves:

leela ~ # USE=hal emerge -pv kde-base/kdebase-kioslaves:3.5

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild R ] kde-base/kdebase-kioslaves-3.5.10-r1 USE="ldap samba -
debug (-hal) -kdehiddenvisibility -openexr" 0 kB [1]

Total: 1 package (1 reinstall), Size of downloads: 0 kB
Portage tree and overlays:
[0] /var/portage/tree
[1] /var/portage/layman/kde-sunset

The (-hal) probably means that this USE flag is disabled by profile. Is
there a way to enable it? Or does one have to mount CDs manually with KDE
3.5 now?

I tried to put -hal in package.use.mask, and hal in package.use.force
(whatever thsi is). And in package.use of course, but this does not help.
When I look into the ebuild, it seems that sys-apps/dbus has to be compiled
with qt3, but there is no such USE flag for this package. Maybe that's why
hal is masked in the first place.

So, is there anything I can do about it?


Here's what I've had to do...

In /etc/portage/package.use.mask:

kde-base/kdebase-kioslaves -hal
app-cdr/k3b -hal

In /etc/portage/package.keywords (because newer masked ebuilds of these
two packages solve some build issues):


kde-base/kdelibs:3.5 ~amd64
kde-base/kcontrol:3.5 ~amd64

In /etc/portage/package.unmask:

kde-base/kdelibs:3.5
kde-base/kcontrol:3.5

Hope this helps...

--
+ Brent A. Busby +
+ Sr. UNIX Systems Admin + Vote for Cthulhu.
+ University of Chicago +
+ James Franck Institute + Why settle for the lesser evil?

Tiago Marques 07-14-2011 03:21 PM

kde-base/kdebase-kioslaves-3.5.10-r1 and hal USE flag
 
Install this and all will be ok:
kde-base/kdebase-kioslaves-3.5.10-r1sys-apps/dbus-1.2.24sys-apps/hal-0.5.13-r2
Hal above this version should be masked for kdebase-kioslaves-3.5.10.


Best regards,Tiago

On Wed, Jul 13, 2011 at 11:29 PM, Brent Busby <brent@keycorner.org> wrote:


On Tue, 12 Jul 2011, Alex Schuster wrote:




Yes, there are still people using KDE 3.5, from the kde-sunset overlay.

Auto-mounting of external media like CDs does not work, I assume it's

because I have no HAL support for kioslaves:



leela ~ # USE=hal emerge -pv kde-base/kdebase-kioslaves:3.5



These are the packages that would be merged, in order:



Calculating dependencies... done!

[ebuild * R * *] kde-base/kdebase-kioslaves-3.5.10-r1 *USE="ldap samba -

debug (-hal) -kdehiddenvisibility -openexr" 0 kB [1]



Total: 1 package (1 reinstall), Size of downloads: 0 kB

Portage tree and overlays:

[0] /var/portage/tree

[1] /var/portage/layman/kde-sunset



The (-hal) probably means that this USE flag is disabled by profile. Is

there a way to enable it? Or does one have to mount CDs manually with KDE

3.5 now?



I tried to put -hal in package.use.mask, and hal in package.use.force

(whatever thsi is). And in package.use of course, but this does not help.

When I look into the ebuild, it seems that sys-apps/dbus has to be compiled

with qt3, but there is no such USE flag for this package. Maybe that's why

hal is masked in the first place.



So, is there anything I can do about it?




Here's what I've had to do...



In /etc/portage/package.use.mask:



kde-base/kdebase-kioslaves -hal

app-cdr/k3b -hal



In /etc/portage/package.keywords (because newer masked ebuilds of these two packages solve some build issues):



kde-base/kdelibs:3.5 ~amd64

kde-base/kcontrol:3.5 ~amd64



In /etc/portage/package.unmask:



kde-base/kdelibs:3.5

kde-base/kcontrol:3.5



Hope this helps...



--

+ Brent A. Busby * * * * +

+ Sr. UNIX Systems Admin + * * *Vote for Cthulhu.

+ University of Chicago *+

+ James Franck Institute + * * *Why settle for the lesser evil?

Alex Schuster 09-18-2011 10:11 PM

kde-base/kdebase-kioslaves-3.5.10-r1 and hal USE flag
 
Sorry for the looong delay. It's partially because I the system it remote
and I do not always have access to it, and partially because I nearly
forgot about this :) Sorry for that.

Long, long ago Tiago Marques wrote:

> On Wed, Jul 13, 2011 at 11:29 PM, Brent Busby <brent@keycorner.org>
> wrote:
> > On Tue, 12 Jul 2011, Alex Schuster wrote:

> >> Auto-mounting of external media like CDs does not work, I assume
> >> it's because I have no HAL support for kioslaves:
> >>
> >> leela ~ # USE=hal emerge -pv kde-base/kdebase-kioslaves:3.5
> >>
> >> These are the packages that would be merged, in order:
> >>
> >> Calculating dependencies... done!
> >> [ebuild R ] kde-base/kdebase-kioslaves-3.**5.10-r1 USE="ldap
> >> samba -
> >> debug (-hal) -kdehiddenvisibility -openexr" 0 kB [1]

> >> The (-hal) probably means that this USE flag is disabled by profile.
> >> Is there a way to enable it? Or does one have to mount CDs manually
> >> with KDE 3.5 now?
> >>
> >> I tried to put -hal in package.use.mask, and hal in
> >> package.use.force (whatever thsi is). And in package.use of course,
> >> but this does not help. When I look into the ebuild, it seems that
> >> sys- apps/dbus has to be compiled with qt3, but there is no such USE
> >> flag for this package. Maybe that's why hal is masked in the first
> >> place.
> >>
> >> So, is there anything I can do about it?
> >
> > Here's what I've had to do...
> >
> > In /etc/portage/package.use.mask:
> >
> > kde-base/kdebase-kioslaves -hal
> > app-cdr/k3b -hal

Here, too.

> > In /etc/portage/package.keywords (because newer masked ebuilds of
> > these two packages solve some build issues):
> >
> > kde-base/kdelibs:3.5 ~amd64
> > kde-base/kcontrol:3.5 ~amd64

Done (with ~x86 instead).

> > In /etc/portage/package.unmask:
> >
> > kde-base/kdelibs:3.5
> > kde-base/kcontrol:3.5
>
> > Hope this helps...

No, it did not help :(

> Install this and all will be ok:
>
> kde-base/kdebase-kioslaves-3.5.10-r1
> sys-apps/dbus-1.2.24
> sys-apps/hal-0.5.13-r2

I tried, getting these ooold versions from the attic. But it still
didn't work out.

But the PC is a rather old one, and so I decided to go away from Gentoo.
Using distcc helped, but only when I and my fast (well not really, but
much faster than that old Sempron) PC were there. I decided to try
Sabayon Linux, which is based on Gentoo, but binary. There is no KDE3,
though, so I had to install KDE4. Which is somewhat slow, maybe Xfce4 or
LXDE will be better.

BTW, I'm not too happy with Sabayon either. The equo package manager is
not as sophisticated as emerge, for example it looks like it is not
possible to call it when another instance is already running. And I do
not yet understand how I can mix equo with portage. But I dod not dig
into this too much, the person using this PC mainly uses KMail, Firefox
and aMSN, and this is working fine.

Anyway, thanks both of you for your assistance.

Wonk


All times are GMT. The time now is 01:08 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.