Linux Archive

Linux Archive (http://www.linux-archive.org/)
-   Gentoo Desktop (http://www.linux-archive.org/gentoo-desktop/)
-   -   startx / X -config /root/xorg.conf.new crash on T410 intel Arrandale (custom kernel) (http://www.linux-archive.org/gentoo-desktop/408446-startx-x-config-root-xorg-conf-new-crash-t410-intel-arrandale-custom-kernel.html)

Levon Ghazaryan 08-04-2010 11:27 AM

startx / X -config /root/xorg.conf.new crash on T410 intel Arrandale (custom kernel)
 
Hi all,

on 2.6.34-r1, ThinkPad T410 with Intel Arrandale with a custom kernel
the laptop freezes on startx or X -retro -config /root/xorg.conf.new (with
a fresh created xorg.conf.new with Xorg -config).

as this happens I'm not able to switch the tty, the laptop doesn't respond
to ping and caps lock is constantly blinking.

there is no error in /var/log/Xorg.0.log and Xorg -config exits without
complaining about anything.

I followed the guide at:
http://www.gentoo.org/doc/en/xorg-config.xml#using_startx

so I completed all steps mentioned there.

at this point I have no idea how to debug, get information what is
going an, or what causes the problem - there are no error messages
and no log left. the only thing I see is a black screen, a blinking cursor
at the top left corner for a moment and a completely black screen after wards
and laptop the responds to nothing as a result. the only way that i could
get out of this was to hard-reboot using the power button.

please post here if you have any ideas what this could be or
how can it be figured out what causes the crash.

at some point i tried:
emerge -e xorg-server

but this changed nothing and startx crashes again in the same way.

thanks in advance,
~levon

Duncan 08-05-2010 07:51 AM

startx / X -config /root/xorg.conf.new crash on T410 intel Arrandale (custom kernel)
 
Levon Ghazaryan posted on Wed, 04 Aug 2010 13:27:18 +0200 as excerpted:

> on 2.6.34-r1, ThinkPad T410 with Intel Arrandale with a custom kernel
> the laptop freezes on startx or X -retro -config /root/xorg.conf.new
> (with a fresh created xorg.conf.new with Xorg -config).
>
> as this happens I'm not able to switch the tty, the laptop doesn't
> respond to ping and caps lock is constantly blinking.

Won't even respond to ping. That's definitely a hard lockup. =:^(

Unfortunately, such lockups often don't leave a lot in the way of logs,
because whatever triggers them panics the kernel to the point it can't
trust itself to write log entries (good thing too, at that point it's
generally so confused who knows where it might scribble on the disk,
precisely the reason it doesn't write anything if it doesn't trust itself
to do so correctly) detailing what went wrong.

But you can tell it doesn't respond to pings, which presumably means you
have at least one other machine available. It's often possible in such
cases to take a log remotely, and sometimes get an entry with the problem
via the remote connection as the kernel's going down, since the kernel
knows that writing to a network connection can't scribble where it's not
supposed to on the disk, like trying to right a log entry to disk might do
at that point.

Unfortunately I don't know those details, as it's only relatively recently
that I have both a netbook and a desktop, to be able to do such things,
and I've not actually done them yet. But I do know it's possible, and you
can look into it further if you find it necessary.

> there is no error in /var/log/Xorg.0.log

One wouldn't be expected in such a case, for the reasons I mention above.

> and Xorg -config exits without complaining about anything.

=:^(

> I followed the guide at:
> http://www.gentoo.org/doc/en/xorg-config.xml#using_startx
>
> so I completed all steps mentioned there.
>
> at this point I have no idea how to debug, get information what is going
> an, or what causes the problem - there are no error messages and no log
> left. the only thing I see is a black screen, a blinking cursor at the
> top left corner for a moment and a completely black screen after wards
> and laptop the responds to nothing as a result. the only way that i
> could get out of this was to hard-reboot using the power button.
>
> please post here if you have any ideas what this could be or how can it
> be figured out what causes the crash.
>
> at some point i tried:
> emerge -e xorg-server
>
> but this changed nothing and startx crashes again in the same way.

Altho my netbook has Intel graphics, I've not had it as long as my main
machine (AMD, several generations of Radeon graphics), and know rather
less about Intel graphics than I do Radeons.

However, both the Radeon and Intel drivers now (with 2.6.34 on the Radeon
side, I believe earlier for the Intel side) default to KMS, kernel mode
setting, as opposed to the former UMS, user (xorg) mode setting. KMS runs
fine on both my main AMD/Opteron/Radeon machine and my Intel/Atom based
Acer Aspire One netbook (ICH7 family chipset, 945GME graphics, rev 03),
but I'm running ~arch on both (~amd64 on the workstation, ~x86 on the
netbook), and in fact, running the x11 overlay as well, so getting X
related packages before they're even in the main tree. With a technology
as new as is KMS, the newest versions are very likely more stable than
earlier versions. as the technology itself is still developing and
stabilizing. FWIW, xorg-server-1.8.2 (from the x11 overlay), on both
machines, here, and the xf86-video-*, drm, mesa, and other such packages,
are equally current, some in-tree already, some from the overlay.

I'd therefore suggest you look into the KMS/UMS thing. That may well be
your problem. I believe there's a kernel parameter you can add in grub,
to turn off KMS and see if that's it. nokms or no-kms or some such, I've
not had to use it so IDR for sure.

Actually, now that I think of it, I believe I've read about a particular
Intel chipset, the ICH-5 series, IIRC, that has had very serious problems
with KMS, and either has /just/ fixed them (would likely be with the
2.6.35 kernel and/or xorg-1.8 or later and/or comparable xf86-video-intel
driver, the fix would be that fresh, tho of course some of us have been
running that stuff for months, now, so it's not necessarily /that/ new),
or they're still affected and won't yet work with kms at all. I've no
clue where Arrandale is relative to ICH-5, but if that's it, you're very
likely affected and need the nokms boot parameter, at least with xorg
earlier than the very latest ~arch and x11 overlay stuff, and with kernels
older than the just release 2.6.35, and might still need it with them.

--
Duncan - List replies preferred. No HTML msgs.
"Every nonfree program has a lord, a master --
and if you use the program, he is your master." Richard Stallman


All times are GMT. The time now is 08:03 PM.

VBulletin, Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2007, Crawlability, Inc.